X
Tap here to go to the mobile version of the site.

Support Forum

Disable desktop notifications for a site

Posted

With the new update, Google Music now sends desktop notifications. Firefox asked me if I wanted to enable them, and I accepted, but now I find them very annoying. How can I turn them off? I searched in the options but I didn't find anything

With the new update, Google Music now sends desktop notifications. Firefox asked me if I wanted to enable them, and I accepted, but now I find them very annoying. How can I turn them off? I searched in the options but I didn't find anything

Chosen solution

You can reset this to the default (or outright disallow it) on a per-site basis by right-clicking somewhere in a blank spot of the site (or pressing Ctrl-I on Windows or Cmd-I on Mac) and then selecting "View Page Info" from the opening menu. This opens a window with a "Permissions" tab. I that, scroll down to the very bottom until you see "Show Notifications" as the third-to-last entry. Either reset that to the default, or just select "Block".

Additionally, the notifications are currently a labs feature in Google Music, so you can also disable them by going into the Google Music Labs preferences and disabling them.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Fornisce informazioni sul browser web di default
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • QuickTime Plugin consente di visualizzare una grande varietà di contenuti multimediali nelle pagine Web. Per maggiori informazioni, visita il sito QuickTime.
  • Unity Web Player version 4.3.1f1. (c) 2013 Unity Technologies ApS. All rights reserved.
  • 20-20 Technologies - 20-20 3D Viewer for IKEA v5.0.94.1

Application

  • Firefox 28.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0
  • Support URL: https://support.mozilla.org/1/firefox/28.0/Darwin/it/

Extensions

  • Ctrl-Tab 0.21.1 (ctrl-tab@design-noir.de)
  • Dizionario italiano 3.3.2 (it-IT@dictionaries.addons.mozilla.org)
  • Dummy Lipsum 3.0.0 (dummylipsum@sogame.cat)
  • Export Cookies 1.2 (exportcookies@aag)
  • Firebug 1.12.8 (firebug@software.joehewitt.com)
  • FireGestures 1.8.6 (firegestures@xuldev.org)
  • LastPass 3.1.1 (support@lastpass.com)
  • Pocket 3.0.4 (isreaditlater@ideashower.com)
  • Rainbow 1.6 (rainbow@colors.org)
  • Sage 1.5.2 ({a6ca9b3b-5e52-4f47-85d8-cca35bb57596})
  • Selenium IDE 2.5.0 ({a6fd85ed-e919-4a43-a5af-8da18bda539f})
  • Selenium IDE: C# Formatters 2.5.0 (csharpformatters@seleniumhq.org)
  • Selenium IDE: Java Formatters 2.5.0 (javaformatters@seleniumhq.org)
  • Selenium IDE: Python Formatters 2.5.0 (pythonformatters@seleniumhq.org)
  • Selenium IDE: Ruby Formatters 2.5.0 (rubyformatters@seleniumhq.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Web Developer 1.2.5 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • YouTube Caption Downloader 2.3 (captiondownloader@hiephm.com)
  • FoxyProxy Basic 3.2.4 (foxyproxy-basic@eric.h.jung) (Inactive)
  • Greasemonkey 1.15 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • NoScript 2.6.8.20 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)
  • Wappalyzer 3.0.4 (wappalyzer@crunchlabz.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x fe0
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GTX 660M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517
  • browser.startup.homepage: about:newtab
  • browser.startup.homepage_override.buildID: 20140314220517
  • browser.startup.homepage_override.mstone: 28.0
  • browser.tabs.warnOnClose: False
  • dom.disable_open_during_load: False
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 28.0
  • font.internaluseonly.changed: False
  • keyword.URL: http://it.search.yahoo.com/search?fr=spigot-adr-ffmac&ei=utf-8&ilc=12&type=997063&p=
  • media.webaudio.enabled: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1398794313
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.silverlight: 0
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • security.tls.version.max: 1
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1398237062

Misc

  • User JS: No
  • Accessibility: No
HARISH KUMAWAT 3 solutions 61 answers

Helpful Reply

Type about:config and filter for plugins.hide_infobar_for_outdated_plugin and double-left-click or right-click and toggle this to true

Type about:config and filter for plugins.hide_infobar_for_outdated_plugin and double-left-click or right-click and toggle this to true
Till Schneidereit 4 solutions 16 answers

Chosen Solution

You can reset this to the default (or outright disallow it) on a per-site basis by right-clicking somewhere in a blank spot of the site (or pressing Ctrl-I on Windows or Cmd-I on Mac) and then selecting "View Page Info" from the opening menu. This opens a window with a "Permissions" tab. I that, scroll down to the very bottom until you see "Show Notifications" as the third-to-last entry. Either reset that to the default, or just select "Block".

Additionally, the notifications are currently a labs feature in Google Music, so you can also disable them by going into the Google Music Labs preferences and disabling them.

You can reset this to the default (or outright disallow it) on a per-site basis by right-clicking somewhere in a blank spot of the site (or pressing Ctrl-I on Windows or Cmd-I on Mac) and then selecting "View Page Info" from the opening menu. This opens a window with a "Permissions" tab. I that, scroll down to the very bottom until you see "Show Notifications" as the third-to-last entry. Either reset that to the default, or just select "Block". Additionally, the notifications are currently a labs feature in Google Music, so you can also disable them by going into the Google Music Labs preferences and disabling them.