Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

How to get tabs under adressbar, if setting "browser.tabs.onTop" to "false" does not work?

  • 21 replies
  • 15 have this problem
  • 12102 views
  • Last reply by Madasan

more options

I know that firefox once put the tabs on top, but I had that fixed with setting in "about:config" the value for "browser.tabs.onTop" to "false". Now, after upgrading Firefox to v.29 this entry is still set to the false value, however, I can't get the tabs below the adressbar (which is super annoying). Any ideas how to resolve this?

Chosen solution

Note that you can also do this easily with code in userChrome.css as basically you only need to give the Tab bar a higher -moz-box-ordinal-group value (most toolbars have a default 1 to show them in DOM order).

Add code to the userChrome.css file below the default @namespace line.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

#TabsToolbar {
	-moz-box-ordinal-group: 10000 !important;
}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

Read this answer in context 👍 2

All Replies (1)

more options

Hi henryfm,

I'm sorry that you are unhappy with the new Firefox design. People helping here are volunteers and they are doing the best they can to help out Firefox users so please don't take it out on them :) If you feel strongly about the new changes I would suggest you to provide feedback on https://input.mozilla.org/feedback for the people who decided on the changes to actually see it.

Please keep in mind that Firefox is a work in progress and your feedback is very valuable for us to understand what can be done better!

  1. 1
  2. 2