X
Tap here to go to the mobile version of the site.

Support Forum

Remove no theme support error message

Posted

I'm noticing that now under Firefox 29, you can install themes (personas) in the private browsing mode. However, you still get an error message saying this isn't possible despite the fact that it is. How, then, do you disable the annoying error message?

Why the browser wouldn't support changing themes in private browsing I'll never understand. After all, "private browsing" means nothing more than it keeps no history of what you've done. Before I went to the private browsing mode I deleted all histories anyway, so what's the big deal?

I'm noticing that now under Firefox 29, you can install themes (personas) in the private browsing mode. However, you still get an error message saying this isn't possible despite the fact that it is. How, then, do you disable the annoying error message? Why the browser wouldn't support changing themes in private browsing I'll never understand. After all, "private browsing" means nothing more than it keeps no history of what you've done. Before I went to the private browsing mode I deleted all histories anyway, so what's the big deal?

Modified by humbz

Additional System Details

Application

  • User Agent: Mozilla/5.0 (masking-agent; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17184 solutions 155303 answers

See:

  • bug 854126 - Lift the lightweight theme restrictions for private windows on Windows and Linux

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

See: *[https://bugzilla.mozilla.org/show_bug.cgi?id=854126 bug 854126] - Lift the lightweight theme restrictions for private windows on Windows and Linux <i>Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>

Question owner

Kindly re-read my original post. My question regarded the fact that I was getting an error message despite the fact that changing personas in private browsing is now possible under FF29.

Under previous versions I was under the impression this was a policy similar to that of other browsers that don't allow add-ons in private browsing. Never did I ever suspect this was a bug. I even searched before posting and found nothing.

Therefore, my original question remains - is there a way to simply disable the error message despite bug 854126 being fixed?

Kindly re-read my original post. My question regarded the fact that I was getting an error message despite the fact that changing personas in private browsing is now possible under FF29. Under previous versions I was under the impression this was a policy similar to that of other browsers that don't allow add-ons in private browsing. Never did I ever suspect this was a bug. I even searched before posting and found nothing. Therefore, my original question remains - is there a way to simply disable the error message despite '''bug 854126''' being fixed?