X
Tap here to go to the mobile version of the site.

Support Forum

How do I play .swf (shock wave flash) from computer?

Posted

The problem is that whenever I try to open .swf files with firefox from my computer, it ask me to either open it with a third party software or to save it on my computer. It should just use its shock wave flash plugin and play the .swf itself. When I did some search on the internet, I found out I was not the only with this problem, but I couldn't find any solution working for me.

Here are some informations that could help you. - My O.S. is Ubuntu 14.04 and my firefox version is 28.0. - firefox can play swf file from web without any problem. - Here is how I installed the plugin flash player : 1 - Downloaded .tar.gz from http://get.adobe.com/fr/flashplayer/.

                                                                                2 - Followed README instructions.
                                                                                3 - From now on, swf content did play fine within firefox while web browsing.

- I followed the instructions from this page "http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions" without success.

Thanks for reading and trying to help,

Little Nooby

The problem is that whenever I try to open .swf files with firefox from my computer, it ask me to either open it with a third party software or to save it on my computer. It should just use its shock wave flash plugin and play the .swf itself. When I did some search on the internet, I found out I was not the only with this problem, but I couldn't find any solution working for me. Here are some informations that could help you. - My O.S. is Ubuntu 14.04 and my firefox version is 28.0. - firefox can play swf file from web without any problem. - Here is how I installed the plugin flash player : 1 - Downloaded .tar.gz from http://get.adobe.com/fr/flashplayer/. 2 - Followed README instructions. 3 - From now on, swf content did play fine within firefox while web browsing. - I followed the instructions from this page "http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions" without success. Thanks for reading and trying to help, Little Nooby

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The Videos 3.10.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

John99 971 solutions 13138 answers

You seem to have achieved your objective if Firefox is offering to save the File. Playing the file you have on the computer using Ubuntu or any other OS is a separate issue and not within the scope of this forum.

Most webpages with FlashPlayer content probably intend the content to be played from the webpage. Are you able to do that ?

Note on some Firefox versions you may need to click to activate the Flasplayer for a website. Also you must ensure that you do have the Flashplayer plugin active.
The test page should confirm whether or not Flashplayer is working See also

Some FlashContent will not be designed to be downloaded. There are however addons available. For that matter there are also addons to block FlashPlayer content, as often it is bandwidth using Adverts.

You seem to have achieved your objective if Firefox is offering to save the File. Playing the file you have on the computer using Ubuntu or any other OS is a separate issue and not within the scope of this forum. Most webpages with FlashPlayer content probably intend the content to be played from the webpage. Are you able to do that ? * Visit this test page http://www.adobe.com/software/flash/about/ Note on some Firefox versions you may need to click to activate the Flasplayer for a website. Also you must ensure that you do have the Flashplayer plugin active. <br /> The test page should confirm whether or not Flashplayer is working See also *[[Flash Plugin - Keep it up to date and troubleshoot problems]] Some FlashContent will not be designed to be downloaded. There are however addons available. For that matter there are also addons to block FlashPlayer content, as often it is bandwidth using Adverts. * See for instance this search <br /> https://addons.mozilla.org/firefox/search/?q=flash&platform=Linux

Question owner

Maybe I wasn't clear enough, so here is some more information : I did achieve to do it in a previous configuration (Now It's a new install, from zero).

Let's explain what I do from the start : 1 - I go to some website with flash content, let's say : http://www.tv-reveil.com/index1.php?id=227&name=raidenx 2 - tools > page info > media > I look the grey entry with swf extension and select it. Save as... Now I have it on my computer. 3 - I right click on the file on my computer, choose to open the .swf file I just downloaded, and now Firefox opens a page with the game totally working.

Thanks again for you time and help.

Maybe I wasn't clear enough, so here is some more information : '''I did achieve to do it in a previous configuration''' (Now It's a new install, from zero). Let's explain what I do from the start : 1 - I go to some website with flash content, let's say : http://www.tv-reveil.com/index1.php?id=227&name=raidenx 2 - tools > page info > media > I look the grey entry with swf extension and select it. Save as... Now I have it on my computer. 3 - I right click on the file on my computer, choose to open the .swf file I just downloaded, and now Firefox opens a page with the game totally working. Thanks again for you time and help.
John99 971 solutions 13138 answers

Sorry no idea how to solve that but it is a Ubuntu or Flashplayer problem not a Firefox problem if you are trying to stream content direct in Ubuntu.

Not too sure what you are trying to do now. Run an embeded Flashpalyer direct on your own computer and open it with Firefox ?

As I said initially this sort of content is designed to be used from the Webpage.

Sorry no idea how to solve that but it is a Ubuntu or Flashplayer problem not a Firefox problem if you are trying to stream content direct in Ubuntu. Not too sure what you are trying to do now. Run an embeded Flashpalyer direct on your own computer and open it with Firefox ? As I said initially this sort of content is designed to be used from the Webpage.

Question owner

-(

I don't know much about webpage programming but I did some search and ended up with that code : <meta charset="utf-8"> <title>Game holder</title> <object data="raidenx.swf" height="600" type="application/x-shockwave-flash" width="800"> <param name="game" value="raidenx.swf"> <param name="quality" value="high"> </object>

It does more or less what I wanted to do (It's just that now it's ugly but I can work that out). Firefox was able to do that without my help and better in the past :-s.

:-( I don't know much about webpage programming but I did some search and ended up with that code : <!DOCTYPE html> <html> <head> <meta charset="utf-8" /> <title>Game holder</title> </head> <body> <object type="application/x-shockwave-flash" data="raidenx.swf" width="800" height="600"> <param name="game" value="raidenx.swf" /> <param name="quality" value="high" /> </object> </body> </html> It does more or less what I wanted to do (It's just that now it's ugly but I can work that out). Firefox was able to do that without my help and better in the past :-s.
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

You can never be sure that such a saved SWF file can run without needing extra file that are usually downloaded from internet. Some of those SWF files have a flashvar parameter in their embed or object tag to specify such additional parameters and in that case you wont be able to run this file unless you would save the page with this code and not only the SWF file.

Did you try to save the page with this Flash object instead?

You can try to open a .swf file from internet in Firefox (use the location bar) to make Firefox create a download action for a SWF file.

Note that most Linux distributions install a standalone Flash player (OpenSUSE does) that you can use instead of Firefox.

You can never be sure that such a saved SWF file can run without needing extra file that are usually downloaded from internet. Some of those SWF files have a flashvar parameter in their embed or object tag to specify such additional parameters and in that case you wont be able to run this file unless you would save the page with this code and not only the SWF file. Did you try to save the page with this Flash object instead? You can try to open a .swf file from internet in Firefox (use the location bar) to make Firefox create a download action for a SWF file. Note that most Linux distributions install a standalone Flash player (OpenSUSE does) that you can use instead of Firefox.
xambroz 0 solutions 1 answers

Hello, I have encountered the same problem (Firefox 29, Linux, Fedora 20). When I access the swf files online - they open in Firefox as flash application spanned over whole window without any problems (for example http://edmullen.net/test/poopboy.swf ). But when you store the files locally (for example file:///tmp/poopboy.swf) , then Firefox behaves differently and offers options for download/execute.

It seems that it has something to do with the mimeType.rdf as mentioned in other support case (case 975971 ), but deleting/resetting the file as instructed in http://kb.mozillazine.org/mimeTypes.rdf didn't help. It seems there are 2 mimeTypes set and one is used when accessing online and the other one when accessing in the filesystem.

If you open Firefox Properties / tab Applications, search for "shock" and you will actually find 2 mimeType entries:

  • SWF file - when set to "Use Shockwave Flash (in Firefox)" this one is responsible for playing it as Flash when accessing online
  • Shockwave Flash file - settings of this entry is used when accessing on the local drive, unfortunately I have not found a way how to set this one to direct it to play in the flash plug-in directly in Firefox. Setting this to open in Firefox (/usr/bin/firefox in my case) resulted in infinite loop opening new tabs.

Best regards Michal Ambroz

Hello, I have encountered the same problem (Firefox 29, Linux, Fedora 20). When I access the swf files online - they open in Firefox as flash application spanned over whole window without any problems (for example [http://edmullen.net/test/poopboy.swf http://edmullen.net/test/poopboy.swf] ). But when you store the files locally (for example file:///tmp/poopboy.swf) , then Firefox behaves differently and offers options for download/execute. It seems that it has something to do with the mimeType.rdf as mentioned in other support case ([https://support.mozilla.org/en-US/questions/975971 case 975971] ), but deleting/resetting the file as instructed in [http://kb.mozillazine.org/mimeTypes.rdf http://kb.mozillazine.org/mimeTypes.rdf] didn't help. It seems there are 2 mimeTypes set and one is used when accessing online and the other one when accessing in the filesystem. If you open Firefox '''Properties''' / tab '''Applications''', search for "shock" and you will actually find 2 mimeType entries: * '''SWF file''' - when set to "Use Shockwave Flash (in Firefox)" this one is responsible for playing it as Flash when accessing online * '''Shockwave Flash file''' - settings of this entry is used when accessing on the local drive, unfortunately I have not found a way how to set this one to direct it to play in the flash plug-in directly in Firefox. Setting this to open in Firefox (/usr/bin/firefox in my case) resulted in infinite loop opening new tabs. Best regards Michal Ambroz

Modified by xambroz

cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

This works for me on Linux when I drag a file in a Firefox tab or open the file via File Open file or the 3-bar Firefox menu button.

Note that on Linux you usually have a standalone Flash player available via the repositories of the Linux distribution.

You can check the MIME types and file extension in locations like this:

/usr/share/mime/application/
/usr/share/applications/
~/.local/share/mime/
~/.local/share/applications/
This works for me on Linux when I drag a file in a Firefox tab or open the file via File Open file or the 3-bar Firefox menu button. Note that on Linux you usually have a standalone Flash player available via the repositories of the Linux distribution. You can check the MIME types and file extension in locations like this: /usr/share/mime/application/ /usr/share/applications/ ~/.local/share/mime/ ~/.local/share/applications/

Modified by cor-el

Malaise 0 solutions 2 answers

I have exactly the same issue as "xambroz" with Ubuntu 14.04 fresh install firefox 30.0 and a brand new user account. I have 2 entries in the application menu and the one for local files, "Shockwave flash file", only allows "Always ask", "Save file", "Use Parole" and "Use other...". No way to select "Use Shockwave Flash (in Firefox)" as it is set for the entry "SWF file".

As opposed to "cor-el", opening the "Open File" of the 3-bar menu or dragging do not work for me.

Please help us to fix this issue.

Thanks in advance

I have exactly the same issue as "xambroz" with Ubuntu 14.04 fresh install firefox 30.0 and a brand new user account. I have 2 entries in the application menu and the one for local files, "Shockwave flash file", only allows "Always ask", "Save file", "Use Parole" and "Use other...". No way to select "Use Shockwave Flash (in Firefox)" as it is set for the entry "SWF file". As opposed to "cor-el", opening the "Open File" of the 3-bar menu or dragging do not work for me. Please help us to fix this issue. Thanks in advance
DrivebyAnswerer 0 solutions 1 answers

Helpful Reply

It looks like no one's provided you with an actual solution, so let me give you what I found to work for me on my Lubuntu 14.04: fixing systemwide MIME types from application/vnd.adobe.flash.movie to application/x-shockwave flash. With that change and a restarted browser, it worked.

I got the answer from http://askubuntu.com/questions/478169/why-cant-firefox-run-local-swf-files which has more detail; the first link in the answer had a script that worked after light editing.

It looks like no one's provided you with an actual solution, so let me give you what I found to work for me on my Lubuntu 14.04: fixing systemwide MIME types from application/vnd.adobe.flash.movie to application/x-shockwave flash. With that change and a restarted browser, it worked. I got the answer from [http://askubuntu.com/questions/478169/why-cant-firefox-run-local-swf-files http://askubuntu.com/questions/478169/why-cant-firefox-run-local-swf-files] which has more detail; the first link in the answer had a script that worked after light editing.
Malaise 0 solutions 2 answers

Helpful Reply

Fixing systemwide MIME types from application/vnd.adobe.flash.movie to application/x-shockwave-flash works for me. Many thanks M. DrivebyAnswerer

Fixing systemwide MIME types from application/vnd.adobe.flash.movie to application/x-shockwave-flash works for me. Many thanks M. DrivebyAnswerer