Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

taskbar icon right click "tasks" menu gone

  • 8 replies
  • 17 have this problem
  • 248 views
  • Last reply by darklink46

more options

When I right clicked on the taskbar icon, I used to get several options including a section entitled tasks. However, since about two days ago, I now only get three options of Mozilla Firefox, Unpin this program from the taskbar and close window. I don't know where the options of Open a new tab, Open a new window etc. have gone. I haven't altered any settings in about:config and have tried reinstalling firefox with no success. If there is a possible fix, please help.

When I right clicked on the taskbar icon, I used to get several options including a section entitled tasks. However, since about two days ago, I now only get three options of Mozilla Firefox, Unpin this program from the taskbar and close window. I don't know where the options of Open a new tab, Open a new window etc. have gone. I haven't altered any settings in about:config and have tried reinstalling firefox with no success. If there is a possible fix, please help.

Chosen solution

Edit, I rechecked in about:config just now and found that browser.taskbar.lastgroupid keeps reverting to user set in bold. Im certain I reset it the first time but I did it again for the sake of it and at least for now I seem to have the right click menu back complete with tasks and frequent. Thanks so much Gingerbread Man and anybody else who posted suggestions. Your a lifesaver!

Read this answer in context 👍 2

All Replies (8)

more options

Try the following.

  1. Right-click the icon and choose "Unpin this program from the taskbar".
  2. Exit Firefox.
  3. Launch Firefox.
  4. Right-click the icon and choose "Pin this program to the taskbar".
more options

Hi,

Thanks for quick response but unfortunately no luck.

If any other ideas, please don't hesitate to message me.

more options

Please try this 1.Right click on the task bar 2.click Properties 3.under the 'jump list' bar, increase the 'number of items to display ' to some number like 10.

see if it works All the Best !

more options

Hi

Thanks for response Kuncheria, I checked the taskbar properties and the 'number of items to display' was already set to 10. I tried increasing it to 20, but without success. Thanks for the suggestion anyway.

more options

Just to add some more information, this jumplist problem only seems to occur with the firefox icon. I get a much larger list of options for skype and windows explorer for example.

more options
  1. Type about:config into the address bar and press Enter.
  2. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  3. In the search box, type taskbar
  4. In the search results, if any of the entries appear in bold text with the status "user set", right-click each one and choose Reset.
  1. If Firefox is currently pinned to the taskbar, once again unpin it.
  2. Open Windows Explorer. Paste the following in the address bar and press Enter:
    • %AppData%\Microsoft\Windows\Recent\AutomaticDestinations\
  3. If you have a file related to Firefox, delete it. You may be able to determine which file belongs to which application if you open it in Notepad (most of it will be unreadable gibberish). Otherwise, try prefixing the name of every file there with backup-
  4. Open Default Programs. Select Internet Explorer, then click the "Set this program as default button"
  5. In Firefox, open Options - Advanced - General. Click the "Make Firefox the default browser" button there. (Setting Firefox as your default browser also pins it to the taskbar)
  6. Log off Windows, then back on.
  7. If that doesn't help, I have no further suggestions. Remember to rename your .automaticDestinations-ms files back the way they were.
more options

Hi Gingerbread Man

Again thanks for your quick response and suggestions, but I still don't seem to be having any luck. Would it be worth attempting to revert to an older firefox version to see if it changes anything?

more options

Chosen Solution

Edit, I rechecked in about:config just now and found that browser.taskbar.lastgroupid keeps reverting to user set in bold. Im certain I reset it the first time but I did it again for the sake of it and at least for now I seem to have the right click menu back complete with tasks and frequent. Thanks so much Gingerbread Man and anybody else who posted suggestions. Your a lifesaver!