Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I upgraded to firfox 28 and my internet download manager 6.18 (IDM cc 7.3.65) won't work any more?!!!!!

more options

please help and I don't want to upgrade my IDM version

All Replies (3)

more options

Please update IDM, or contact them for support.

more options

This happens on every single FF update; IDM is always disabled for some reason. Yet, problems like: 'Slow shut downs lead to 'Firefox is already running' warning' go unaddressed for years on end while they focus on the next, new way, to disable it next month/update. Why should the user have to contact IDM for your browser? They do not manage your updates. They didn't make changes to your browser. Would you suggest if someone got a cold cup of coffee, or a wrong order, at Starbucks that they go to Wendy's and ask for support on how to get a new can of beep for their horn? Can see that 2684 people have searched for and viewed this topic with 94 taking the time to click that they're having this problem, too. Doesn't seem to ever matter, however.

more options

"Why should the user have to contact IDM for your browser? " They made the add-on that is the "hook" into Firefox, therefore it is up to IDM to keep their stuff up-to-date with Firefox.

As far as "coffee", it's hot, so don't spill it on your thighs or hold the container between your thighs. And if you get burned, sue McDonald's.