X
Tap here to go to the mobile version of the site.

Support Forum

stop playing mp3 in new tab

Posted

I want to open mp3 files in my player of choice. Firefox opens a new tab and plays them instead. Did the "always ask" stuff and that doesn't work as explained in other threads. Tried changing the "media.windows" etc in the about:config to false. Did not help at all! I know I can "save as". I'd rather use firefox the way I have for the past years. A button on a website that is labelled "Download" should allow me to open the file in my player of choice. Instead it opens to a new tab and begins playing (if I wanted that I would have clicked the "play" button). Gave up hope and installed Chrome - and I have the same problem! Would rather stick with firefox if I can solve this minor problem (it IS a PITA!) Please help me!

)
I want to open mp3 files in my player of choice. Firefox opens a new tab and plays them instead. Did the "always ask" stuff and that doesn't work as explained in other threads. Tried changing the "media.windows" etc in the about:config to false. Did not help at all! I know I can "save as". I'd rather use firefox the way I have for the past years. A button on a website that is labelled "Download" should allow me to open the file in my player of choice. Instead it opens to a new tab and begins playing (if I wanted that I would have clicked the "play" button). Gave up hope and installed Chrome - and I have the same problem! Would rather stick with firefox if I can solve this minor problem (it IS a PITA!) Please help me! :)

Chosen solution

Imustbestupid wrote:

I did set 'media.windows-media-foundation.play-stand-alone' to false.

Yes, that preference doesn't work anymore.

Set media.directshow.enabled to false to disable built-in support for MP3 files. This might also affect other things, but I don't know what. Playing MP4 (H.264) files still works with this preference set to false.

Imustbestupid wrote:

Thanks for the response.

Thank you for the links. This issue turned up before, but I was never able to find MP3 links without Content-Disposition: attachment, so I couldn't reproduce the problem.

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • 5.1.30214.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

Gingerbread Man 403 solutions 1537 answers

At the moment, Firefox doesn't respect your preference for MP3 and MP4 files. This is a known issue (bug 861090).

Imustbestupid wrote:

Tried changing the "media.windows" etc in the about:config to false. Did not help at all!

If you set media.windows-media-foundation.play-stand-alone to false in about:config, then you should get a download prompt when clicking a direct link to an MP3 file. Do you have an example of a link that still opens in Firefox?

Imustbestupid wrote:

A button on a website that is labelled "Download" should allow me to open the file in my player of choice.

To force a download prompt, the site owner must send the Content-Disposition: attachment header. Example:

At the moment, Firefox doesn't respect your preference for MP3 and MP4 files. This is a known issue (bug 861090). ''Imustbestupid wrote:'' Tried changing the "media.windows" etc in the about:config to false. Did not help at all! If you set ''media.windows-media-foundation.play-stand-alone'' to '''false''' in [http://kb.mozillazine.org/About:config about:config], then you should get a download prompt when clicking a direct link to an MP3 file. Do you have an example of a link that still opens in Firefox? ''Imustbestupid wrote:'' A button on a website that is labelled "Download" should allow me to open the file in my player of choice. To force a download prompt, the site owner must send the ''Content-Disposition: attachment'' header. Example: * http://freepd.com/Classical/Allemande.mp3

Question owner

Thanks for the response. I did set 'media.windows-media-foundation.play-stand-alone' to false. I just rechecked again today and it is still false.

Here are two sites that give an example of the problem:

http://www.thisamericanlife.org/radio-archives/episode/521/bad-baby?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+talpodcast+%28This+American+Life+Podcast%29

and

http://www.econtalk.org/

When I hit download on either it opens a tab and begins playing the file.

It started doing this recently (within the last week). Thanks again for taking the time to respond.

Thanks for the response. I did set 'media.windows-media-foundation.play-stand-alone' to false. I just rechecked again today and it is still false. Here are two sites that give an example of the problem: [http://example.com http://www.thisamericanlife.org/radio-archives/episode/521/bad-baby?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+talpodcast+%28This+American+Life+Podcast%29] and http://www.econtalk.org/ When I hit download on either it opens a tab and begins playing the file. It started doing this recently (within the last week). Thanks again for taking the time to respond.
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157335 answers

That is an mp3 file send as Content-Type: audio/mpeg

I get a download dialog if I disable the HTML5 media player and possible plugins that can play MP3 files.

That is an mp3 file send as Content-Type: audio/mpeg I get a download dialog if I disable the HTML5 media player and possible plugins that can play MP3 files.
Gingerbread Man 403 solutions 1537 answers

Chosen Solution

Imustbestupid wrote:

I did set 'media.windows-media-foundation.play-stand-alone' to false.

Yes, that preference doesn't work anymore.

Set media.directshow.enabled to false to disable built-in support for MP3 files. This might also affect other things, but I don't know what. Playing MP4 (H.264) files still works with this preference set to false.

Imustbestupid wrote:

Thanks for the response.

Thank you for the links. This issue turned up before, but I was never able to find MP3 links without Content-Disposition: attachment, so I couldn't reproduce the problem.

''Imustbestupid wrote:'' I did set 'media.windows-media-foundation.play-stand-alone' to false. Yes, that preference doesn't work anymore. Set ''media.directshow.enabled'' to '''false''' to disable built-in support for MP3 files. This might also affect other things, but I don't know what. Playing MP4 (H.264) files still works with this preference set to false. ''Imustbestupid wrote:'' Thanks for the response. Thank you for the links. This issue turned up before, but I was never able to find MP3 links without ''Content-Disposition: attachment'', so I couldn't reproduce the problem.

Question owner

That worked for me Gingerbread Man! Thanks!

I'll report back if there are any side effects, etc. Weee!

That worked for me Gingerbread Man! Thanks! I'll report back if there are any side effects, etc. Weee!