X
Tap here to go to the mobile version of the site.

Support Forum

I lose the minimize, restore and close down buttons in the top right corner when removing the Menu Bar.

Posted

I am using Firefox 28.0 on my Windows 7 64-bit PC. I would like to remove ONLY the menu bar and keep the orange Firefox tab. But when I uncheck the Menu Bar box, I not only lose the menu bar, I lose the three buttons on the very right of the screen as well - the minimize button, the maximize/restore down button, and the red 'X' close button. The space where these buttons ought to be is black. When I recheck the Menu Bar box, those three buttons on the right of the screen reappear!

I would like to know how I am to remove the Menu Bar but keep the minimize button, the maximize/restore down button and the red 'X' close button.

Eagerly waiting for your reply! Thanks much! ♥

I am using Firefox 28.0 on my Windows 7 64-bit PC. I would like to remove ONLY the menu bar and keep the orange Firefox tab. But when I uncheck the Menu Bar box, I not only lose the menu bar, I lose the three buttons on the very right of the screen as well - the minimize button, the maximize/restore down button, and the red 'X' close button. The space where these buttons ought to be is black. When I recheck the Menu Bar box, those three buttons on the right of the screen reappear! I would like to know how I am to remove the Menu Bar but keep the minimize button, the maximize/restore down button and the red 'X' close button. Eagerly waiting for your reply! Thanks much! ♥

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 28.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
  • Support URL: https://support.mozilla.org/1/firefox/28.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! Online Security 9.0.2016.82 (wrc@avast.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 635
  • adapterDescription2:
  • adapterDeviceID: 0x1280
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-26-2013
  • driverDate2:
  • driverVersion: 9.18.13.1147
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 635 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517
  • browser.startup.homepage: https://www.yahoo.com/
  • browser.startup.homepage_override.buildID: 20140314220517
  • browser.startup.homepage_override.mstone: 28.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 28.0
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158975 answers

You can try to disable hardware acceleration in Firefox (you need to close and restart Firefox).

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If you have the Firefox maximized then try a smaller window.

You can try to disable hardware acceleration in Firefox (you need to close and restart Firefox). *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If you have the Firefox maximized then try a smaller window.
oberz3 1 solutions 17 answers

Thank you cor-el, for your reply, but disabling "Use hardware acceleration when available" did not solve the problem. I unchecked that option as you suggested, closed Firefox, reopened Firefox, unchecked the box for "Menu Bar", and the top right corner of my screen containing the minimize, maximize/restore down button, and the red 'X' close buttons disappeared again leaving that space black.

It did not matter if I was using full screen or a smaller window.

???

Thank you cor-el, for your reply, but disabling "Use hardware acceleration when available" did not solve the problem. I unchecked that option as you suggested, closed Firefox, reopened Firefox, unchecked the box for "Menu Bar", and the top right corner of my screen containing the minimize, maximize/restore down button, and the red 'X' close buttons disappeared again leaving that space black. It did not matter if I was using full screen or a smaller window. ???
cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158975 answers

Did you try Safe Mode as well?

Did you try a different Windows theme?

Did you try Safe Mode as well? *https://support.mozilla.org/kb/Safe+Mode Did you try a different Windows theme?
oberz3 1 solutions 17 answers

Helpful Reply

Hello again, cor-el,

Thank you again for keeping up with me on this! I really appreciate your time!

I tried your suggestions of using Safe Mode and a different Windows theme (2 different ones to be exact), but neither solved the problem. Each time I tried disabling the Menu Bar, the same 3 buttons disappeared and I got nothing but black space. It doesn't even fill the space with any background I may have. It's just black.

Additionally, disabling all my personas did not help, either. :(

I've been using Firefox for years now and I've never had this issue. It's always worked flawlessly for me.

Hello again, cor-el, Thank you again for keeping up with me on this! I really appreciate your time! I tried your suggestions of using Safe Mode and a different Windows theme (2 different ones to be exact), but neither solved the problem. Each time I tried disabling the Menu Bar, the same 3 buttons disappeared and I got nothing but black space. It doesn't even fill the space with any background I may have. It's just black. Additionally, disabling all my personas did not help, either. :( I've been using Firefox for years now and I've never had this issue. It's always worked flawlessly for me.
cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158975 answers

Try to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

Try to create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
oberz3 1 solutions 17 answers

You know, I am just not that comfortable with creating a new profile only because I'm afraid I don't know what I'm doing and if I mess this up, I'm going to have more problems than I started with.

If creating a new profile is the only solution to not losing those three buttons at the top right corner of my screen, I think I'll deal with the extra tool bar.

Is there anything else I could try?

You know, I am just not that comfortable with creating a new profile only because I'm afraid I don't know what I'm doing and if I mess this up, I'm going to have more problems than I started with. If creating a new profile is the only solution to not losing those three buttons at the top right corner of my screen, I think I'll deal with the extra tool bar. Is there anything else I could try?
oberz3 1 solutions 17 answers

UPDATE: I just did a clean install of Firefox 28 - removed any and all program files my computer could find (I did not actively look for or remove/create new any Profile folders), ran CCleaner, and restarted my computer.

Downloaded Firefox from Mozilla.org and everything is now working as it should! I do NOT automatically have a Menu Bar (it's unchecked by default), and when I DO check the box and get the Menu Bar, I have no problem when I uncheck it - I do not lose my minimize/restore down/close buttons, and NO black space!

Whatever happened with the last install seems to have been corrected.

UPDATE: I just did a clean install of Firefox 28 - removed any and all program files my computer could find (I did not actively look for or remove/create new any Profile folders), ran CCleaner, and restarted my computer. Downloaded Firefox from Mozilla.org and everything is now working as it should! I do NOT automatically have a Menu Bar (it's unchecked by default), and when I DO check the box and get the Menu Bar, I have no problem when I uncheck it - I do not lose my minimize/restore down/close buttons, and NO black space! Whatever happened with the last install seems to have been corrected.