Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have problems controlling font size in this latest version of Firefox.

  • 13 replies
  • 5 have this problem
  • 906 views
  • Last reply by jscher2000

more options

Regardless what I do in Preferences->Content->Default font, including the "Advanced" option, the font size on any webpage goes to at least 120% automatically. For example: in Yahoo Mail, Inbox I reduce the zoom/font size using the Command plus "-" keys. The moment I click on another tab, or click on an email message, the contents of the other tab or the email message come up on reduced size for only one second, then it switches back to what it was before I reduced the zoom for the previous tab. I couldn't find a way in Firefox to set a default zoom for any or all websites.

I found an add-on on your website, it is called NoSquint, which apparently does just that. I installed it, configured it, but . . . I click on an email message, the contents of the message comes up for keeping the reduced zoom size. When I switch back to Inbox, for about one second the reduced zoom is on, but immediately it jumps back to the high zoom size.

Interestingly enough in the bottom right corner of the monitor the NoSquint zoom size shows the reduced zoom, even on the screen the zoom is high after switching back to the previous window. Only when I just start using the keyboard shortcut to reduce the zoom size clicking it once, the bottom corner indicator jumps back to show the correct zoom size. So, even this add-on doesn't work properly.

Not to be able to keep font sizes at "normal" level is a nuisance, since I use a 30" monitor (for photo restoration work in Photoshop and Lightroom), and fonts come up huge at 120% zoom. a 70-80% zoom would produce a much better font size on this large monitor.

All Replies (13)

more options

If you want the zoom to stop resetting when you go to another website, try the following:

  • Open Firefox.
  • In the address bar type about:config
  • Locate the browser.zoom.siteSpecific string
  • Set its value to False.
  • Close the about:config window and restart Firefox

You can also try setting the default zoom level with the Default FullZoom Level add-on.

You can also check out the Font Size And Zoom Mozilla help article.

more options

Note that you have two page zoom extensions: Zoom Page and NoSquint

The latter can set a global default zoom factor, so you can check its Options/Preferences in Tools > Add-ons > Extensions

more options

I've said it, and I am saying it again: problem not solved. I set the global zoom level for both text and image to 70%. I go in yahoo mail, Inbox. It is zoomed 70%, fonts are really small, smaller than I like, but I did it just to underline the problem I still have. I choose one email message, it pops up with the same 70% zoom level. So far, so good. When I go back to Inbox, the Inbox screen comes with the 70% zoom fonts for one second, then it zooms back instantly to 120% or 150%, whatever, the fonts are huge again. Using the Command+"0" shortcut the 70% global zoom comes back. Doing the same exercise, click on any email message to bring it up, then click on Inbox to bring the Inbox back, the same thing happens: one second the 70% zoom comes up, then instantly changes to the huge fonts. Again and again and again!!!! Please understand: there is a bug in Firefox, there is absolutely no other explanation for this misbehavior! How many more times do I have to explain this thing before you will really comprehend it! I am not a teenager who plays around with a computer to have fun. I had worked for decades as a Professional Engineer, I have retired and now I have a part time business in old photos restoration. I am not a high level expert in computers, but I know about computers much more than the general population. There is a problem here, and it looks like I will have to live with it.

more options

You can rename (or delete) the content-prefs.sqlite file to content-prefs.sqlite.old in the Firefox profile folder to reset the page zoom for all websites.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Maybe deactivate both of the zoom-related extensions and try them independently. They may be fighting with one another.

more options

Unfortunately this advise did not help to solve my problem, which is not restricted to Yahoo Mail only. It is "global" to all websites. For example: if I do a search in Google, the list of websites comes up with large letters (zoom of something 120%-150%). I can easily reduce the zoom size to that established in NoSquint (which I set at 100%) by pressing the Command+"0" key. When I click on any of the websites to go there the website comes up with the same large letters (a zoom of 120%-150%, whatever). Again, I have to use the same two buttons to get the 100% zoom. Switching back to the Google search list . . . you guessed, the same thing comes up, 120-150% zoom, etc. Very, very annoying.

I couldn't find the "Profile Directory" item in the Troubleshooting Information screen, but doing a search in Finder I found the file.

As I said renaming/removing the content-prefs.sqlite file closing and re-opening Firefox did not help.

But the Troubleshooting Information gave me a hint, which is to reset Firefox to its default state.This will require some preparatory work (taking notes about changes in about:config, additions of plug-ins, extensions), but, anything else failing, it's worth the extra effort. And that's what I will do. If that fails too I will just uninstall Firefox using the CleanApp application, which removes all files related to Firefox. Then I will install Firefox again, configure it to suit my needs (changes in about:config, adding plug-ins, extensions), but doing that one item at a time. This way I may discover the root of my problem.

more options

Some websites have a line of code that overrides your settings on font size.
Most sites don't do this, but there are a few that do.

If you think that this is why you are having an issue, consider contacting Yahoo for my details.


If you believe that this is a Firefox bug, feel free to file a bug report on Bugzilla. This way our developers can take a look at it.

more options

If you have made changes to Advanced font settings like increasing the minimum/default font size then reset the default minimum setting to "none" and the default font size to 16 in case the current setting is causing problems.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"
more options

If you are seriously considering a removal that would wipe out your data files (bookmarks, etc.), please make a backup first: Back up and restore information in Firefox profiles.

more options

Yahoo was only one of a multiple of examples I gave about the same problem. This problem did come up some time after upgrading the Firefox 28. It did not exist in any of the earlier versions of Firefox, and I have been using Firefox for several years, the last five with my Apple computers.

I tried everything, including the checking and unchecking of "Allow pages to choose . . ." etc. It did not work. I will try to set the font sizes as indicated, but I don't think it will solve my problem.

I would give up all all of my data files, bookmarks included. In order to try to solve my problem what I really need is an absolute clean install of Firefox, then adding plug-ins and extensions, one at a time, while checking if the problem comes up, and when. By trial and error I could be able to get to the root of my problem before finally deciding that the program has a bug.

more options

If you would like to try that, that would be a great solution.

Your issue will most likely be solved with a clean reinstall, but you can try Safe Mode before you do this.

Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:
FirefoxSafeMode

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

more options

I have a similar problem which was resolved by changing the minimum font size to None, but on re-start, FF always changes it back to 20.

more options

Hi pjdemmitt, the following support article suggests things to check when your settings change at startup: How to fix preferences that won't save.

Another common issue is Advanced SystemCare's "Surfing Protection" feature. If you have that software, you may need to disable that feature temporarily to save settings changes.