X
Tap here to go to the mobile version of the site.

Support Forum

Which Java 8 version do I choose to download?

Posted

It says I need to update Java but the automatic link takes me only to download 7.51 which I already have. I know there are links to Java 8 but I am not tech savvy enough to work out which version. Usually I need to download both a 32 bit and 64 bit version. Can anyone help me with specific download links or information please. Thanks in advance.

It says I need to update Java but the automatic link takes me only to download 7.51 which I already have. I know there are links to Java 8 but I am not tech savvy enough to work out which version. Usually I need to download both a 32 bit and 64 bit version. Can anyone help me with specific download links or information please. Thanks in advance.

Chosen solution

You don't need to do anything since Java 7 Update 51 is not vulnerable (afaik) and is the recommended version offered at http://www.java.com/en/download/manual.jsp and http://www.java.com/en/download/

If you check the "Do I have Java?" link at http://www.java.com/en/download/ and run the Java Detection applet it will tell you that you have the recommended Java installed (Version 7 Update 51).

Related bugs:

  • Bug 985968 - Mozilla Plugin check page displays Java plugin as vulnerable even if the latest version is installed.
  • Bug 985056 - Java JDK 8 released

P.S. The bug reports are for information only. Don't comment in bug reports unless you have something constructive to add (see Bugzilla Etiquette).

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 12.0 r0
  • 5.1.30214.0
  • iTunes Detector Plug-in
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

AliceWyman
  • Moderator
240 solutions 2594 answers

Chosen Solution

You don't need to do anything since Java 7 Update 51 is not vulnerable (afaik) and is the recommended version offered at http://www.java.com/en/download/manual.jsp and http://www.java.com/en/download/

If you check the "Do I have Java?" link at http://www.java.com/en/download/ and run the Java Detection applet it will tell you that you have the recommended Java installed (Version 7 Update 51).

Related bugs:

  • Bug 985968 - Mozilla Plugin check page displays Java plugin as vulnerable even if the latest version is installed.
  • Bug 985056 - Java JDK 8 released

P.S. The bug reports are for information only. Don't comment in bug reports unless you have something constructive to add (see Bugzilla Etiquette).

You don't need to do anything since Java 7 Update 51 is not vulnerable (afaik) and is the recommended version offered at http://www.java.com/en/download/manual.jsp and http://www.java.com/en/download/ If you check the "[http://www.java.com/en/download/installed.jsp?detect=jre&try=1 Do I have Java?]" link at http://www.java.com/en/download/ and run the Java Detection applet it will tell you that you have the recommended Java installed (Version 7 Update 51). Related bugs: *[https://bugzilla.mozilla.org/show_bug.cgi?id=985968 Bug 985968] - Mozilla Plugin check page displays Java plugin as vulnerable even if the latest version is installed. *[https://bugzilla.mozilla.org/show_bug.cgi?id=985056 Bug 985056] - Java JDK 8 released P.S. The bug reports are for information only. Don't comment in bug reports unless you have something constructive to add (see [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette]).

Modified by AliceWyman

Question owner

Should it not go to to the latest version available though when clicking the link to update?

Should it not go to to the latest version available though when clicking the link to update?
John99 971 solutions 13138 answers

Helpful Reply

Ideally it should do but there are faults at present and it is not working as intended.

Ideally it should do but there are faults at present and it is not working as intended.
AliceWyman
  • Moderator
240 solutions 2594 answers

See this Java help page for more information:

http://www.java.com/en/download/faq/java8.xml
Why is Java 8 not available on java.com?

See this Java help page for more information: http://www.java.com/en/download/faq/java8.xml <br> ''Why is Java 8 not available on java<!---->.com?''