X
Tap here to go to the mobile version of the site.

Support Forum

How can I turn on spellcheck as default?

Posted

I was happily typing along and noticed both a typo and the fact that the typo was NOT underlined in red squiggles. Hmmmm, I thought.

Fiddling around, I discovered an option on right-click that allowed Me to turn on spellcheck. Now, every time I type in an email or forum, on Twitter, anywhere, I have to right-click to be sure of My spelling.

Thus began My efforts to find how to set the button to be on by default... Finding none led Me to "Help," which a search of the term "spellcheck default" led Me to a zero in returns. Sure, there were discussions with those terms, but I could not prowl them all looking for the method of setting spellcheck to be on by default. The first few pages yielded nothing...

So if You would please, direct Me to that function. [smile]

Thank You.

I was happily typing along and noticed both a typo and the fact that the typo was NOT underlined in red squiggles. Hmmmm, I thought. Fiddling around, I discovered an option on right-click that allowed Me to turn on spellcheck. Now, every time I type in an email or forum, on Twitter, anywhere, I have to right-click to be sure of My spelling. Thus began My efforts to find how to set the button to be on by default... Finding none led Me to "Help," which a search of the term "spellcheck default" led Me to a zero in returns. Sure, there were discussions with those terms, but I could not prowl them all looking for the method of setting spellcheck to be on by default. The first few pages yielded nothing... So if You would please, direct Me to that function. [smile] Thank You.

Chosen solution

Hello,

Try this go to Tools >> Options >> Advanced >> General >> Check my spelling as I Type

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Google Update
  • 5.1.30214.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.9
  • Next Generation Java Plug-in 1.6.0_39 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

sfhowes 247 solutions 990 answers

Tools (or AppMenu/Options)/Options/Composition/Spelling, check "Enable spell-check as you type".

Tools (or AppMenu/Options)/Options/Composition/Spelling, check "Enable spell-check as you type".
Diego Victor
  • Top 25 Contributor
  • Moderator
593 solutions 3775 answers

Chosen Solution

Hello,

Try this go to Tools >> Options >> Advanced >> General >> Check my spelling as I Type

Hello, Try this go to '''Tools''' >> '''Options''' >> '''Advanced''' >> '''General''' >> '''Check my spelling as I Type'''

Question owner

Thank You both. Somehow I missed that tab. LOL!

Thank You both. Somehow I missed that tab. LOL!
Edward27821 22 solutions 225 answers

For some reason this solution does not work. At least not permanently Every time I start Firefox I need to re-enable this setting.

For some reason this solution does not work. At least not permanently Every time I start Firefox I need to re-enable this setting.

Modified by Edward27821

Charles 0 solutions 2 answers

Helpful Reply

Spellcheck enabled but still doesn't work.

Spellcheck enabled but still doesn't work.
tbenton 0 solutions 8 answers

My option is set for check spelling while I type but its not working and it used to work????? NEXT ?

My option is set for check spelling while I type but its not working and it used to work????? NEXT ?

Modified by tbenton

cor-el
  • Top 10 Contributor
  • Moderator
12133 solutions 112700 answers

Helpful Reply

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected. *Open the "Add Dictionaries" link to install a dictionary if you do not have one. *Make sure that [X] "Check Spelling" in the right-click context menu is check-marked. You can enable or disable spell checking globally: *Tools > Options > Advanced : General: Browsing: "Check my spelling as I type" You can look here for dictionaries: *https://addons.mozilla.org/firefox/language-tools/