X
Tap here to go to the mobile version of the site.

Support Forum

I removed certain buttons from my toolbar but they keep reappearing when I restart Firefox.

Posted

I've already reset Firefox to it's default setting and now I'm trying to customize it again back the way I had it. But every time after I remove buttons from the navigation toolbar they reappear when I restart Firefox. The buttons themselves are for the Readability addon and I have disabled them in the addon's settings, but I want them gone from the toolbar altogether.

I've already reset Firefox to it's default setting and now I'm trying to customize it again back the way I had it. But every time after I remove buttons from the navigation toolbar they reappear when I restart Firefox. The buttons themselves are for the Readability addon and I have disabled them in the addon's settings, but I want them gone from the toolbar altogether.

Chosen solution

The solution above didn't work for me. So I tried this instead.

Go to about:config and find the flag browser.uiCustomization.state. In its value (a string) remove any entry that has "readability" in it (there should be three of them for the three buttons).

Click OK and restart FF and the buttons will stay removed.

Good luck.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.9
  • 5.1.20913.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12275 solutions 113676 answers

You can check for problems caused by a corrupted localstore.rdf file.

If you do not keep changes after a restart or otherwise have problems with preferences, see:


If you have software like Advanced SystemCare that might reset some files to older versions to protect these files against changes then check the settings or uninstall this software.

You can check for problems caused by a corrupted localstore.rdf file. *http://kb.mozillazine.org/Corrupt_localstore.rdf If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved ---- If you have software like Advanced SystemCare that might reset some files to older versions to protect these files against changes then check the settings or uninstall this software.

Question owner

Thank you!

Thank you!
khaister 1 solutions 1 answers

Chosen Solution

The solution above didn't work for me. So I tried this instead.

Go to about:config and find the flag browser.uiCustomization.state. In its value (a string) remove any entry that has "readability" in it (there should be three of them for the three buttons).

Click OK and restart FF and the buttons will stay removed.

Good luck.

The solution above didn't work for me. So I tried this instead. Go to about:config and find the flag '''browser.uiCustomization.state'''. In its value (a string) remove any entry that has "readability" in it (there should be three of them for the three buttons). Click OK and restart FF and the buttons will stay removed. Good luck.

Modified by khaister

homerjsimpson8 0 solutions 6 answers

Hi The Readability toolbar icons keep reappearing for me. Using Firefox for mac ver 30.0.

I amend the following in the browser.uiCustomization.state field FROM: {"placements":{"PanelUI-contents":["edit-controls","zoom-controls","new-window-button","privatebrowsing-button","save-page-button","print-button","history-panelmenu","fullscreen-button","find-button","preferences-button","add-ons-button","developer-button"],"addon-bar":["addonbar-closebutton","status-bar"],"PersonalToolbar":["personal-bookmarks"],"nav-bar":["readability-toolbar-read","readability-toolbar-save","readability-toolbar-kindle","urlbar-container","search-container","webrtc-status-button","bookmarks-menu-button","downloads-button","home-button","social-share-button","abp-toolbarbutton","lpt_lastpass-compact-btn","RIL_toolbar_button"],"TabsToolbar":["tabbrowser-tabs","new-tab-button","alltabs-button","tabs-closebutton"]},"seen":["abp-toolbarbutton"],"dirtyAreaCache":["PersonalToolbar","nav-bar","TabsToolbar","PanelUI-contents","addon-bar"],"newElementCount":0}

TO: {"placements":{"PanelUI-contents":["edit-controls","zoom-controls","new-window-button","privatebrowsing-button","save-page-button","print-button","history-panelmenu","fullscreen-button","find-button","preferences-button","add-ons-button","developer-button"],"addon-bar":["addonbar-closebutton","status-bar"],"PersonalToolbar":["personal-bookmarks"],"nav-bar":["urlbar-container","search-container","webrtc-status-button","bookmarks-menu-button","downloads-button","home-button","social-share-button","abp-toolbarbutton","lpt_lastpass-compact-btn","RIL_toolbar_button"],"TabsToolbar":["tabbrowser-tabs","new-tab-button","alltabs-button","tabs-closebutton"]},"seen":["abp-toolbarbutton"],"dirtyAreaCache":["PersonalToolbar","nav-bar","TabsToolbar","PanelUI-contents","addon-bar"],"newElementCount":0}

Click OK and restart Firefox but the 3 Readability icons keep reappearing on my the left hand side of my toolbar. Am I doing something wrong or is there another way to prevent this from happening?

Thanks

Hi The Readability toolbar icons keep reappearing for me. Using Firefox for mac ver 30.0. I amend the following in the browser.uiCustomization.state field FROM: {"placements":{"PanelUI-contents":["edit-controls","zoom-controls","new-window-button","privatebrowsing-button","save-page-button","print-button","history-panelmenu","fullscreen-button","find-button","preferences-button","add-ons-button","developer-button"],"addon-bar":["addonbar-closebutton","status-bar"],"PersonalToolbar":["personal-bookmarks"],"nav-bar":["readability-toolbar-read","readability-toolbar-save","readability-toolbar-kindle","urlbar-container","search-container","webrtc-status-button","bookmarks-menu-button","downloads-button","home-button","social-share-button","abp-toolbarbutton","lpt_lastpass-compact-btn","RIL_toolbar_button"],"TabsToolbar":["tabbrowser-tabs","new-tab-button","alltabs-button","tabs-closebutton"]},"seen":["abp-toolbarbutton"],"dirtyAreaCache":["PersonalToolbar","nav-bar","TabsToolbar","PanelUI-contents","addon-bar"],"newElementCount":0} TO: {"placements":{"PanelUI-contents":["edit-controls","zoom-controls","new-window-button","privatebrowsing-button","save-page-button","print-button","history-panelmenu","fullscreen-button","find-button","preferences-button","add-ons-button","developer-button"],"addon-bar":["addonbar-closebutton","status-bar"],"PersonalToolbar":["personal-bookmarks"],"nav-bar":["urlbar-container","search-container","webrtc-status-button","bookmarks-menu-button","downloads-button","home-button","social-share-button","abp-toolbarbutton","lpt_lastpass-compact-btn","RIL_toolbar_button"],"TabsToolbar":["tabbrowser-tabs","new-tab-button","alltabs-button","tabs-closebutton"]},"seen":["abp-toolbarbutton"],"dirtyAreaCache":["PersonalToolbar","nav-bar","TabsToolbar","PanelUI-contents","addon-bar"],"newElementCount":0} Click OK and restart Firefox but the 3 Readability icons keep reappearing on my the left hand side of my toolbar. Am I doing something wrong or is there another way to prevent this from happening? Thanks
homerjsimpson8 0 solutions 6 answers

Helpful Reply

Found alternative solution that worked. https://support.mozilla.org/en-US/questions/995019#answer-599880

Gingerbread Man's solution:

    Type about:config into the address bar and press Enter.
   Press the big button to bypass the warning.
   In the search box, paste extensions.readability.first_run_complete
   In the search results, double-click extensions.readability.first_run_complete to set its value to true
   Restart Firefox.
   Right-click an empty area of the tab bar and choose Customize. Place Readability's icons wherever you like. 

The problem you're describing is a bug in the add-on. I can confirm it, as do others who've posted reviews. Contact the authors of the add-on using either the "Support site" or "Support e-mail" links on the add-on's description page.

Found alternative solution that worked. https://support.mozilla.org/en-US/questions/995019#answer-599880 Gingerbread Man's solution: Type about:config into the address bar and press Enter. Press the big button to bypass the warning. In the search box, paste extensions.readability.first_run_complete In the search results, double-click extensions.readability.first_run_complete to set its value to true Restart Firefox. Right-click an empty area of the tab bar and choose Customize. Place Readability's icons wherever you like. The problem you're describing is a bug in the add-on. I can confirm it, as do others who've posted reviews. Contact the authors of the add-on using either the "Support site" or "Support e-mail" links on the add-on's description page.