X
Tap here to go to the mobile version of the site.

Support Forum

Fire Fox no longer applies my UN and PW when I open a site. The function is not enabled. All PS are still showing in tools, options.

Posted

I have several site that have User names and Pass Words assigned and saved in tools, options. Fire Fox no longer applies these when I open the site. When I look at tools, options the "Remember passwords for sites" is not enabled. How do I re enable this function.

This happened after a bout with some malware from a program called Torch.

I have several site that have User names and Pass Words assigned and saved in tools, options. Fire Fox no longer applies these when I open the site. When I look at tools, options the "Remember passwords for sites" is not enabled. How do I re enable this function. This happened after a bout with some malware from a program called Torch.

Chosen solution

See:

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 12.0 r0
  • iTunes Detector Plug-in
  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 5.1.4.17398
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Garmin Communicator Plug-In 4.1.0.0
  • GEPlugin
  • VLC media player Web Plugin 2.0.6
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.4.1 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

Extensions

  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • FLV Runner 10.23.0.822 ({3bbd3c14-4c16-4989-8366-95bc9179779d}) (Inactive)
  • Geomate.jr Manager 1.0.3.2 (navitfound@apisphere.com) (Inactive)
  • Geomate.jr Upgrader 1.0.3.2 (navitloader@apisphere.com) (Inactive)
  • HP Smart Web Printing 4.5 (smartwebprinting@hp.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • SweetPacks A14 10.23.0.822 ({ecf9d4ae-b571-42c2-9745-74fdb8b0d27a}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce FX 5200 (Microsoft Corporation)
  • adapterDescription2:
  • adapterDeviceID: 0x0322
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'182.65']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 4-7-2004
  • driverDate2:
  • driverVersion: 5.6.7.3
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'182.65']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'182.65']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage: www.yahoo.com
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • browser.urlbar.autocomplete.enabled: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 27.0.1
  • keyword.URL: http://search.conduit.com/ResultsExt.aspx?ctid=CT3201318&SearchSource=2&CUI=UN37882895381203685&UM=2&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1394375961
  • places.history.expiration.transient_current_max_pages: 53661
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.np-mswmp: 2
  • plugin.state.npconduitfirefoxplugin: 2
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1394055052

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17697 solutions 160125 answers

Your System Details List shows that you run Firefox in permanent Private Browsing mode (browser.privatebrowsing.autostart: True).

Firefox won't fill name and password automatically when you are in PB mode. You will have to double-click the empty input field or type the first letter(s) and select the name from the drop-down list.

Your System Details List shows that you run Firefox in permanent Private Browsing mode (browser.privatebrowsing.autostart: True). *https://support.mozilla.org/kb/Private+Browsing Firefox won't fill name and password automatically when you are in PB mode. You will have to double-click the empty input field or type the first letter(s) and select the name from the drop-down list.

Question owner

How do I get out of this mode?

How do I get out of this mode?
cor-el
  • Top 10 Contributor
  • Moderator
17697 solutions 160125 answers

Chosen Solution

See:

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
See: *Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode"

Question owner

Thanks that worked

Thanks that worked

Question owner

This worked for one day. I am still setup as above but the UN and PW are not filled in as I open a site.

Another problem. When I open a new tab there are 8 past sites displayed even though I have selected do not remember history.

Both problem started when I was hit by some program called Torch. I can not remove that program from the computer

This worked for one day. I am still setup as above but the UN and PW are not filled in as I open a site. Another problem. When I open a new tab there are 8 past sites displayed even though I have selected do not remember history. Both problem started when I was hit by some program called Torch. I can not remove that program from the computer
cor-el
  • Top 10 Contributor
  • Moderator
17697 solutions 160125 answers

Do you see this Torch program in the Windows Control Panel or are there other programs that were installed recently?

  • Control Panel > Programs > Programs and Features > Uninstall or change a program
  • Click the Installed column to sort by this heading

Do a malware check with several malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:


Your System Details List shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts.

The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

See also:

Do you see this Torch program in the Windows Control Panel or are there other programs that were installed recently? *Control Panel > Programs > Programs and Features > Uninstall or change a program *Click the Installed column to sort by this heading Do a malware check with several malware scanning programs on the Windows computer.<br> Please scan with all programs because each program detects different malware.<br> All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender: Home Page:<br>http://www.microsoft.com/windows/products/winfamily/defender/default.mspx *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked ---- Your System Details List shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file is only present if you or other software has created this file and normally it wouldn't be there. You can check its content with a plain text editor (right-click: Open with) if you didn't create this file yourself. The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. See also: *http://kb.mozillazine.org/Preferences_not_saved

Question owner

My computer appears to be free of malware but the UN and PW issue is still there.

I have removed PW from the save password file and reentered them via FF asking if i want to save them. FF still will not auto fill the UN & PS when I open a site. In some sites FF will complete the auto fill once I type the first letter of my UN so the information is saved it just won't auto fill.

My computer appears to be free of malware but the UN and PW issue is still there. I have removed PW from the save password file and reentered them via FF asking if i want to save them. FF still will not auto fill the UN & PS when I open a site. In some sites FF will complete the auto fill once I type the first letter of my UN so the information is saved it just won't auto fill.
cor-el
  • Top 10 Contributor
  • Moderator
17697 solutions 160125 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

I have started a new computer and have this problem.

I know FF can be made to automatically apply the UN and PW to a site and open that site when I click on the bookmark for that site. I ma not referring to auto fill of the UN and PW once one types the first letter of the UN. I am referring to a completely automatic opening of the site from the click of a bookmark.

My question is how to get this to work? Every time I reconfigure my computer it is an ordeal to get this simple function to work.

I have started a new computer and have this problem. I know FF can be made to automatically apply the UN and PW to a site and open that site when I click on the bookmark for that site. I ma not referring to auto fill of the UN and PW once one types the first letter of the UN. I am referring to a completely automatic opening of the site from the click of a bookmark. My question is how to get this to work? Every time I reconfigure my computer it is an ordeal to get this simple function to work.

Modified by HowieE

cor-el
  • Top 10 Contributor
  • Moderator
17697 solutions 160125 answers

Automatically opening a web page that way might only work if you have saved a "remember me" cookie from that site on a previous visit and you still have this cookie and the server recognizes it.

Note that direct links to specific pages on a server may stop working in case those pages are removed and thus the link has become invalid.

Details like websites remembering you (log you in automatically) are stored in a cookie.

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

Automatically opening a web page that way might only work if you have saved a "remember me" cookie from that site on a previous visit and you still have this cookie and the server recognizes it. Note that direct links to specific pages on a server may stop working in case those pages are removed and thus the link has become invalid. Details like websites remembering you (log you in automatically) are stored in a cookie. *Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed. *Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions In case you are using "Clear history when Firefox closes": *do not clear the Cookies *do not clear the Site Preferences *Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings *https://support.mozilla.org/kb/Clear+Recent+History Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data. Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

Question owner

OK we are getting closer.

In case you are using "Clear history when Firefox closes":

   do not clear the Cookies
   do not clear the Site Preferences 
   Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings 

I am using Clear History when Firefox closes . I have the sites in question in the exception list.

I can not enable Do Not Clear Cookies. That box when checked does not remain if I go back to that option.

As mentioned before if that function is enabled on my other computer the auto apply of UN and PW works.

I have also checked these instructions and comply with them. But no help

Passwords being automatically cleared

Firefox may be set to remove saved passwords when it is closed. To undo this setting:

   At the top of the Firefox window, click on the Firefox button and then select Options
   .
   Select the Privacy panel.
   If Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, click on the Settings… button.
   Make sure that Saved Passwords is not selected.
   Click OK to close the Options window . 

Firefox is now configured to not clear your passwords when closing.

Another issue. When I get your e mail reply I can no longer go directly to the Forum to reply.

OK we are getting closer. '''In case you are using "Clear history when Firefox closes": do not clear the Cookies do not clear the Site Preferences Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings ''' I am using Clear History when Firefox closes . I have the sites in question in the exception list. I can not enable Do Not Clear Cookies. That box when checked does not remain if I go back to that option. As mentioned before if that function is enabled on my other computer the auto apply of UN and PW works. I have also checked these instructions and comply with them. But no help '''Passwords being automatically cleared Firefox may be set to remove saved passwords when it is closed. To undo this setting: At the top of the Firefox window, click on the Firefox button and then select Options . Select the Privacy panel. If Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, click on the Settings… button. Make sure that Saved Passwords is not selected. Click OK to close the Options window . Firefox is now configured to not clear your passwords when closing. Another issue. When I get your e mail reply I can no longer go directly to the Forum to reply.'''

Modified by HowieE