X
Tap here to go to the mobile version of the site.

Support Forum

Firefox slow on startup

Posted

Hello everyone, i need some help with an issue i've been recently noticing when opening firefox. Whenever i try to open it without any previous tab opened, it takes a long time to start up (~10 seconds). Never had this problem before. After starting up everything works fine and even opening new tabs/windows is done instantly, the issue is experienced only when firefox is closed and needs to start.

I tried disabling my antivirus and the problem persists. I tried disabling hardware acceleration and the problem persists. I tried starting firefox whit a clean, new profile and the problem persists. I tried reinstalling firefox and the problem persists. I tried starting firefox in safe mode and seems to work fine, but when i try to run it normally while disabling all plug-ins and extensions (running default theme) the problem shows up again.

Any idea what else i could try to fix this annoying thing?

Hello everyone, i need some help with an issue i've been recently noticing when opening firefox. Whenever i try to open it without any previous tab opened, it takes a long time to start up (~10 seconds). Never had this problem before. After starting up everything works fine and even opening new tabs/windows is done instantly, the issue is experienced only when firefox is closed and needs to start. I tried disabling my antivirus and the problem persists. I tried disabling hardware acceleration and the problem persists. I tried starting firefox whit a clean, new profile and the problem persists. I tried reinstalling firefox and the problem persists. I tried starting firefox in safe mode and seems to work fine, but when i try to run it normally while disabling all plug-ins and extensions (running default theme) the problem shows up again. Any idea what else i could try to fix this annoying thing?

Chosen solution

Try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to to see if that helps.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
    *http://kb.mozillazine.org/about:config
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 12.0 r0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • VLC media player Web Plugin 2.1.0
  • Battlelog Game Launcher (2.3.2)
  • 0.70.4

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.5.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • avast! Online Security 9.0.2013.75 (wrc@avast.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Aimersoft Video Converter Ultimate 5.0.0 ({CF13FA66-1F4F-426d-BB1B-E07A13BFF2C8}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 670
  • adapterDescription2:
  • adapterDeviceID: 0x1189
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 4095
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 2-8-2014
  • driverDate2:
  • driverVersion: 9.18.13.3489
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 670 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 27.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • network.http.max-persistent-connections-per-server: 4
  • places.database.lastMaintenance: 1394099375
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.npbattlelog: 2
  • plugin.state.npdeployjava: 1
  • plugin.state.npesnsonar: 2
  • plugin.state.npnv3dv: 2
  • plugin.state.npnv3dvstreaming: 2
  • plugin.state.nppdf: 2
  • plugin.state.npqtplugin: 2
  • plugin.state.npvlc: 2
  • privacy.sanitize.migrateFx3Prefs: True
  • security.disable_button.openCertManager: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1391937932

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
12747 solutions 117141 answers

Chosen Solution

Try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to to see if that helps.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
    *http://kb.mozillazine.org/about:config
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
Try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to to see if that helps. ---- In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit)<br>*http://kb.mozillazine.org/about:config *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected

Helpful Reply

Thanks for your response, a full list of what is disabled during firefox's safe mode is exactly what i needed.

I double checked everything again and even though it didn't seem like it made any difference the first time, disabling hardware acceleration cuts down my load times to about 2-3 seconds so i'm guessing it's an issue with my (recently updated) video drivers. Think i can call this solved, thanks for the help!

Thanks for your response, a full list of what is disabled during firefox's safe mode is exactly what i needed. I double checked everything again and even though it didn't seem like it made any difference the first time, disabling hardware acceleration cuts down my load times to about 2-3 seconds so i'm guessing it's an issue with my (recently updated) video drivers. Think i can call this solved, thanks for the help!