X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Wednesday, April 1, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

How do I disable Firefox as default on Mac OS 10.6 Snow Leopard

Posted

Accidentally checked use as default browser and want to remove this. Use Safari regularly and now cannot disable default for Firefox.

Thanks.

Accidentally checked use as default browser and want to remove this. Use Safari regularly and now cannot disable default for Firefox. Thanks.

Chosen solution

1. Open Safari (/Applications).

2. From the Safari menu, choose Preferences.

3. Click the General button.

4. Choose your desired browser from the "Default web browser" pop-up menu.

(See the screenshot)

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • WebEx64 General Plugin Container Version 205
  • iPhoto6
  • Coupons Inc., Coupon Printing FireFox Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Version 3.15.2.12038
  • DivX VOD Helper Plug-in
  • 5.1.20913.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • DivX Web Player version 3.1.0.13
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 5.1.4.17398
  • Shockwave Flash 12.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17855 solutions 161578 answers

Did you try to set Safari as the default browser in the Safari preferences?

  • Safari > Preferences > General > Default Web Browser

Make sure to remove the tick here:

  • Firefox > Preferences > Advanced > General : System Defaults
Did you try to set Safari as the default browser in the Safari preferences? *Safari > Preferences > General > Default Web Browser Make sure to remove the tick here: *Firefox > Preferences > Advanced > General : System Defaults
DH Shawon 1 solutions 3 answers

Chosen Solution

1. Open Safari (/Applications).

2. From the Safari menu, choose Preferences.

3. Click the General button.

4. Choose your desired browser from the "Default web browser" pop-up menu.

(See the screenshot)

1. Open Safari (/Applications). 2. From the Safari menu, choose Preferences. 3. Click the General button. 4. Choose your desired browser from the "Default web browser" pop-up menu. (See the screenshot)