Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

setting initial default homepage

  • 5 replies
  • 9 have this problem
  • Last reply by cor-el

more options

I am deploying FF18.0.2 to about 700 workstations, in the past I have been using;

Mozilla.cfg, copied to <install_Folder> //Firefox Default Settings

// set Firefox Default homepage pref("browser.startup.homepage","");

// disable default browser check pref("", false); pref("browser.startup.homepage_override.mstone", "ignore");

// disable application updates pref("app.update.enabled", false)

// disables the 'know your rights' button from displaying on first run pref("browser.rights.3.shown", true);

// disables the request to send performance data from displaying pref("toolkit.telemetry.prompted", 2); pref("toolkit.telemetry.rejected", true);

local-settings.js; Copied to <install_folder>\defaults\pref

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg"); lockPref("", false); lockPref("app.update.enabled", false);

but the endusers can not change this homepage, how do I enable them to be able to change the default page?

All Replies (5)

more options

hello, change that into

// set Firefox Default homepage 

for reference please see

more options

Thanks for trying, but when I do that FF wont open; Error "Failed to read the configuration file. Please contact your system administrator"

made that change to the Mozilla.cfg file, which is copied to "c:\program files (x86)\Mozilla Firefox"

more options

Make sure that the file name is mozilla.cfg (;case sensitive; all lowercase).

Does it work with the pref() function?

Also try to save the mozilla.cfg file with UNIX line ending (i.e. only a linefeed and not cr/lf).

more options

The pref() function works fine, I have set a few prefs set during install, but this is the one I can not get to make so the users can change it!

have tried;


Only pref() works

more options

The "browser.startup.homepage" is a complex pref and apparently requires a different approach to set as a default value.


  • defaultPref("browser.startup.homepage", "data:text/plain,browser.startup.homepage=");