X
Tap here to go to the mobile version of the site.

Support Forum

Firefox audio doesn't change when headphones are plugged in

Posted

My Realtek audio device is set up to detect the microphone jack and to switch the audio to headphones when they are plugged in. This works for everything except for Firefox. Firefox doesn't realize that the default audio device has changed and still uses the speakers. If I restart Firefox, it detects the correct default audio device. However, I don't want to restart my Firefox every time I plug or unplug my headphones.

Searching has revealed that there is no way to manually change the audio device in Firefox. But is there any way for Firefox to detect the current default audio device upon change? Other applications switch mid-stream when I plug in my headphones.

My Realtek audio device is set up to detect the microphone jack and to switch the audio to headphones when they are plugged in. This works for everything except for Firefox. Firefox doesn't realize that the default audio device has changed and still uses the speakers. If I restart Firefox, it detects the correct default audio device. However, I don't want to restart my Firefox every time I plug or unplug my headphones. Searching has revealed that there is no way to manually change the audio device in Firefox. But is there any way for Firefox to detect the current default audio device upon change? Other applications switch mid-stream when I plug in my headphones.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 12.0 r0
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 5.1.4.17398
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Pando Web Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Plugin for Wacom tablets.

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.4.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Anti-Aliasing Tuner 11.12.01.01 (aatuner@hotmint.com)
  • Greasemonkey 1.15 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Reddit Enhancement Suite 4.3.1.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Stylish 1.4.1 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Skype Click to Call 7.0.14735.1561 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon R9 200 Series
  • adapterDescription2:
  • adapterDeviceID: 0x67b1
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 4095
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: BGR ClearType Level: 100 Enhanced Contrast: 400
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 11-29-2013
  • driverDate2:
  • driverVersion: 13.250.18.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon R9 200 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 0
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 27.0.1
  • font.internaluseonly.changed: True
  • general.autoScroll: False
  • gfx.content.azure.enabled: False
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.font_rendering.cleartype_params.rendering_mode: 1
  • keyword.URL: http://www.bing.com/search?FORM=UP97DF&PC=UP97&q=
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1392803812
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1391112076

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars 475 solutions 5852 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:
FirefoxSafeMode

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes). ''(If you're using an added theme, switch to the Default theme.)'' If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the '''Restart with Add-ons Disabled...''' menu item:<br> [[Image:FirefoxSafeMode|width=520]]<br><br> If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you.

Question owner

it's present in Safe mode

it's present in Safe mode
iamjayakumars 475 solutions 5852 answers

Then it may be your Addon issue. Check the addons

Then it may be your Addon issue. Check the addons

Question owner

I restarted with Add-ons disabled and it didn't fix it.

I restarted with Add-ons disabled and it didn't fix it.
lm108 1 solutions 42 answers

I have a similar problem and started a new thread here: https://support.mozilla.org/en-US/questions/989180

I have a similar problem and started a new thread here: https://support.mozilla.org/en-US/questions/989180