X
Tap here to go to the mobile version of the site.

Support Forum

after clicking backbutton, return to google search page, page is blank

Posted

I have just downloaded firefox 27.0.1. (windows 8.1 64 pro). I do a search in Google, go somewhere, then return by clicking the back arrow. The page is blank. Sometimes I will see the google data before it gets wiped. THis has happened most of the time but not all. I downloaded it yesterday (2/14) and got the problem right away.

Just a few minutes, I navigated to a page after google search and hit the back button. It worked.

  then hit the forward arrow, then back again.. blank page now.
  repeat many times with result of blank page.

First Firefox experience not good.

I have just downloaded firefox 27.0.1. (windows 8.1 64 pro). I do a search in Google, go somewhere, then return by clicking the back arrow. The page is blank. Sometimes I will see the google data before it gets wiped. THis has happened most of the time but not all. I downloaded it yesterday (2/14) and got the problem right away. Just a few minutes, I navigated to a page after google search and hit the back button. It worked. then hit the forward arrow, then back again.. blank page now. repeat many times with result of blank page. First Firefox experience not good.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; rv:11.0) like Gecko

More Information

Diego Victor
  • Top 25 Contributor
  • Moderator
604 solutions 3855 answers

Hello,

Try clear your recent history:

Also:

Hello, Try clear your recent history: *[https://support.mozilla.org/en-US/kb/remove-recent-browsing-search-and-download-history Clear recent history] Also: *[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in safe mode] *[http://www.mozilla.org/en-US/plugincheck/ Check plugins]
cor-el
  • Top 10 Contributor
  • Moderator
12306 solutions 113980 answers

Helpful Reply

Try to set the browser.sessionhistory.max_total_viewers pref to 0 (zero) on the about:config page.

You can open the about:config page via the location bar

Try to set the <b>browser.sessionhistory.max_total_viewers</b> pref to 0 (zero) on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location bar *http://kb.mozillazine.org/about:config

Question owner

Wow.I cant believe the quick responses. That impresses me.

However..

 I cleared the history - everything.  It did not help. (the firefox button is not there, but
    I found it in the menus)
 This is a fresh install.  No add ins, plugins. or anything. 
 Also, no add-ons when i checked that from tools
 If I set the  browser.sessionhistory.max_total_viewers = 0 or 1, the  back button
     was disabled after navigation, so I could not go back at all..  Putting it back to
     the default of course got me back to the original problem.

For me, the real issue should be.. a fresh install should not require me changing anything to get a back button to work, so seems to me that fix should is in order. Agreed ?

I installed Firefox because when I use IE, it seems that at least half the pages I visit are disabling the back button. I have to start clicking it fast to get it to work. So, why not see if the same problem is in Firefox. So far, I have not seen that behavior, but then again, Ive only had it installed a very short time. But this is about as bad. I can click refresh and the data is displayed, so I guess that it is better.

Thx for the replies.

Wow.I cant believe the quick responses. That impresses me. However.. I cleared the history - everything. It did not help. (the firefox button is not there, but I found it in the menus) This is a fresh install. No add ins, plugins. or anything. Also, no add-ons when i checked that from tools If I set the browser.sessionhistory.max_total_viewers = 0 or 1, the back button was disabled after navigation, so I could not go back at all.. Putting it back to the default of course got me back to the original problem. For me, the real issue should be.. a fresh install should not require me changing anything to get a back button to work, so seems to me that fix should is in order. Agreed ? I installed Firefox because when I use IE, it seems that at least half the pages I visit are disabling the back button. I have to start clicking it fast to get it to work. So, why not see if the same problem is in Firefox. So far, I have not seen that behavior, but then again, Ive only had it installed a very short time. But this is about as bad. I can click refresh and the data is displayed, so I guess that it is better. Thx for the replies.
cor-el
  • Top 10 Contributor
  • Moderator
12306 solutions 113980 answers

See also:

See also: *[[/questions/970863]]

Question owner

Thanks for the link.

Looks like the issue has been around for a while (since September) and no resolution.

Thanks for the link. Looks like the issue has been around for a while (since September) and no resolution.
differencetone 0 solutions 3 answers

Problem solved by switching to the default Firefox Home Page.

Could be caused because you are using Open DNS.

Problem solved by switching to the default Firefox Home Page. Could be caused because you are using Open DNS.

Question owner

I tried setting about:config browser.cache.default_cache_doc (that may not be right, i unloaded the page) to zero, but that didn't help.

Regardless, This is a problem that Should be fixed, not just some discussion of workarounds and settings in the forum. I realize that this is a open source thing, but it needs to get put on to someones to do list.

The only reliable way that I have found to get around this is to get new pages loaded into a new window. But that should works in IE as well.

Oh well, maybe next version. I give up.

I tried setting about:config browser.cache.default_cache_doc (that may not be right, i unloaded the page) to zero, but that didn't help. Regardless, This is a problem that Should be fixed, not just some discussion of workarounds and settings in the forum. I realize that this is a open source thing, but it needs to get put on to someones to do list. The only reliable way that I have found to get around this is to get '''new pages loaded into a new window'''. But that should works in IE as well. Oh well, maybe next version. I give up.
cor-el
  • Top 10 Contributor
  • Moderator
12306 solutions 113980 answers

Helpful Reply

Try to disable the Google Instant predictions: Never show Instant results

Try to disable the Google Instant predictions: Never show Instant results *https://www.google.com/preferences