Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

after installing firefox 27 "save link as" is not working

  • 17 replies
  • 28 have this problem
  • Last reply by janbar

more options

after installing firefox 27 "save link as" is not working started a few days ago use to work fine before v27 was installed. please help.

All Replies (17)

more options

Hello hansram, Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

more options

Hi Ideato

Thank so so very much for replying to my question , unfortunately safe mode did not solve the problem. I also changed the status off the pluggins to never active and restarted in safe mode but I was unable to "safe link as".

Hope you can help solve this problem, do you have any more ideas on solving it? It only started with Firefox 27

Kind regards Hans

more options


Try do a clean reinstall:

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be recovered unless they have been backed up to an external device!

Please report back to see if this helped you!

Thank you.

more options

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

more options

Hi well I have tried various options that you boys have kindly replied to me with.

1) I have created and logged on with a new profile, setted the system still did not work 2) reset to default browser did not work 3) deleted and reinstalled firefox did not work.

4) resetting download actions could not find "" file in "about:config" could this be the problem?

I really need this to start working again as it is an important part off my work from home.

Any help is greatly received.

kind Regards Hansram

more options

If creating a new profile via the Profile Manager doesn't help then there is no need to reset Firefox as that does about the same, but imports old data and thus might still carry over some issues.

So it sounds that you have a problem that lies outside of Firefox.
. This could be security or other software software blocking this dialog.

You can try a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

Download a fresh Firefox copy and save the file to the desktop.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you lose personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.

more options

Hi thank you for the help again.

but unfortunately Its has not worked.

1) I uninstalled firefox through windows control panel and/remove

2) deleted c:\program files\miz.. firefox folder

3) reinstalled a fresh firefox browser

4) tried to "save link as" and still not working

could it be plungings that are causing this?

it was working fine until I installed firefox 27

any further help would be appropriated.


more options

Hi everone,

Ihave just restarted my computer "windows XP" in safe mode and started fire fox safe mode and tryed "save link as" and it works ok in safe mode.

hope this helps but still unable to save in normal mode

any help would be appricated.


more options

This happens in all websites?

more options

Yes unfortunately it does

any ideas?

Kind regards Hansram

more options

You said that works in safe mode, try disable addon by addon and try this in normal mode, when you disable on addon test the option

more options

I don't have any add on but I have gone through and disabled my plugins and extensions but still unable to "save link as" I have also uninstall and reinstalled a fresh copy of firefox.

please help over come this problem.

are others severing the same ?


more options

If it works in Windows Safe mode then you have a problem with other software, possibly security software or a system driver, that is running on your computer.
Make sure that you have the latest updates of your security software and major hardware drivers.

You can use the MSConfig program or the Autoruns utility to see which software and services are getting started (be cautious with disabling services).

more options


The "save as link" works in other browsers I don't have have problem with IE "save target as" or with Chrome "save as"

in both these it works fine I'm having a problem with Firefox not saving link as since Firefox 27.

are other users experiencing the same?

kind regards


more options

hello hansram, other affected users have reported that this was caused by their avast security software, can you switch to a different program?

more options

I have the same problem and I don't use Avast but F-secure and yes I can using that option in other browsers.

EDIT: It's look like here in that thread:

Modified by janbar

more options

Well, in my case it was PhotoME 2.0 extension but I remember that in 27 version in Safe mode it appears too. Now I have latest 28 version and Safe mode is not affected. I disabled it and all works fine. I can't register on its forum but I sended an email to its maker.