X
Tap here to go to the mobile version of the site.

Support Forum

ssl goes mix content on google after pressing back button?

Posted

Hi,

Interesting issue here. Did a total reinstall of firefox and issue remains.

Steps to reproduce:

Go to google.com and search for something

Then, Click a result and after it loads press the back button, back to results.

For me, my SSL search page no longer fully encrypted.

Web developer tools shows no calls to unencrypted content, what gives?

Video showing what I see : https://app.box.com/shared/om89uo735aisc4v2fxmn

Hi, Interesting issue here. Did a total reinstall of firefox and issue remains. Steps to reproduce: Go to google.com and search for something Then, Click a result and after it loads press the back button, back to results. For me, my SSL search page no longer fully encrypted. Web developer tools shows no calls to unencrypted content, what gives? Video showing what I see : https://app.box.com/shared/om89uo735aisc4v2fxmn

Modified by thebigonedanny

Chosen solution

This may be related to how Firefox's aggressive back-forward caching attempts to minimize the re-parsing of pages. Because of the complexity of Google's result pages, Firefox might be getting a little confused about the page content. Here is a suggested workaround if the mixed content warning (which appears to be inaccurate) really troubles you:

Force Firefox to re-parse the page by changing a setting (note: this is not Google-specific and may slow down "Back" on all sites by some milliseconds). Here's how:

  • In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.
  • In the search box above the list, type or paste sess and pause while the list is filtered
  • Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).


Edit: Be careful not to change browser.sessionstore.max_tabs_undo or browser.sessionstore.max_windows_undo to zero, or you won't be able to re-open any recently closed tabs or windows.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • iTunes Detector Plug-in
  • VLC media player Web Plugin 2.1.0
  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.9.1.16010
  • 5.1.20913.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17687 solutions 160003 answers

It is possible that an extension is sending some request that causes this or otherwise data might get send.

You can try if the Live Http Headers shows any requests and responses (tick all boxes on the Generator tab).

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
It is possible that an extension is sending some request that causes this or otherwise data might get send. You can try if the Live Http Headers shows any requests and responses (tick all boxes on the Generator tab). * https://addons.mozilla.org/firefox/addon/live-http-headers/ Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Safe mode still had the issue.

Using live http headers shows no requests (Really, firefox is just replaying it from cache most likely?)

Only extensions I have are noscript, https everywhere and live http headers.

Does not happen on another computer on the same network connection, so its not a router/modem/ISP issue


Also, it seems directly related to the action of "going back".

IE- If i am on https://www.google.com/search?q=asdf , click first result and then press back button, issue appears

BUT

if I am on https://www.google.com/search?q=asdf , click first result and then manually paste https://www.google.com/search?q=asdf into the address bar, SSL shows correctly.


Issue is not present in chrome or IE.

Safe mode still had the issue. Using live http headers shows no requests (Really, firefox is just replaying it from cache most likely?) Only extensions I have are noscript, https everywhere and live http headers. Does not happen on another computer on the same network connection, so its not a router/modem/ISP issue Also, it seems directly related to the action of "going back". IE- If i am on https://www.google.com/search?q=asdf , click first result and then press back button, issue appears BUT if I am on https://www.google.com/search?q=asdf , click first result and then manually paste https://www.google.com/search?q=asdf into the address bar, SSL shows correctly. Issue is not present in chrome or IE.

Modified by thebigonedanny

cor-el
  • Top 10 Contributor
  • Moderator
17687 solutions 160003 answers

Does this only happen when you are logged on to Google?

Does this only happen if you open a http link or also with a https link?

Does this only happen when you are logged on to Google? Does this only happen if you open a http link or also with a https link?

Question owner

Yes, only when logged into google. When I open a incognito window and recreate my steps, it stays as SSL so the issue is somehow being tied to being logged into google.

It happens with both ssl and non ssl links clicked.


As for my google 'settings':

2 factor auth, multiple account switcher, google + account enabled but unused, web history disabled


update* Tested with a different google account in a icognito window. This account has 2factor auth enabled, no multi acct switcher, NO google + profile, web history off

So, maybe its related to either google + or acct switcher?

Yes, only when logged into google. When I open a incognito window and recreate my steps, it stays as SSL so the issue is somehow being tied to being logged into google. It happens with both ssl and non ssl links clicked. As for my google 'settings': 2 factor auth, multiple account switcher, google + account enabled but unused, web history disabled update* Tested with a different google account in a icognito window. This account has 2factor auth enabled, no multi acct switcher, NO google + profile, web history off So, maybe its related to either google + or acct switcher?

Modified by thebigonedanny

Question owner

Ok, tracked it down.

Its google plus. When its enabled, the behavior in first post is seen.

When google plus is not enabled, the behavior is NOT seen (good)

So, is this a google issue or a mozilla issue?

Ok, tracked it down. Its google plus. When its enabled, the behavior in first post is seen. When google plus is not enabled, the behavior is NOT seen (good) So, is this a google issue or a mozilla issue?
averymd 0 solutions 1 answers

I can replicate the issue while unauthenticated in FF 27: https://dl.dropboxusercontent.com/u/12063618/Firefox%20SSL%20Error%20on%20Back.avi

I'm also seeing this on a non-Google site, which is what led me here, so it's not Google-specific.

I can replicate the issue while unauthenticated in FF 27: https://dl.dropboxusercontent.com/u/12063618/Firefox%20SSL%20Error%20on%20Back.avi I'm also seeing this on a non-Google site, which is what led me here, so it's not Google-specific.
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Chosen Solution

This may be related to how Firefox's aggressive back-forward caching attempts to minimize the re-parsing of pages. Because of the complexity of Google's result pages, Firefox might be getting a little confused about the page content. Here is a suggested workaround if the mixed content warning (which appears to be inaccurate) really troubles you:

Force Firefox to re-parse the page by changing a setting (note: this is not Google-specific and may slow down "Back" on all sites by some milliseconds). Here's how:

  • In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.
  • In the search box above the list, type or paste sess and pause while the list is filtered
  • Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).


Edit: Be careful not to change browser.sessionstore.max_tabs_undo or browser.sessionstore.max_windows_undo to zero, or you won't be able to re-open any recently closed tabs or windows.

This may be related to how Firefox's aggressive back-forward caching attempts to minimize the re-parsing of pages. Because of the complexity of Google's result pages, Firefox might be getting a little confused about the page content. Here is a suggested workaround if the mixed content warning (which appears to be inaccurate) really troubles you: Force Firefox to re-parse the page by changing a setting (note: this is not Google-specific and may slow down "Back" on all sites by some milliseconds). Here's how: * In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. * In the search box above the list, type or paste '''sess''' and pause while the list is filtered * Double-click the '''browser.session<u>history</u>.max_total_viewers''' preference and change it to 0 (that's a zero). ''Edit: Be careful not to change browser.sessionstore.max_tabs_undo or browser.sessionstore.max_windows_undo to zero, or you won't be able to re-open any recently closed tabs or windows.''

Modified by jscher2000

Question owner

This kills the crab.

Problem solved, thanks!

This kills the crab. Problem solved, thanks!