Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do Firefox page icons not display properly?

  • 5 replies
  • 23 have this problem
  • 9728 views
  • Last reply by emmacgold

more options

hi there, I have a problem which is only happening in Firefox (26). Which is that page icons don't seem to display and show as a default icon. This makes it hard to use some sites which don't have associated text with the button.

I have attached an icons which you can see the images across the top are all defaulted. Any help would be appreciated.

Screen Shot 2014-02-04 at 9.19.02 AM.png

Chosen solution

That are actually characters supplied by a font that is downloaded from the server and not icons as you can see the the little boxes that show the hex code if the character.

Make sure that you allow pages to choose their own fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and reset user set (bold) prefs via the right-click context menu to the default value.

You can open the about:config page via the location bar

Read this answer in context 👍 11

All Replies (5)

more options

Sorry, image below.

more options

Chosen Solution

That are actually characters supplied by a font that is downloaded from the server and not icons as you can see the the little boxes that show the hex code if the character.

Make sure that you allow pages to choose their own fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and reset user set (bold) prefs via the right-click context menu to the default value.

You can open the about:config page via the location bar

more options

Cor-el you're a bloody legend! As simple as that. Thanks so much as this has been bugging me for a while now and I've just put up with it.

All the best.

more options

You're welcome.

more options

Helped me, too! Thanks Cor-el, primo advice!