X
Tap here to go to the mobile version of the site.

Support Forum

Audio doesn't work only in Firefox. In the mixer it appears like Firefox's using SPDIF output instead of speakers, but in the system (win81) speakers is default

Posted

Hi, I.ve a Win 8.1 64 installation. Everything's working and also audio in Mozilla form youtube or other sources. But when I play Vimeo videos it doesn't work Opening the mixer, selecting the output "speakers" nothing happens; igf I select SPDIF output, Firefox's audio bar seems move up and down . But audio default in win8 system is speakers. What happens? It's a problem related with Vimeo? Should I install some kind of plugin for Vimeo? Thx Antonio

Hi, I.ve a Win 8.1 64 installation. Everything's working and also audio in Mozilla form youtube or other sources. But when I play Vimeo videos it doesn't work Opening the mixer, selecting the output "speakers" nothing happens; igf I select SPDIF output, Firefox's audio bar seems move up and down . But audio default in win8 system is speakers. What happens? It's a problem related with Vimeo? Should I install some kind of plugin for Vimeo? Thx Antonio

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.9.1.16010
  • 5.1.20913.0
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/it/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7500 Series
  • adapterDescription2:
  • adapterDeviceID: 0x675d
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 9-10-2013
  • driverDate2:
  • driverVersion: 13.152.1.1000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7500 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1391257641
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1390432578

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars 475 solutions 5852 answers
Fix common audio and video issues *https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

Question owner

That was the first thing i tried..... Did you read my message? it seems that firefox redirects audio on the spdif output also if the standard output in windows is speaker and youtube works fine

That was the first thing i tried..... Did you read my message? it seems that firefox redirects audio on the spdif output also if the standard output in windows is speaker and youtube works fine
iamjayakumars 475 solutions 5852 answers

May be your plugin issues.

May be your plugin issues. *http://www.mozilla.org/en-US/plugincheck/

Question owner

already checked ! all plugins are up to date and working correctly!

already checked ! all plugins are up to date and working correctly!
cor-el
  • Top 10 Contributor
  • Moderator
13079 solutions 119732 answers

You probably need to set the default audio device and close and restart Firefox to make Firefox use or switch to the selected audio device.

You probably need to set the default audio device and close and restart Firefox to make Firefox use or switch to the selected audio device.

Question owner

The PC was restarted many time the audio device is set to speakers. In youtube firefox audio works properly. In vimeo it doesn't.

The PC was restarted many time the audio device is set to speakers. In youtube firefox audio works properly. In vimeo it doesn't.
cor-el
  • Top 10 Contributor
  • Moderator
13079 solutions 119732 answers

Do both sites use the same plugin or possibly the built-in HTML5 media player with the video tag?

Do both sites use the same plugin or possibly the built-in HTML5 media player with the video tag?

Modified by cor-el

iamjayakumars 475 solutions 5852 answers

Whether its happening to particular video or all video in VIMEO?

Could you provide the link if you can

Whether its happening to particular video or all video in VIMEO? Could you provide the link if you can

Question owner

HI cor-el I don't understand your suggestion...

HI cor-el I don't understand your suggestion...

Question owner

HI iamjayakumars, all Vimeos... but I tried on another PC and it works.. there should be something wrong locally. Ho can we fix it?

HI iamjayakumars, all Vimeos... but I tried on another PC and it works.. there should be something wrong locally. Ho can we fix it?
cor-el
  • Top 10 Contributor
  • Moderator
13079 solutions 119732 answers

What I mean that the website might be using the built-in HTML5 media player and not the Flash plugin to play the media files. That can make a difference. The Flash player always gives its own context menu if you right-click in the player area.

What I mean that the website might be using the built-in HTML5 media player and not the Flash plugin to play the media files. That can make a difference. The Flash player always gives its own context menu if you right-click in the player area.

Question owner

Yes I think it works with HTML5 on VImeo videos... In Youtube , right-clicking appears the Flash menu... not in vimeo how can I change it?

Yes I think it works with HTML5 on VImeo videos... In Youtube , right-clicking appears the Flash menu... not in vimeo how can I change it?

Question owner

fixed !! found this: https://support.mozilla.org/en-US/questions/966369

Question owner

but after restart windows the problem reappear!! So there is some setting which'll be restred every time I restart the PC in Firefox (or in the pc)! Have some idea?

but after restart windows the problem reappear!! So there is some setting which'll be restred every time I restart the PC in Firefox (or in the pc)! Have some idea?

Question owner

No news? What I can do?

No news? What I can do?

Question owner

I couldn't image Mozilla spammed in this manner....

I couldn't image Mozilla spammed in this manner....