X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox do not play sound in any HTML5 player.

Posted

When trying to play any sample from any album sold in Bandcamp.com the player starts playing, but there is no sound. Meanwhile other browsers plays it fine.

I use latest FF, I tried disabling various addons and plugins but it didn't help (they are not sound related anyway).

I run on Win8x64.

Update: The sound plays fine everywhere else on Firefox. YouTube etc. It plays everywhere except Bandcamp.

And the Bandcamp player is not Flash, it has nothing Flash related. It is HTML5 player.

Modified by rhazor

Chosen solution

SOLVED

Finally, after hundreds of hours I fixed it and Firefox plays sound in HTML5 in everywhere, YouTube (HTML5 mode), SoundCloud, Bandcamp and etc.

You have to: Right-click on your sound/speakers icon in the system tray and select Playback Devices, go to Speakers properties (the one which is green-ticked, also disable the red ones, if any), then go to Enhancements and tick Disable all sound effects. And that's it, restart the browser and enjoy.

In short: Volume mixer -> Playback devices -> Playback tab -> Speakers properties -> Enhancements -> Disable all sound effects -> Restart browser.

I use latest stable Firefox 23.0.1 on Windows 8 x64 (but Firefox is 32-bit).

Also, if didn't help, make sure you have media.windows-media-foundation.enabled set to 'true' in about:config.

You should also have some decent codecs installed in your machine, I have VLC Player and it comes with lots of in-built codecs. Also make sure you have VLC Web Plugin enabled in Add-ons -> Extensions (Always activate)

So the unanswered is who's problem is that? Is it Firefox? Or Windows 8? Or my Realtek audio drivers fault? (Anyway without disabling sound effects, HTML5 works fine in any other browser, so I blame Firefox for this nonsense for extra configurations in Windows audio settings)

So, pretty much it.

Cheers, rhazor

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-GB/

Extensions

  • Adblock Plus 2.3.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Disable Anti-Adblock 3.1 ({d49a148e-817e-4025-bee3-5d541376de3b})
  • Element Hiding Helper for Adblock Plus 1.2.3 (elemhidehelper@adblockplus.org)
  • Feed Sidebar 7 (feedbar@efinke.com)
  • Firebug 1.11.4 (firebug@software.joehewitt.com)
  • RightBar 0.5 (rightbar@realmtech.net)
  • Translate This! 3.0 (jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • FullRip.net Youtube Video Converter 2.0.2 (admin@fullrip.net) (Inactive)
  • Password Exporter 1.2.1 ({B17C1C5A-04B1-11DB-9804-B622A1EF5492}) (Inactive)
  • SearchIMDB 1.2.0 (searchimdb@sogame.cat) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 650
  • adapterDescription2:
  • adapterDeviceID: 0x0fc6
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1023
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100 ] DISPLAY5 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100 ]
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 3-14-2013
  • driverDate2:
  • driverVersion: 9.18.13.1422
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 650)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.startup.homepage: google.com/ncr
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.warnOnClose: False
  • dom.max_chrome_script_run_time: 0
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: True
  • gfx.content.azure.enabled: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1375023387
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.npadobeaamdetect: 0
  • plugin.state.npadobeexmandetectx: 0
  • plugin.state.npctrl: 0
  • plugin.state.npdeployjava: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npmeetingjoinpluginoc: 0
  • plugin.state.npqtplugin: 0
  • plugin.state.npspwrap: 0
  • plugin.state.npvlc: 0
  • privacy.clearOnShutdown.cache: False
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1372775568

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin

You can try clear the Flash local storage and settings.

  • Windows Control Panel > Flash Player > Storage: Local Storage Settings
    • Remove a specific domain: Local Storage Settings by site
    • Remove all domains: Delete All and Delete Data

Flash Website Storage Settings panel:

Global Storage Settings Panel:

Question owner

Update: The sound plays fine everywhere else on Firefox. YouTube etc. It plays everywhere except Bandcamp.

And the Bandcamp player is not Flash, it has nothing Flash related. It is HTML5 player.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

I'm seeing a hidden Flash player on bandcamp.com playing the sound and disabling Flash makes the sound stop for me.
There are only audio tags in the page code, but they are empty (i.e. no source specified).

<embed id="proxy_swfobject_1" width="0" height="0" flashvars="proxyid=1&namespace=FlashProxy" style="z-index: 9999;" allowscriptaccess="always" quality="high" bgcolor="#F0F0F0" name="proxy_swfobject_1" src="http://bandcamp.com/js/shared/nugget2.swf" type="application/x-shockwave-flash"></embed>

Question owner

So what does it mean? My flash is enabled everywhere. Is it somehow disabled on that site? How to enable that then?

Question owner

Okay. I think I found out that there is no audio on Firefox on any HTML5 player. I tried the one at home page of http://mediaelementjs.com/ it shows it is playing but there is no audio (there is video though). And below video player there is an audio player too - no sound.

I cleared all caches and settings and disabled all addons and extensions and updated to all latest flashes and everything.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can click the Volume icon on the Windows Taskbar near the clock and click the Mixer link at the bottom to open the mixer.
You can adjust the volume level for each application in that window, so make sure that Firefox is not muted or set at a low level.
Current Firefox versions use the plugin-container process to run plugins, so you need to check the volume setting for the plugin-container process.
You will only see the Firefox program or the Plugin Container in the Mixer if you are on a website that plays sound.

See also:

Question owner

All mixer volume levels are set to max, I did that already and I mentioned that there is sound on YouTube or any other Flash player. There is no sound on HTML5 players.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Does the video player on this page show controls?

You can check via the right-click context menu if show controls is enabled.

Question owner

It does. And audio is set to max on its Volume bar. But there is no sound, only video. Same issue with all HTML5 players on latest Firefox.

meegja 3 solutions 41 answers

Got similar problems with a lot of videos on YouTube when HTML5 is enabled there. A lot of videos have no sound then. Here some examples of my own creations there.

These work both in Firefox and IE with HTML5 enabled: http://www.youtube.com/watch?v=P9OQcIVt644

http://www.youtube.com/watch?v=cu9qsmJXc9U

http://www.youtube.com/watch?v=9q5MwAF46AU

http://www.youtube.com/watch?v=7DGf8tVCjgI

These work on IE but not in Firefox when YouTube HTML5 is enabled: http://www.youtube.com/watch?v=U9fis5vWlTs

http://www.youtube.com/watch?v=SQKx5V8xSEo

http://www.youtube.com/watch?v=GFAK40HKhKY

http://www.youtube.com/watch?v=Mv32GGYXlo8

Some of those videos have recorded sound, others I added afterwards.

And when I check on http://html5test.com/ with my Firefox, it states that there is no MPEG-4 and H.264 support for HTML5.

Modified by meegja

Question owner

Yeah for me it also says that my browser doesn't have MPEG-4 support, but at http://caniuse.com/mpeg4 it says that latest FF has support for it. So I don't get it at all.

Also for anyones interest since I started this thread, soundcloud was working fine, but maybe couple days ago it also started not to work, it plays, but there is no sound. Just like that, for no reason. I even reset all my Firefox settings, neither safe mode with all addons disabled or this, do not help.

Windows 8 x64.

Youtube for me works fine though.

Modified by rhazor

meegja 3 solutions 41 answers

Seems that those changing formats (Flash, HTML5, and so on) are way more picky on system/OS configurations. For me http://caniuse.com/mpeg4 says that FF 23 is partially supported. And Soundcloud is giving no troubles at all, can hear all the clips. And YouTube with HTML5 there enabled is around 50/50 for me when it comes to audio with the videos. Here on Windows 8 Pro 64bit.

Question owner

I just upgraded to Windows 8.1 Preview and Soundcloud is playing fine again, but still no sound in example at bandcamp.com

Chosen Solution

SOLVED

Finally, after hundreds of hours I fixed it and Firefox plays sound in HTML5 in everywhere, YouTube (HTML5 mode), SoundCloud, Bandcamp and etc.

You have to: Right-click on your sound/speakers icon in the system tray and select Playback Devices, go to Speakers properties (the one which is green-ticked, also disable the red ones, if any), then go to Enhancements and tick Disable all sound effects. And that's it, restart the browser and enjoy.

In short: Volume mixer -> Playback devices -> Playback tab -> Speakers properties -> Enhancements -> Disable all sound effects -> Restart browser.

I use latest stable Firefox 23.0.1 on Windows 8 x64 (but Firefox is 32-bit).

Also, if didn't help, make sure you have media.windows-media-foundation.enabled set to 'true' in about:config.

You should also have some decent codecs installed in your machine, I have VLC Player and it comes with lots of in-built codecs. Also make sure you have VLC Web Plugin enabled in Add-ons -> Extensions (Always activate)

So the unanswered is who's problem is that? Is it Firefox? Or Windows 8? Or my Realtek audio drivers fault? (Anyway without disabling sound effects, HTML5 works fine in any other browser, so I blame Firefox for this nonsense for extra configurations in Windows audio settings)

So, pretty much it.

Cheers, rhazor

Modified by rhazor

meegja 3 solutions 41 answers

That indeed works! :) But, think it's indeed more a treatment of a symptom with Firefox then the solution to the problem. The problem itself still is there :( Besides that: the audio is there now but now the video(s) in HTML5 are jerky, freezing for a second every 5 seconds orso (at YouTube) while the video allready is completely loaded. But at least there is a kind of workaround for this problem now :)

Modified by meegja

Helpful Reply

Hmm, I don't know. I don't have these issues now at all. Maybe you are trying to watch HD content on older machine? Or maybe slow internet connection? I am watching 1080p HD HTML5 videos on YouTube now with i3 computer and 100Mbps optic fiber line.

Anyway, could be anything, and yes, this problem should be fixed by Firefox, someone should report somewhere.

DubhlinnDel 0 solutions 1 answers

Disabled all Add ons, enable one at a time

Adblock Plus 2.1.1 was the culprit.

Disabled it and volume AOK.

Update to Adblock Plus 2.3.2 volume gone again.

Disable 2.3.2 reload Firefox page and volume returns.

Adblock Plus currently disabled.

Listening to good music.

Thanks for help

Alphas 0 solutions 4 answers

I have the same problem, HTML5 video does not play sound to my computer speaker but instead to my TV speakers!

Tried disabling my LG TV audio in playback device and also disable all sound effect but the sound still output via ARC through HDMI. My default onboard sound is the default audio playback for all formats. My mediaplayer play without problem, youtube play flash to my speakers, only HTML5 plays the audio to my LG TV speakers!

Is there any away to configure the playback device for HTML5 audio?????

ddcnl 0 solutions 1 answers

This problem has been driving me insane for like 6 months.

This finally did it for me:

You can try to set the media.windows-media-foundation.enabled pref to false on the about:config page to disable the built-in mp4 media player.

Bandcamp works after I do that. However, lots of other built-in media still doesn't play (such as the drop on Relevantmag.com) in Firefox. I'm really losing faith in Firefox and don't want to switch to chrome, but I may have to :(

Modified by ddcnl