Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF seems ot now open multiple windows on start up. Even on a new laptop. How can I change to just opeining my homepage?!

  • 6 replies
  • 1 has this problem
  • 715 views
  • Last reply by jbeard888

more options

A few weeks ago FF started loading multiple pages (tabs) on startup. I have treid many things to abate and to no avail Even on a new machine it is doing this. I am sure it is a setting but after and hours + of looking I am forced to migrate ot Chrome. Prefer to stay if there is a quick fix and I am just not savvy enough to figure out. please advise...

Chosen solution

Best is to open a new window with only that tab if you want to use the "Use Current Page" (note that Firefox adds the 's' pages if more than one tab is open).
You should also be able to drag a tab or the "Site Identity Button" (globe/padlock) on the location bar on the toolbar Home button to set this tab as the home page (you need to confirm this).

Read this answer in context 👍 1

All Replies (6)

more options

Thank you for providing your detailed system information. It shows that you have multiple home pages set. This may not be obvious from the small amount that you can see in the Preferences dialog, but you have (URLs shortened for forum display):

I suggest completely clearing out your home page setting, then saving your preferred page again. These article should help with that:

Does that work?

more options

By the way, are you using the Firefox Sync service to copy settings between different system or devices? There may be some additional steps in that case, to prevent the unwanted list of pages from getting "sync'd" back.

more options

So...when I save a Home Page (use Current Page) that actually saves all open tabs. Wow. NEVER would've figured that one out. Thank you for the incredibly prompt reply with the fix. Very impressed and grateful.!

more options

Glad to hear that fixed it.

It's probably too subtle: the button says "Use Current Pages", in other words, it's plural. Maybe some kind of confirmation is in order? Actually, displaying all the pages on separate rows in a list box for easy editing would be a good idea.

more options

Chosen Solution

Best is to open a new window with only that tab if you want to use the "Use Current Page" (note that Firefox adds the 's' pages if more than one tab is open).
You should also be able to drag a tab or the "Site Identity Button" (globe/padlock) on the location bar on the toolbar Home button to set this tab as the home page (you need to confirm this).

more options

Thanks you for the info!