Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I re-enable the 'Restore Previous Session', 'Recently Closed Tabs' and 'Recently Closed Windows' functions in the History menu?

  • 15 replies
  • 84 have this problem
  • 29508 views
  • Last reply by jscher2000

more options

Since a while back, the four choices in the restore section (Tabs from Other Devices, Restore Previous Session, Recently Closed Tabs and Recently Closed Windows) have been greyed out. The keyboard shortcuts don't work, and nor does Undo Closed Tab in the tab context menu.

I have found and tried various fixes for this, including:

  • Starting Firefox in Safe Mode without addons.
  • Resetting Firefox.
  • Changing the values of browser.sessionstore.max_tabs_undo and browser.sessionstore.max_windows_undo in about:config.
  • Checking to see if I have a user.js in the Firefox profile. (I don't.)
  • Checking that Private Browsing isn't the default mode. (It isn't.)
  • Creating a new profile to see if it had the same issue. (It did.)
  • Running anti-malware scans. (BitDefender and SpyBot.)
  • Disabling my anti-virus and anti-malware temporarily.

None of these solve my problems.


Tabs from Other Devices is greyed out, but I have never used it, and it might have been greyed out previously.

History works in general. Sites I visit are added to the log.

Preferences are properly saved when I change them.


Any advice on how to fix the problem would be much appreciated, as I am very fond of these features and used them often until they stopped working.


ADDENDUM

After looking through the Modified Preferences list created by the Troubleshooter, I have now also tried resetting the following:

  • browser.places.smartBookmarksVersion
  • browser.newtabpage.storageVersion
  • browser.cache.disk.capacity
  • browser.cache.disk.smart_size.first_run
  • browser.cache.disk.smart_size.use_old_max
  • browser.cache.disk.smart_size_cached_value

The problem persists.

Modified by Ahnìon

Chosen solution

I finally managed to figure this out. By searching the web, I found a thread detailing a similar problem at the Mozillazine forum. The problem was identified as a missing browser.sessionstore.enabled setting, so I went looking for it in about:config and could not find it. After creating the entry, setting it to true and restarting Firefox, the Restore/Recently functions started working again. Apparently, some bookmark- and session-focussed plugins can cause this problem, but in my case, it must have been something else, as I have never had any such plugins installed.

If you have this problem, here's a detailed walkthrough of how I fixed it. Considering that there seem to be several problems that can cause the Restore/Recently functions to stop working, this is not a guaranteed fix, but it's one more thing to try, at least.

  1. Open a new tab or window.
  2. Type about:config into the address box and hit Enter.
  3. Read the notice and promise to be careful.
  4. Copy this: browser.sessionstore.enabled -- and paste it into about:config's Search box. Hit Enter.
  5. If you copied the text above right, the setting should appear in the list. If it does not, you have the same problem I did. (I would suggest double-checking that you copy/pasted the indicated text and only that text before proceeding.)
  6. If the setting does not exist, right-click the settings list and choose New-->Boolean. Paste the setting name you copied previously into the Name box, hit OK and then set the Boolean value to True. Once you've hit OK, restart Firefox and (hopefully) things should be working properly again.


Thanks to everyone who have offered help and thoughts!

Read this answer in context 👍 20

All Replies (15)

more options

Be careful with modifying or resetting prefs.
That is where the warning message comes in (general.warnOnAboutConfig).

The version prefs are used so that Firefox knows if a (SQLite) database file needs to be converted to a newer version because of changes in the source code, so leave those alone.


Such issues are usually caused by a problem with the sessionstore.js file, that either doesn't get created or that Firefox can't update for some reason.

Does Firefox create and update sessionstore.js file?

  • Tools > Options > General > Startup: "When Firefox Starts":
    "Show my windows and tabs from last time"

Do all browser.sessionstore.* prefs have the default value?

If not then reset them via the right-click context menu on the about:config page to make sure that Session Restore is enabled and working properly.


Did you try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test?

more options

First of all, thank you for the reply.

I do try not to fiddle with things of which I don't have a clear understanding, but resetting values to their defaults should be relatively safe, shouldn't it? I would presume (perhaps, indeed, wrongly) that if the values are vital, then the FF update in question would also change the defaults.


Firefox does indeed not create a sessionstore.js in my profile directory, regardless of the startup options. What could cause this?

I have tried booting in safe mode, but forgot to mention it in my post. All browser.sessionstore.* values are at default. Since yesterday, I have also tried a clean install of Firefox, to no avail.

Modified by Ahnìon

more options

Hi Ahnìon, sorry about the unrelated reply.

In case your Firefox program folder contains files that are damaged or modified, could you rename the program folder and then reinstall Firefox? In this process, the Firefox installer should recognize and automatically connect with your existing profiles. Still, it might be a good idea to make a backup. This article has suggestions: Back up and restore information in Firefox profiles.

You can download the installer for Firefox 27.0 from here:

https://www.mozilla.org/firefox/all/ (scroll down to your language)

Then after exiting Firefox, rename the folder

C:\Program Files (x86)\Mozilla Firefox

something like

C:\Program Files (x86)\OldFirefox

And run the installer. (Note: This is sometimes called a "clean reinstall.")

more options

I lost too many saved pages and bookmarks because the Restore Previous Sessioin option disappeared from my home page and was grayed out under history. If you're not computer savvy and the complicated suggested fixes are over your head or don't work, save all your Firefox bookmarks to Google Chrome. Delete Firefox and start using Google Chrome. I have never had this problem with Google Chrome.

more options

Chosen Solution

I finally managed to figure this out. By searching the web, I found a thread detailing a similar problem at the Mozillazine forum. The problem was identified as a missing browser.sessionstore.enabled setting, so I went looking for it in about:config and could not find it. After creating the entry, setting it to true and restarting Firefox, the Restore/Recently functions started working again. Apparently, some bookmark- and session-focussed plugins can cause this problem, but in my case, it must have been something else, as I have never had any such plugins installed.

If you have this problem, here's a detailed walkthrough of how I fixed it. Considering that there seem to be several problems that can cause the Restore/Recently functions to stop working, this is not a guaranteed fix, but it's one more thing to try, at least.

  1. Open a new tab or window.
  2. Type about:config into the address box and hit Enter.
  3. Read the notice and promise to be careful.
  4. Copy this: browser.sessionstore.enabled -- and paste it into about:config's Search box. Hit Enter.
  5. If you copied the text above right, the setting should appear in the list. If it does not, you have the same problem I did. (I would suggest double-checking that you copy/pasted the indicated text and only that text before proceeding.)
  6. If the setting does not exist, right-click the settings list and choose New-->Boolean. Paste the setting name you copied previously into the Name box, hit OK and then set the Boolean value to True. Once you've hit OK, restart Firefox and (hopefully) things should be working properly again.


Thanks to everyone who have offered help and thoughts!

more options

The browser.sessionstore.enabled is no longer supported in current Firefox releases because Session Restore saves more data like pinned tabs and tab groups, so disabling Session Restore would cause issues and thus support for this pref had been removed a long time ago.
There are other browser.sessionstore.* prefs that can effect restoring tabs and windows.

  • browser.sessionstore.max_tabs_undo
  • browser.sessionstore.max_windows_undo

From http://kb.mozillazine.org/Browser.sessionstore.enabled

Mozilla Firefox 3.0 and below. Since Firefox 3.5 this preference is superseded with setting browser.sessionstore.max_tabs_undo and browser.sessionstore.max_windows_undo to 0.
more options

cor-el: That may well be, but changing max_tabs_undo and max_windows_undo did not fix the problem. Adding browser.sessionstore.enabled (and setting it to True) did.

It seems that I can now remove the value from browser.sessionstore.enabled and still retain the functionality, so I would guess that adding the value caused some sort of reset or similar that could not be affected by changing other values.

more options

Creating the < browser.sessionstore.enabled > file didn't help me at all.

Here's the solution= In the search engine you use, copy and paste and go to < about:config > Next enter < browser.sessionstore.max_tabs_undo > into the config search area. Next right click on it and click < reset >. This will set it to default. Which should be an integer with a value of 10. Do the same thing with < browser.sessionstore.max_windows_undo > . It is also an integer, but the default has a value of 3.

Note= If you created the < browser.sessionstore.enabled > file. If you want to remove it, right click on it and click on < reset >. The next time you go to < about:config > it will be gone.
more options

aj34977: While it is nice of you to make this comment, you might want to read my first post again. The answer you suggest is actually mentioned there, in my list of things that did not fix the problem.

This is not to diminish the fact that this worked for you (and no doubt many others) but there are already several posts about that particular solution and -- as stated -- this was about what to do when that (and several other proposed fixes) did not work.

more options

As I had it too I believe the problem was caused by 'Malwarebytes' (or a similar program like 'F-SecureOnlineScanner'). In my case many files ending in '.js' along with others were quarantined. And some security sites also suggest you delete such files. There is a good reason to delete them but obviously there is a negative side to this like the problem created here in this post.

more options

Ahnìon's solution worked for me the 1st time around. However, the problem occurred again a few days later and this time by going to 'about:config' and then 'browser.sessionstore.enabled' did show the entry unlike the first time. and then still nothing. Hence my initial thought of the entry (the .js file) being removed by Malwarebytes made sense the 1st time. But what of the 2nd time where Malwarebytes was not involved? Truly strange since no malware/trojan/virus exists either.

more options

I am having a problem essentially identical to what you have described. I have tried the solutions listed here, yet they have not worked.

more options

What I ended up doing finally, not being able to resolve it is go to my history, Open each page manually from there, then copy the URLs onto a .txt file. Uninstall and reinstall Firefox and then got the URLS back in separate tabs. This is not a solution and a little long but, for now at least my tabs and all are back to normal.

more options

pintree3, There is a quicker way to save your tabs. This is what I do. In Firefox click on "Tools" , then "Options", then "General", then "Use Current Pages". Next, highlight the entire area to the right of where it says "Home Page:". Now, go to your desktop ( or whatever folder you want to use) and right click on a blank area. On the drop-down go to new and then click on where it says "Text document". You can name this file something like "Firefox Tabs.txt" or something similar. Open the file, right click on the body and then "paste". When you close the file it will ask you if you want to save changes. Click "Yes".

I often up-date this file, just in-case. When up-dating you will highlight the body of the txt file first before pasting.
If you open Firefox and need your tabs back just reverse the process. Open and copy the txt file first. Then go to the "Tools", "Options", "General" pop-up, and then paste into the "Home Page" area. Note: On that same "General" pop-up page select "Show my windows and tabs from last time" to the right of "When Firefox starts:". After you have done this you may have to relaunch Firefox. This is much faster then going to the History tab and copying each website one-by- one.

FYI- I am using Windows 7 operating system.

more options

Hi belac1, thank you for starting a new question. I replied over here: https://support.mozilla.org/questions/1010551#answer-603360

Because this thread is already marked as Solved, and is very long with many different people posting in it, I suggest anyone who isn't helped by this thread please also start a new question so it's less confusing for the volunteers.