X
Tap here to go to the mobile version of the site.
IMPORTANT ANNOUNCEMENT: We’re going through some system changes, that may have slowed responses to your questions. If you had asked a question in the last couple of months, please re-post it and the community will help you as soon as we can. If you’ve registered after February 7th, please register again, the accounts on the previous site were not migrated to this temporary site. If you joined us before February 7, please reset your password if you have trouble logging into this temporary site.

Support Forum

Location bar search goes to my internet service provider instead of search engine selected in search bar; why?

Posted

Using Firefox 26.0 for openSUSE 12.3

I have disabled keyword search from the location/address bar, because instead of search results from the source selected in the search bar (google), my string entry got sent to my internet service provider, some kind of dead-end, unproductive "web search" page with no results.

I had typed in "ezsniper" to the location bar. After disabling the keyword search in about:config, my string entry took me to ezsniper.com, which is better than the dead-end Charter.com page

Using Firefox 26.0 for openSUSE 12.3 I have disabled keyword search from the location/address bar, because instead of search results from the source selected in the search bar (google), my string entry got sent to my internet service provider, some kind of dead-end, unproductive "web search" page with no results. I had typed in "ezsniper" to the location bar. After disabling the keyword search in about:config, my string entry took me to ezsniper.com, which is better than the dead-end Charter.com page

Chosen solution

I've set my DNS addresses to 8.8.8.8 and 8.8.4.4 (Google Public DNS)

The problem has not happened again, but stopped before I made the DNS change. Charter Communications seemed to allow a way to turn off the "service" that had ignored my browser/preferences, so that might have done it.... I appreciate the responses, doubt Charter will get another chance to hijack DNS again.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The IcedTea-Web Plugin executes Java applets.
  • Plugin for Installing Applications (new)

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

Question owner

After resetting the config setting mentioned above to the default (true) value again, and restarting firefox, the same string and any others entered in the location bar correctly were sent to the search provider selected in my search bar.

The only other thing that might have affected this is that I had recently made a temporary change to the selected search provider. But this had been reset to google before the above described search was misdirected to the internet service provider.

After resetting the config setting mentioned above to the default (true) value again, and restarting firefox, the same string and any others entered in the location bar correctly were sent to the search provider selected in my search bar. The only other thing that might have affected this is that I had recently made a temporary change to the selected search provider. But this had been reset to google before the above described search was misdirected to the internet service provider.
philipp
  • Top 10 Contributor
  • Moderator
4424 solutions 19851 answers

those useless pages are normally served through your ISP on invalid DNS requests. another way to mitigate that would be to configure your system to use an alternative DNS server like the one google provides: https://developers.google.com/speed/public-dns

those useless pages are normally served through your ISP on invalid DNS requests. another way to mitigate that would be to configure your system to use an alternative DNS server like the one google provides: https://developers.google.com/speed/public-dns
cor-el
  • Top 10 Contributor
  • Moderator
14855 solutions 134681 answers

Helpful Reply

See also http://en.wikipedia.org/wiki/DNS_hijacking

Chosen Solution

I've set my DNS addresses to 8.8.8.8 and 8.8.4.4 (Google Public DNS)

The problem has not happened again, but stopped before I made the DNS change. Charter Communications seemed to allow a way to turn off the "service" that had ignored my browser/preferences, so that might have done it.... I appreciate the responses, doubt Charter will get another chance to hijack DNS again.

I've set my DNS addresses to 8.8.8.8 and 8.8.4.4 (Google Public DNS) The problem has not happened again, but stopped before I made the DNS change. Charter Communications seemed to allow a way to turn off the "service" that had ignored my browser/preferences, so that might have done it.... I appreciate the responses, doubt Charter will get another chance to hijack DNS again.
James
  • Top 25 Contributor
  • Moderator
1201 solutions 8365 answers

Helpful Reply

There is this page however not sure if it is cookie based or if once you opt out it will not matter what browser is used or if cookies are removed. http://search.charter.net/prefs.php

There is this page however not sure if it is cookie based or if once you opt out it will not matter what browser is used or if cookies are removed. http://search.charter.net/prefs.php

Question owner

Yep, James, this is the page where I attempted to disable the Charter Communications "Web Helper."

      But on revisiting the page, I see that it is nevertheless "enabled."  (So I have "disabled" it again, and an immediate recheck shows it is "disabled."  Guessing it defaults back to "enabled" if/ when cookies are cleared, which is sometimes needed to avoid other unsolicited "help."

Hopefully using Google Public DNS will prevent Charter from "helping" me any more with my "website preferences"! Thanks again to all who have addressed this issue.

Yep, James, this is the page where I attempted to disable the Charter Communications "Web Helper." But on revisiting the page, I see that it is nevertheless "enabled." (So I have "disabled" it again, and an immediate recheck shows it is "disabled." Guessing it defaults back to "enabled" if/ when cookies are cleared, which is sometimes needed to avoid other unsolicited "help." Hopefully using Google Public DNS will prevent Charter from "helping" me any more with my "website preferences"! Thanks again to all who have addressed this issue.