Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox and a Linksys router

  • 4 replies
  • 1 has this problem
  • 485 views
  • Last reply by stevensj5

more options

I run a bed and breakfast. I have a Linksys router (EA6200). Through the Linksys support, I have found solutions to help the sign in page appear for my guests in IE and Google Chrome. Unfortunately, it still doesn't load in Firefox.

I want this to work just like when you go into a coffee shop or a fast food restaurant with WiFi. I don't want to be telling guests that they must do this or that unless it is really simple to do.

Any reason why this doesn't work in Firefox and how to correct it?

Chosen solution

jsher2000, you are brilliant, but I guess you've heard that before. The bypassing cache (Ctrl + Shift + R) didn't work, but putting in another URL worked like a charm.

PROBLEM SOLVED!

Read this answer in context 👍 0

All Replies (4)

more options

Sometimes, because Firefox is very tenacious in holding on to cached pages, simply starting Firefox with the home page doesn't trigger the router login page. Instead, the user may need to request an address that they don't normally visit, or run a search from the search bar. Alternately, they could try a reload that bypasses the cache.

  • Windows: Ctrl+Shift+r
  • Mac: Command+Shift+r
  • Linux: Ctrl+Shift+r

I don't have a good way to test what is going to be simplest or best in your case. Can you experiment a bit and see whether any of that helps?

more options

Thanks for the answer. Unfortunately, it didn't work.

more options

Hi stevensj5, none of those worked: reload bypassing cache, going to a new site not visited before, or running a search from the search bar?

I wonder whether part of the problem is HTTPS. If you request a regular HTTP page does the router intercept it?

more options

Chosen Solution

jsher2000, you are brilliant, but I guess you've heard that before. The bypassing cache (Ctrl + Shift + R) didn't work, but putting in another URL worked like a charm.

PROBLEM SOLVED!