X
Tap here to go to the mobile version of the site.

Support Forum

Profile bug? "unresponsive plugin" Shockwave (/questions/970014)

Posted

While using almost anything that involves Shockwave Flash, at some point it will suddenly hang Firefox, and eventually display a 'Plugin not responding' message. Since even adverts on pages are using flash, this is happening ALL the time.

I've uninstalled and reinstalled the current version of Flash; no luck.

While using almost anything that involves Shockwave Flash, at some point it will suddenly hang Firefox, and eventually display a 'Plugin not responding' message. Since even adverts on pages are using flash, this is happening ALL the time. I've uninstalled and reinstalled the current version of Flash; no luck.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • VLC media player Web Plugin 2.1.0
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.9.1.16010
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • ActiveGS Emulator 3.6.1307
  • Unity Player 4.1.2f1
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • NPWLPG
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • Delivery Network Acceleration by BitTorrentâ„¢
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • BlackBerry WebSL Browser Plug-In
  • Yahoo Application State Plugin version 1.0.0.7
  • Office Authorization plug-in for NPAPI browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • ActiveGS 3.6.1307 (activegs@freetoolsassociation.com)
  • Bloody Vikings! 0.5.6 (bloodyvikings@ffs.bplaced.net)
  • ChatZilla 0.9.90.1 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2})
  • Exif Viewer 2.00 (exif_viewer@mozilla.doslash.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Default Manager 2.2 ({3252b9ae-c69a-4eaf-9502-dc9c1f6c009e}) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Freemake Video Downloader Plugin 1.0.0 (fmdownloader@gmail.com) (Inactive)
  • Freemake Youtube Download Button 1.0.0 (ytfmdownloader@gmail.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Move Media Player 7 (moveplayer@movenetworks.com) (Inactive)
  • Norton Toolbar 2014.6.2.3 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 12.0.4.5 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 9300 GE
  • adapterDescription2:
  • adapterDeviceID: 0x06e0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 7.0.6002.23200
  • driverDate: 1-18-2013
  • driverDate2:
  • driverVersion: 9.18.13.1106
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 9300 GE Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • font.internaluseonly.changed: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1389459698
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.nppandowebplugin: 0
  • plugin.state.npqmp: 0
  • plugin.state.nprlsecurepluginlayer: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1387668010

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
3598 solutions 32243 answers

One mitigating strategy you could adopt temporarily is to switch the Flash plugin to "click-to-play" so that sites can't use it without your approval. To do that, open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column click Plugins, then find Shockwave Flash and set it to "Ask to Activate". On pages that want to use Flash, you will see some combination of the following:

  • Link in a blank rectangle where Flash was blocked
  • Notification icon in the address bar similar to a piece of Lego
  • Infobar sliding down between the toolbar area and the top of the page
One mitigating strategy you could adopt temporarily is to switch the Flash plugin to "click-to-play" so that sites can't use it without your approval. To do that, open the Add-ons page using either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column click Plugins, then find Shockwave Flash and set it to "Ask to Activate". On pages that want to use Flash, you will see some combination of the following: * Link in a blank rectangle where Flash was blocked * Notification icon in the address bar similar to a piece of Lego * Infobar sliding down between the toolbar area and the top of the page
jscher2000
  • Top 10 Contributor
3598 solutions 32243 answers

This is some standard guidance that addresses the most common reasons for Flash problems in Firefox. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable the protected mode feature (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

This is some standard guidance that addresses the most common reasons for Flash problems in Firefox. I'm sure you've seen some of it before, but just in case: (1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them. (2) Disable hardware graphics acceleration in Firefox and in Flash (A) In Firefox, un-check the box here and restart: orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available" (B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable the protected mode feature (Windows Vista/7/8) See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?]