Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Playback controls on YouTube and other video players are tiny

  • 7 replies
  • 75 have this problem
  • 9966 views
  • Last reply by shera

more options

I'm running Windows 8.1 on a Lenovo Yoga Pro 2 (really high resolution). I believe that this is causing the pause/play, volume, full screen, etc. buttons in YouTube and other video streaming players to be really uncomfortably small.

Also, Flash games only fill in the top-left corner of the space that they should. Sometimes this can be fixed by right-clicking and clicking Zoom in, but this option is not always there, and YouTube does not have this option, either.

I read something online about turning off HiDPI in the about:config page to fix this, but this option seems to have been removed.

Any ideas how to fix this? Thanks.

Chosen solution

Yes, you can file a report on Bugzilla: https://bugzilla.mozilla.org/

The form is pretty simple and you likely will get some follow-up questions cc'd to you by email. I would mention the variations you tried, such as hardware acceleration enabled or disabled, same result. Effect of zooming the page, effect of changing the device/pixel ratio.

Read this answer in context 👍 1

All Replies (7)

more options

You can set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 or on Windows 8 to 1.25 (percentage divided by DPI) and if necessary, adjust layout.css.devPixelsPerPx starting from 1.0 in 0.1 or 0.05 steps (1.1 or 0.9) to make icons show correctly.

See also:

Use an extension to adjust the text size in the user interface and the page zoom in the browser window.

You can look at this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx.

more options

Thanks for your reply, cor-el!

I have tried changing the devPixelsPerPx setting in about:config; however, this changes everything about the browser except for the YouTube playback controls.

Also, pressing Ctrl +/- (or Ctrl+scroll) zooms in on the rest of the window, but not the playback controls. It looks like to me that the two add-ons that you linked to at the end of your post would only change the zoom in the same way that Ctrl+ does.

Any other suggestions? Is this at least an issue that Mozilla knows about that might get fixed in future updates?

[attached: Screenshot of YouTube from my computer. The fonts, video, thumbnails, etc. are all normal size; just the playback controls are mini.]

Modified by shera

more options

Also possibly worth noting: The Adobe Flash Player Settings window (right-click > Settings...) is also tiny. This leads me to believe that this an issue with Adobe Flash Player, since I also have a similar issue with Flash games (i.e., Newgrounds).

[attached: Screenshot of YouTube with Adobe Flash Player Settings open.]

Modified by shera

more options

This reminds me a problem from last year with the Apple Retina display, where users who had disabled hardware acceleration had the plugin content shrunk to 1/4 size in one corner. However, your system details show hardware acceleration to be enabled and working, so that bug (which has been fixed) doesn't seem relevant.

I do think it's possible that the resolution (native: 3200x1800) is so high that it may exceed what was expected when the relevant code (in Firefox or in the Flash plugin) was written. I don't know how to research that, but you could try increasing the zoom substantially (e.g., 4 or more steps of Ctrl+) and reloading the page to see whether things start getting more proportional.

more options

Thanks for your reply, jscher2000.

I think I came across the thread about the Apple Retina display issue, but as you said, it didn't really help much.

I believe you're right that my resolution is just so high that it's causing an issue with displaying the Flash content.

This isn't an issue with Chrome or IE, but I was hoping to stick with Firefox, since Chrome fixes it by changing the resolution of the browser (ugh) and I can't get used to using IE.

In any case, should/can I file a bug report about this, and how would I do that?

Modified by shera

more options

Chosen Solution

Yes, you can file a report on Bugzilla: https://bugzilla.mozilla.org/

The form is pretty simple and you likely will get some follow-up questions cc'd to you by email. I would mention the variations you tried, such as hardware acceleration enabled or disabled, same result. Effect of zooming the page, effect of changing the device/pixel ratio.

more options

Found a half-solution:

In Firefox, go to https://www.youtube.com/html5 and click the "Request the HTML5 player" button.

This forces some (but not all) of the videos on YouTube to have normal-sized controls. I'm not sure why only some videos will play with the HTML5 player and others will play with Flash player. (Any idea, anyone?)

This doesn't fix the issue with other video players and Flash games, but it's something.