Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Get add-ons" page on "add-ons manager" in russian instead of english.What to do?

  • 9 replies
  • 1 has this problem
  • 43 views
  • Last reply by DynamiteT

more options

"Get add-ons" page on "add-ons manager" in russian instead of english. How can i change that specific page back to English.

Chosen solution

In case it's a weird glitch with obsolete cached files or broken cookies, you could open the Add-ons site directly and do the usual:

https://addons.mozilla.org/

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Read this answer in context 👍 0

All Replies (9)

more options

Is this the only "site" that comes up in Russian, or do you generally want Russian for other sites but just not this site?

more options

Only site.Don't know a word of Russian. I came across a Russian site a while a go but I used google translator.

more options

The standard URL for that page uses the %LOCALE% variable. Yours appears to be en-GB, so it's puzzling that the page you get is not in British English.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste geta and pause while the list is filtered

(3) If any of the extensions.getAddons.category.url preferences are bolded and user set, you can right-click them and use Reset to return them to the default.

more options

Chosen Solution

In case it's a weird glitch with obsolete cached files or broken cookies, you could open the Add-ons site directly and do the usual:

https://addons.mozilla.org/

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Did you try to change the ru part in the URL on the location bar to en-GB or en-US or leave out this part and let the server handle it?

more options

tried it but it still showed in russian.

more options

Going to try this now then.

more options

I had not touched the url once.

more options

Thanks a lot, this has solved it.The site is no longer in Russian but English.