X
Tap here to go to the mobile version of the site.

Support Forum

Why does private browsing close unexpectedly sometimes on Windows 8.1?

Posted

I had all these tabs open in private browsing but then it suddenly closed. I don't get any crash reports or anything, it just closes as if I'm the one who clicked on the 'x' - my cursor was nowhere near it. I thought it might have something to do with my touchpad but I can't find any solution to this online. There are certain ways to close apps in Windows 8.1 but it requires me to move my mouse to the top right corner which I don't do.

I tried different swipe actions on my touchpad while using firefox but nothing happens. Private browsing just closes on random occasions.

Sometimes I'm using private browsing and when I click on a different tab, instead I've been switched to firefox in non-private browsing mode (although my tabs don't move over, it just switches to that window).

I had all these tabs open in private browsing but then it suddenly closed. I don't get any crash reports or anything, it just closes as if I'm the one who clicked on the 'x' - my cursor was nowhere near it. I thought it might have something to do with my touchpad but I can't find any solution to this online. There are certain ways to close apps in Windows 8.1 but it requires me to move my mouse to the top right corner which I don't do. I tried different swipe actions on my touchpad while using firefox but nothing happens. Private browsing just closes on random occasions. Sometimes I'm using private browsing and when I click on a different tab, instead I've been switched to firefox in non-private browsing mode (although my tabs don't move over, it just switches to that window).

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • VLC media player Web Plugin 2.1.0
  • 5.1.20913.0
  • Foxit Reader Plug-In For Firefox and Netscape
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

guigs 1072 solutions 11697 answers
[https://bugzilla.mozilla.org/show_bug.cgi?id=928068] ?
guigs 1072 solutions 11697 answers

Hi, Thank you for contacting support. It does not look like that is what is happening. Do you often use hot corners for other applications?

If you can reproduce this in Safe Mode and in a New profile, please create a bug for this in bugzilla with the steps you took and including the expected results and actual results. _____ Instructions for safe mode


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Hi, Thank you for contacting support. It does not look like that is what is happening. Do you often use hot corners for other applications? If you can reproduce this in Safe Mode and in a New profile, please create a bug for this in bugzilla with the steps you took and including the expected results and actual results. _____ Instructions for safe mode '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.''