X
Tap here to go to the mobile version of the site.

Support Forum

Videos like on AOL begin to play, then the video blanks out and the audio continues. If I run Firefox in "Safe Mode" it works. disabling plug-ins doesn't work

Posted

TED talks, AOL videos and others will begin with a flash of the video, then go blank. The audio continues. I deleted the flash and quicktime plugins - no luck. I restarted Firefox in safe mode and it works fine. I then restarted and disabled all the plugins -- no luck. Internet Explorer works fine. Any ideas?

TED talks, AOL videos and others will begin with a flash of the video, then go blank. The audio continues. I deleted the flash and quicktime plugins - no luck. I restarted Firefox in safe mode and it works fine. I then restarted and disabled all the plugins -- no luck. Internet Explorer works fine. Any ideas?

Chosen solution

One of the feature of Safe Mode is that it disables Firefox's use of hardware acceleration for graphics. This works around incompatibilities with certain graphics driver software.

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect after you exit and restart Firefox.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; BRI/1; MAAU; Zune 4.7; .NET4.0C; InfoPath.3; .NET4.0E)

More Information

Application Basics
------------------
Name: Firefox
Version: 26.0
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Extensions
----------
Name: Hotspot Shield Extension
Version: 3.19
Enabled: false
ID: afext@anchorfree.com
Name: WBE Paste
Version: 1.3
Enabled: false
ID: wbepaste@starfield
Important Modified Preferences
------------------------------
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 358400
browser.places.smartBookmarksVersion: 4
browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
browser.startup.homepage_override.buildID: 20131205075310
browser.startup.homepage_override.mstone: 26.0
extensions.lastAppVersion: 26.0
gfx.direct3d.last_used_feature_level_idx: 0
network.cookie.prefsMigrated: true
places.history.expiration.transient_current_max_pages: 101825
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
Graphics
--------
Adapter Description: Intel(R) HD Graphics
Adapter Description (GPU #2): NVIDIA GeForce 310M
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: Unknown
Adapter RAM (GPU #2): 1024
ClearType Parameters: Gamma: 2200 Pixel Structure: RGB
Device ID: 0x0046
Device ID (GPU #2): 0x0a70
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.18245)
Driver Date: 1-10-2012
Driver Date (GPU #2): 9-5-2010
Driver Version: 8.15.10.2622
Driver Version (GPU #2): 8.17.12.5964
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x8086
Vendor ID (GPU #2): 0x10de
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
JavaScript
----------
Incremental GC: true
Accessibility
-------------
Activated: false
Prevent Accessibility: 0
Library Versions
----------------
NSPR
Expected minimum version: 4.10.2
Version in use: 4.10.2
NSS
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSMIME
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSSL
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSUTIL
Expected minimum version: 3.15.3.1
Version in use: 3.15.3.1

jscher2000
  • Top 10 Contributor
3598 solutions 32242 answers

Actually, it appears you have done this already. Never mind!

What is the Hotspot Shield Extension for? A user in another thread said he had a lot of Youtube problems from that extension (but he didn't want to give it up).

Instead of disabling plugins, could you try disabling that extension? You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions.

If a link appear above the extension to restart Firefox, go ahead and click that. If you are in a regular (non-private session), Firefox should automatically restore your open windows and tabs.

Does that improve things?

''Actually, it appears you have done this already. Never mind!'' What is the Hotspot Shield Extension for? A user in another thread said he had a lot of Youtube problems from that extension (but he didn't want to give it up). Instead of disabling plugins, could you try disabling that extension? You can do that on the Add-ons page. Either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Extensions. If a link appear above the extension to restart Firefox, go ahead and click that. If you are in a regular (non-private session), Firefox should automatically restore your open windows and tabs. Does that improve things?

Modified by jscher2000

jscher2000
  • Top 10 Contributor
3598 solutions 32242 answers

Chosen Solution

One of the feature of Safe Mode is that it disables Firefox's use of hardware acceleration for graphics. This works around incompatibilities with certain graphics driver software.

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect after you exit and restart Firefox.

One of the feature of Safe Mode is that it disables Firefox's use of hardware acceleration for graphics. This works around incompatibilities with certain graphics driver software. orange Firefox button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" This takes effect after you exit and restart Firefox.
Wesley Branton 183 solutions 2297 answers

Helpful Reply

Please try any the below:

Please report back soon.

Please try any the below: *Disable the Firefox hardware acceleration <sup>[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration (More Details)]</sup> *Disable the Flashplayer acceleration <sup>[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration-flash (More Details)]</sup> Please report back soon.

Question owner

Thanks very much for your help. Well - I deleted Hotspot Shield to no avail. Now no plugins or extensions are enabled. Killing the hardware accelerator DID work! But why? It has never had this problem before today. Was there an update that would have made that sensitive? I am not sure I like it that the accelerator is disabled.

Thanks very much for your help. Well - I deleted Hotspot Shield to no avail. Now no plugins or extensions are enabled. Killing the hardware accelerator DID work! But why? It has never had this problem before today. Was there an update that would have made that sensitive? I am not sure I like it that the accelerator is disabled.

Modified by thedavee

jscher2000
  • Top 10 Contributor
3598 solutions 32242 answers

As the Firefox developers enable different features to use hardware acceleration, new problems may arise even if Firefox was previously stable with the same graphics drivers. And on the other hand, graphics driver updates may have been bundled in with the recent round of Windows updates, or updates from your system manufacturer. It's apparently a complicated problem making these things work together; some user have it way worse: frequent blue screen crashes...

Hardware acceleration offloads graphics processing from your main system CPU onto the graphics card. If you use a lot of 3D in Firefox, you probably will notice a difference, but for regular 2D graphics and media, not so much.

As the Firefox developers enable different features to use hardware acceleration, new problems may arise even if Firefox was previously stable with the same graphics drivers. And on the other hand, graphics driver updates may have been bundled in with the recent round of Windows updates, or updates from your system manufacturer. It's apparently a complicated problem making these things work together; some user have it way worse: frequent blue screen crashes... Hardware acceleration offloads graphics processing from your main system CPU onto the graphics card. If you use a lot of 3D in Firefox, you probably will notice a difference, but for regular 2D graphics and media, not so much.

Question owner

Thanks for the help! I really appreciate it jscher. Also thanks computer whiz

Happy holidays!

Thanks for the help! I really appreciate it jscher. Also thanks computer whiz Happy holidays!
Wesley Branton 183 solutions 2297 answers

No problem.
I'm just glad to help you.

Thank you using the Mozilla support forum.
Happy holidays to you as well.

No problem.<br> I'm just glad to help you. Thank you using the Mozilla support forum.<br> Happy holidays to you as well.