Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox's Media Foundation support breaks music playback and turning it off doesn't do anything.

more options

A friend sent me an MP3 link about a month ago, and I was confused when Firefox told me the file was corrupt. I figured it was just the server it was on.

Then, I stopped being able to listen to music posted through Tumblr. I figured they just updated their player and broke something.

Then I tried listening directly to an MP3 on another site tonight, and again, Firefox told me "Video can't be played because the file is corrupt." I dashed around to a handful of other sites and every single one of them told me the same thing when I tried to play an MP3 file.

After doing some investigation, I learned that the Firefox team has tried to implement their own internal music playback system that either can't find a codec or isn't detecting these files as music properly. Now, a long time ago, I got pretty used to all these files playing through Quicktime, to the point where I would specifically install Quicktime with each version of Windows just to restore this functionality. But now Firefox is overriding that functionality for some reason.

The culprit seemed to be the option "media.windows-media-foundation.enabled", which I promptly disabled. Didn't help. Firefox is still insisting that these files are corrupt instead of letting Quicktime handle them.

This site also suggested turning plugins.load_appdir_plugins to true, but that didn't help, either.

It would seem Firefox is intentionally relying on a part of Windows that I don't have, because I'm still stuck on Windows XP (video capture hardware I depend on doesn't have drivers for Vista on up). The annoying part is that I can't seem to change it back to the way it was, and I'm pretty angry because this has broken a significant portion of the internet for me.

Chosen solution

The technology for playing MP3s on Windows XP is called DirectShow. Do you want to try flipping the following preference and see whether that does anything useful?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false.

I don't know whether that changes takes effect immediately or after you exit and restart Firefox.

Read this answer in context 👍 13

All Replies (5)

more options

Hello,

Would it be fair to summarize your issue that you are unable to play mp3 files using the quicktime plugin on Firefox 26.0 on Windows XP. You are noticing that the browser is trying to play the MP3 files directly and reporting errors, where you expect it to load them in the quicktime plugin.

Would that be a fair description of the issue?

Thank you

more options

That sounds about right, yes. Firefox's internal media player stuff is telling me ALL MP3 files are corrupt, when that is clearly not the case, and keeps doing so even after I disable Firefox's Windows Media Foundation support. It refuses to let Quicktime handle MP3 files.

more options

One of the headline changes in Firefox 26 is "Support for MP3 decoding on Windows XP, completing MP3 support across Windows OS versions." This was late to arrive because Microsoft does not provide media foundation for Windows XP, only Vista and later.

So... that could explain new problems since the release of Firefox 26, but were you using it in beta release before, or did you have the problem in Firefox 25 as well?

more options

Chosen Solution

The technology for playing MP3s on Windows XP is called DirectShow. Do you want to try flipping the following preference and see whether that does anything useful?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false.

I don't know whether that changes takes effect immediately or after you exit and restart Firefox.

more options

That seems to have done the trick! Thanks a million.