X
Tap here to go to the mobile version of the site.

Support Forum

Firefox automatically opens addon page on every startup

Posted

I knew the App Market/Conduit virus was on my computer, so I got rid of it-or so it seems. Now every time I turn on or restart the computer Firefox automatically opens, about:newaddon?id={64d64833-9296-421b-a362-83cfbd6291b6} and the addon name shows blank; a few seconds later it automatically closes. I did find out that that url has to do with App Market. But when I open Firefox again, it's as if nothing happened. There are no crash reports on this, despite the many times it's happened. I've tried scanning my computer many times afterward with no luck. There is no user.js file, and I deleted every extension and program related to Conduit.

I knew the App Market/Conduit virus was on my computer, so I got rid of it-or so it seems. Now every time I turn on or restart the computer Firefox automatically opens, about:newaddon?id={64d64833-9296-421b-a362-83cfbd6291b6} and the addon name shows blank; a few seconds later it automatically closes. I did find out that that url has to do with App Market. But when I open Firefox again, it's as if nothing happened. There are no crash reports on this, despite the many times it's happened. I've tried scanning my computer many times afterward with no luck. There is no user.js file, and I deleted every extension and program related to Conduit.

Chosen solution

I found the solution! It turns out the adware set my computer so it would go to Firefox on startup. Now, when you go to your normal Windows startup entry things, it only says Firefox, nothing else.

Then I installed CCleaner and looked at the startup entries there. In the Firefox section not only did it have the program, but also the URL it redirects me to. I deleted it, restarted, and it worked!

Now, to find out what BackgroundContainer.dll is... ^^;

I downloaded CCleaner from a site called Bleeping Computer. I think my mistake was downloading from CNET, which is sad because I always thought that site was reputable and trustworthy. But do not be fooled... MyWOT.com says CNET is no longer that safe. Bleeping Computer, however, is much safer and trusted. uwu

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • GEPlugin
  • iTunes Detector Plug-in
  • 5.1.20913.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • WinZip Courier Plugin for Mozilla Firefox
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

Diego Victor
  • Top 25 Contributor
  • Moderator
618 solutions 3966 answers

Helpful Reply

What is the value in "browser.startup.homepage" on "about:config" ?

What is the value in "browser.startup.homepage" on "about:config" ?

Helpful Reply

about:home

about:home
Diego Victor
  • Top 25 Contributor
  • Moderator
618 solutions 3966 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

'''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Question owner

Is there a way to make it stay in safe mode, all the time? From that it looks like you can only start safe mode manually every time you open Firefox, which doesn't help with the fact that it opens and closes automatically.

In any case, that doesn't solve the problem

Is there a way to make it stay in safe mode, all the time? From that it looks like you can only start safe mode ''manually'' every time you open Firefox, which doesn't help with the fact that it opens and closes ''automatically''. In any case, that doesn't solve the problem

Modified by Patfo

ideato
  • Top 25 Contributor
756 solutions 5468 answers

Hello Patfo, check also if you have something related to appmarket- Toolbar/Conduit in windows %ProgramFiles%

or C:\Program Files\Mozilla Firefox

and in : Application Data\Mozilla\Firefox\Profiles\your profile(es)\extensions


thank you

Hello Patfo, check also if you have something related to appmarket- Toolbar/Conduit in windows '''%ProgramFiles%''' or C:\Program Files\Mozilla Firefox and in : Application Data\Mozilla\Firefox\Profiles\''your profile(es)''\'''extensions''' thank you

Question owner

Sorry for the late reply--I have found nothing related to it in ProgramFiles. The only files in the extensions folder are for the extension NoScript.

Sorry for the late reply--I have found nothing related to it in ProgramFiles. The only files in the extensions folder are for the extension NoScript.
cor-el
  • Top 10 Contributor
  • Moderator
12751 solutions 117172 answers

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

Question owner

It's just firefox.exe, nothing after it

It's just firefox.exe, nothing after it

Chosen Solution

I found the solution! It turns out the adware set my computer so it would go to Firefox on startup. Now, when you go to your normal Windows startup entry things, it only says Firefox, nothing else.

Then I installed CCleaner and looked at the startup entries there. In the Firefox section not only did it have the program, but also the URL it redirects me to. I deleted it, restarted, and it worked!

Now, to find out what BackgroundContainer.dll is... ^^;

I downloaded CCleaner from a site called Bleeping Computer. I think my mistake was downloading from CNET, which is sad because I always thought that site was reputable and trustworthy. But do not be fooled... MyWOT.com says CNET is no longer that safe. Bleeping Computer, however, is much safer and trusted. uwu

I found the solution! It turns out the adware set my computer so it would go to Firefox on startup. Now, when you go to your normal Windows startup entry things, it only says Firefox, nothing else. Then I installed CCleaner and looked at the startup entries there. In the Firefox section not only did it have the program, but also the URL it redirects me to. I deleted it, restarted, and it worked! Now, to find out what BackgroundContainer.dll is... ^^; I downloaded CCleaner from a site called Bleeping Computer. I think my mistake was downloading from CNET, which is sad because I always thought that site was reputable and trustworthy. But do not be fooled... MyWOT.com says CNET is no longer that safe. Bleeping Computer, however, is much safer and trusted. uwu

Modified by Patfo