X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox doesn't warn me before closing multiple tabs!

Posted

I don't know when this started, probably a few versions ago, but it is driving me mad! And before you ask, I already checked about:config and both warning options are true. After searching a bit, I have found that the cause of this may be that I also have "Show my windows and tabs from last time" selected. Are these two options really incompatible, or is this just a common bug? If they are, is this by design? I close Firefox on accident all the time because Windows does not always automatically set the most recent or top-most window as active, and it is very annoying to have to wait for xmarks to sync when I don't even want to close FF in the first place. If there is currently no way to have firefox warn before closing and restore your tabs, are there any easy work arounds or addons that solve this? Sorry about all the questions but this is so frustrating.

Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • VLC media player Web Plugin 2.0.6
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Happy Cloud Web Plugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 0.3
  • Nexon Game Controller
  • Best Buy pc app Detector Plug-in
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • Firefox 25.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.1 (adblockpopups@jessehakanen.net)
  • Add to Search Bar 2.2 (add-to-searchbox@maltekraus.de)
  • Beef Taco (Targeted Advertising Cookie Opt-Out) 1.3.7 (john@velvetcache.org)
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Brief 1.7.2 (brief@mozdev.org)
  • DivX Web Player 2.0.2.039 (DivXWebPlayer@divx.com)
  • Element Hiding Helper for Adblock Plus 1.2.3 (elemhidehelper@adblockplus.org)
  • FlashGot 1.5.5.95 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • LastPass 2.0.20 (support@lastpass.com)
  • LuckyBar 0.3.1.1 (jid0-RZ1wv8WwA7CKjr2eJZV648uKiuE@jetpack)
  • Space Next 0.33 ({c71ff04d-f001-1fc1-1fc1-c71ff04df005})
  • Tab Slideshow 5.0 ({16466865-007f-4ce4-aeb5-a0aa8b34c61a})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Xmarks 4.2.1 (foxmarks@kei.com)
  • Content Blocker 13.0.1.4372 (content_blocker@kaspersky.com) (Inactive)
  • Cookies Manager+ 1.5.2 ({bb6bc1bb-f824-4702-90cd-35e2fb24f25d}) (Inactive)
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8}) (Inactive)
  • HTTPS-Everywhere 3.4.3 (https-everywhere@eff.org) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4372 (url_advisor@kaspersky.com) (Inactive)
  • Location Bar Enhancer 5.1 (UIEnhancer@girishsharma) (Inactive)
  • Stop YouTube Autoplay 1.0.3 (jid0-Pm0nbsggUvL00CBoW6YwCaqv8bk@jetpack) (Inactive)
  • Virtual Keyboard 13.0.1.4372 (virtual_keyboard@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 560M
  • adapterDescription2:
  • adapterDeviceID: 0x1251
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-14-2013
  • driverDate2:
  • driverVersion: 9.18.13.1144
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 560M Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.max_tabs_undo: 15
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • gfx.direct3d.checkDX10: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&rls=org.mozilla:en-US:official&client=firefox-a&sourceid=navclient&gfns=1&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1386988361
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npuplaypc: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.brief.sqlite: 1385263081
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1386996806

Misc

  • User JS: No
  • Accessibility: No
titoxproxy 6 solutions 64 answers

Hello technologically_inept,

go to Settings > Tabs > and tick the box "Warn me when I close many tabs." (second box).

Do not hesitate to contact us further.

Was this helpful to you? 5
Reply
Abhi Khatri 0 solutions 5 answers

Go to Options then click on Tabs. Please tick Warn Me When Closing Multiple Tabs and click on OK. I hope this will help you to fix your problem.

Regards Abhi Khatri

Was this helpful to you? 3
Reply

Question owner

I guess this is my fault for not stating it directly (although it should have been obvious from the context of my post) but I have that checked. I can't help but think you only read the title based on your responses, but thank you nonetheless. I will await further assistance.

Was this helpful to you? 0
Reply
guigs2
  • Top 10 Contributor
  • Administrator
  • Moderator
122 solutions 1463 answers

There was another question like this a month back, but could not find root cause, may I confirm how you close Firefox when you do not see the warning? It comes up when I hit the X button but not when I hit File> Exit, is this the same behavior for you on version 25?

Cheers,

Rachel

Was this helpful to you? 1
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.