X
Tap here to go to the mobile version of the site.

Support Forum

Enable JAVA plugin on Firefox 25 in Linux

Posted

Java is installed and running:

java -version

java version "1.7.0_45" Java(TM) SE Runtime Environment (build 1.7.0_45-b18) Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)

created symbolic link - pwd /home/kramer9/Images/firefox/plugins [kramer9@oc6138011027 plugins]$ ls -al lrwxrwxrwx. 1 kramer9 kramer9 49 Dec 13 12:34 libnpjp2.so -> /opt/java/64/jre1.7.0_45/bin/lib/i386/libnpjp2.so

Still no luck - ideas?

Java is installed and running: java -version java version "1.7.0_45" Java(TM) SE Runtime Environment (build 1.7.0_45-b18) Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode) created symbolic link - pwd /home/kramer9/Images/firefox/plugins [kramer9@oc6138011027 plugins]$ ls -al lrwxrwxrwx. 1 kramer9 kramer9 49 Dec 13 12:34 libnpjp2.so -> /opt/java/64/jre1.7.0_45/bin/lib/i386/libnpjp2.so Still no luck - ideas?

Chosen solution

Ok all is well had todo this step:

about:config

   In the address bar, type "about:config" (with no quotes), and press Enter.
   Click "I'll be careful, I promise"
   In the search bar, search for "javascript.enabled" (with no quotes).
   Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled. 

To Re-enable JavaScript, repeat these steps.

Thanks to all for the help!!

Read this answer in context 2
gnittala 25 solutions 307 answers

Helpful Reply

Hello, Can you please confirm if the issue is that the Java plugin is not showing up in the Addons on Firefox? Or is it that the Java installed is not functioning properly.

If the latter please check this article to see if it can help How to allow Java on trusted sites. If not, please confirm you are following the steps mentioned in the official Sun site Installing Sun JRE for Firefox.

Also, please confirm that you are running a 64-bit Firefox. I see this on my Linux Mint machine, when I try 'file /usr/lib/firefox/firefox'

firefox: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=0xd3dd6eefdfcb323673b3e1fb0c4cc30093e67a78, stripped

Hello, Can you please confirm if the issue is that the Java plugin is not showing up in the Addons on Firefox? Or is it that the Java installed is not functioning properly. If the latter please check this article to see if it can help [[How to enable Java if it's been blocked]]. If not, please confirm you are following the steps mentioned in the official Sun site [https://www.java.com/en/download/help/linux_install.xml Installing Sun JRE for Firefox]. Also, please confirm that you are running a 64-bit Firefox. I see this on my Linux Mint machine, when I try 'file /usr/lib/firefox/firefox' firefox: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=0xd3dd6eefdfcb323673b3e1fb0c4cc30093e67a78, stripped
cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149981 answers
If you have a (default) 32 bit Firefox version then you need to install and use the 32 bit Java version. *http://kb.mozillazine.org/Java See also: *http://kb.mozillazine.org/Determining_plugin_directory_on_Linux *https://developer.mozilla.org/en/Gecko_Plugin_API_Reference/Plug-in_Basics#How_Gecko_finds_plug-ins

Question owner

Java is functioning correctly.

I think its the browser version: [kramer9@oc6138011027 ~]$ file /home/kramer9/Images/firefox/firefox /home/kramer9/Images/firefox/firefox: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped [kramer9@oc6138011027 ~]$

Let me try to unstall firefox and reinstall the 64 bit version after I find it. I will post an update

Java is functioning correctly. I think its the browser version: [kramer9@oc6138011027 ~]$ file /home/kramer9/Images/firefox/firefox /home/kramer9/Images/firefox/firefox: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped [kramer9@oc6138011027 ~]$ Let me try to unstall firefox and reinstall the 64 bit version after I find it. I will post an update

Question owner

Ok still didnt work.

Created symbolic link in the 'new x64 installation directory' libnpjp2.so -> /opt/java/64/jre1.7.0_45/lib/i386/libnpjp2.so

$pwd /home/kramer9/Images/FF25x64/firefox

$file firefox firefox: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped

$ java -version java version "1.7.0_45" Java(TM) SE Runtime Environment (build 1.7.0_45-b18) Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode) [kramer9@oc6138011027 lib]$

I go to the plugin tab in firefox and no plugins, and I did verify I am running out of the x64 directory

Ok still didnt work. Created symbolic link in the 'new x64 installation directory' libnpjp2.so -> /opt/java/64/jre1.7.0_45/lib/i386/libnpjp2.so $pwd /home/kramer9/Images/FF25x64/firefox $file firefox firefox: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped $ java -version java version "1.7.0_45" Java(TM) SE Runtime Environment (build 1.7.0_45-b18) Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode) [kramer9@oc6138011027 lib]$ I go to the plugin tab in firefox and no plugins, and I did verify I am running out of the x64 directory
cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149981 answers

Where did you place the symlink?

Does Firefox find other plugins located in the same directory?

Where did you place the symlink? Does Firefox find other plugins located in the same directory?

Question owner

[kramer9@oc6138011027 plugins]$ pwd /home/kramer9/Images/FF25x64/firefox/plugins

lrwxrwxrwx. 1 root root 45 Dec 16 12:03 libnpjp2.so -> /opt/java/64/jre1.7.0_45/lib/i386/libnpjp2.so

I created a plugins directory in the installation directory I installed FF in.

FF is running from /home/kramer9/Images/FF25x64/firefox

[kramer9@oc6138011027 plugins]$ pwd /home/kramer9/Images/FF25x64/firefox/plugins lrwxrwxrwx. 1 root root 45 Dec 16 12:03 libnpjp2.so -> /opt/java/64/jre1.7.0_45/lib/i386/libnpjp2.so I created a plugins directory in the installation directory I installed FF in. FF is running from /home/kramer9/Images/FF25x64/firefox
cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149981 answers

Helpful Reply

Does it work if you create a ~/.mozilla/plugins folder and place the symlink is this folder?

You can also check the about:plugins page or the pluginreg.dat file for paths used by other plugins.

Does it work if you create a ~/.mozilla/plugins folder and place the symlink is this folder? You can also check the about:plugins page or the pluginreg.dat file for paths used by other plugins.

Question owner

I backed out both 64 bit java and FF. Installed 32 bit on both, created lync in /usr/lib/mozilla/plugins

And I now have the plugin in the browser, I changed the 'when add on runs' to always activate.

I think I am that much closer

Now getting this error:

JavaScript Required

This Web site uses JavaScript in order to provide you with access to your published resources.

You must enable JavaScript in your browser. Contact your system administrator for assistance.

I backed out both 64 bit java and FF. Installed 32 bit on both, created lync in /usr/lib/mozilla/plugins And I now have the plugin in the browser, I changed the 'when add on runs' to always activate. I think I am that much closer Now getting this error: JavaScript Required This Web site uses JavaScript in order to provide you with access to your published resources. You must enable JavaScript in your browser. Contact your system administrator for assistance.

Chosen Solution

Ok all is well had todo this step:

about:config

   In the address bar, type "about:config" (with no quotes), and press Enter.
   Click "I'll be careful, I promise"
   In the search bar, search for "javascript.enabled" (with no quotes).
   Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled. 

To Re-enable JavaScript, repeat these steps.

Thanks to all for the help!!

Ok all is well had todo this step: about:config In the address bar, type "about:config" (with no quotes), and press Enter. Click "I'll be careful, I promise" In the search bar, search for "javascript.enabled" (with no quotes). Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled. To Re-enable JavaScript, repeat these steps. Thanks to all for the help!!
cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149981 answers

It is best to leave JavaScript in the default enabled state because a lot of website won't function properly with JavaScript disabled.

Use extensions like NoScript or YesScript if you want to block JavaScript.

It is best to leave JavaScript in the default enabled state because a lot of website won't function properly with JavaScript disabled. Use extensions like NoScript or YesScript if you want to block JavaScript.