Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Anyone having problems with script messages with the new versions of GMail and Yahoo Mail? All others seem fine and no problem with other browsers. Using FF25

  • 7 replies
  • 13 have this problem
  • 3181 views
  • Last reply by gioral

more options

Gmail and Yahoo mail are very slow to load. I get a script message almost every time instructing me to continue or stop script. Whatever I do stop or continue the browser goes white and locks up. I then have to restart Firefox. I have followed all suggestions on the help pages for slow or problematic email accounts. (cleared cache etc, reset etc etc) nothing fixes the issue. I only noticed the problem since the first update of FF25. Even stopping scripts on these pages is not acceptable as you are directed to pages that insist you must restart scripts. It is a nightmare! Both Gmail and Yahoomail are very slow responding to clicks as well.

Chosen solution

Your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.


You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Note that the "Application Data" folder in XP/Win2K and the "AppData" folder in Windows Vista and Windows 7 and later versions are hidden folders.

Read this answer in context 👍 0

All Replies (7)

more options

hello hickoryshirt, please try to reset firefox and see if this can address the issue (this will keep your bookmarks and passwords)...

more options

Already tried all those remedies as I stated in the question. None of them has worked.

more options

i was making this recommendation since your troubleshooting information shows that you have various custom network-preferences which might affect performance negatively and a user.js file in your profile folder which shouldn't be present in most cases (since it is used to overwrite a user's preferences).

more options

Phillip, Can yo please tell which js file you are referring to?

Thanks, Jim

As a side note. I also use The Firefox clone BlueMoon which does not have any of the issues that I am complaining about and also has the prefs files at least ones exactly like those in Firefox. I am asuming you are referring to the files created by Faster Fox add on. I removed that extension Reset Firefox and tried it that way and there was no change. I deleted that file as well and no change. So I reinstalled the add ons I have been using for years now. I guess the only answer is to remove My long time favorite browser ( Firefox) and simply go with BlueMoon. It's faster as well.

more options

Chosen Solution

Your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.


You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Note that the "Application Data" folder in XP/Win2K and the "AppData" folder in Windows Vista and Windows 7 and later versions are hidden folders.

more options

As I noted deleting these files and removing FasterFox ( which made the user file changes) then resetting Firefox did not result in a solution. The Gmail and Yahoomail pages are still extremely slow loading in Firefox even with all extensions etc removed or disabled. I still think there is a problem with Firefox! It uses inordinate amounts of ram as well. I have switched to Pale Moon and have removed Firefox. Sad, as I have noted before I have ALWAYS used Firefox and recommended it to everyone I Know and assist. I will have to recommend Pale Moon from now on until a better version of Firefox comes along. I will not give up hope that it will.

jim

more options

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

The above script message was what drove me crazy when opening Gmail. The problem was with Avast. Disabling the Avast online security add on solved the problem.Hope it help you too. Cheers

Modified by gioral