X
Tap here to go to the mobile version of the site.

Support Forum

PDF files don't open I have tried EVERYTHING to no avail please help

Posted

In the last couple of weeks I cannot open PDF files in Firefox. They open fine in Internet Explorer. I have been on the support forum now for over 2 hours and tried EVERYTHING suggested to no avail. It appears this is a common problem. Please help.

In the last couple of weeks I cannot open PDF files in Firefox. They open fine in Internet Explorer. I have been on the support forum now for over 2 hours and tried EVERYTHING suggested to no avail. It appears this is a common problem. Please help.

Chosen solution

I think I have solved it :)

In the address bar there is a padlock icon (but not always) I clicked on that then 'more information' then 'permissions' then changed adobe reader to 'allow' So now all attachments open. I then checked 'do this automatically from now on when the file opening dialog box came up. Thanks to everyone who contributed. Ray

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Google Update
  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122

Application

  • Firefox 25.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG Security Toolbar 17.1.2.1 (avg@toolbar) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon 3000 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9616
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon 3000 Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage: www.google.co.uk
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 25.0.1
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 93889
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No

Chosen Solution

I think I have solved it :)

In the address bar there is a padlock icon (but not always) I clicked on that then 'more information' then 'permissions' then changed adobe reader to 'allow' So now all attachments open. I then checked 'do this automatically from now on when the file opening dialog box came up. Thanks to everyone who contributed. Ray

I think I have solved it :) In the address bar there is a padlock icon (but not always) I clicked on that then 'more information' then 'permissions' then changed adobe reader to 'allow' So now all attachments open. I then checked 'do this automatically from now on when the file opening dialog box came up. Thanks to everyone who contributed. Ray
Ajay Kumar Jogawath 6 solutions 67 answers

Hello,

I am glad to hear that your problem has been resolved.

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently.

I hope you continue using our products and thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you have not already, please mark this thread as solved by marking the solution.<br> This will help other users experiencing similar problems find help faster and more efficiently. I hope you continue using our products and thank you for contacting Mozilla Support.