X
Tap here to go to the mobile version of the site.

Support Forum

How can I get my pay statements on the ADP portal to show up? I've restarted with add-ons disabled, and other browsers work; is this a Java or Flash issue?

Posted

http://portal.adp.com/ -> Pay & Taxes -> Pay Statements

There's a list of pay statements with links (blue text) from each pay date. If I click one, all these links turn to purple text, and I get taken to a page that it supposed to have a pay statement, but just has a big blank area where the statement should be. I'm pretty sure all my plugins are up to date.

Unfortunately, you need to have an account with ADP to check this out. Everyone else in my department who uses Firefox has had the same problem, though. It seems to be recent -- within the last month or two. Could it have something to do with Firefox updates? Again, it works on Chrome and Explorer.

http://portal.adp.com/ -> Pay & Taxes -> Pay Statements There's a list of pay statements with links (blue text) from each pay date. If I click one, all these links turn to purple text, and I get taken to a page that it supposed to have a pay statement, but just has a big blank area where the statement should be. I'm pretty sure all my plugins are up to date. Unfortunately, you need to have an account with ADP to check this out. Everyone else in my department who uses Firefox has had the same problem, though. It seems to be recent -- within the last month or two. Could it have something to do with Firefox updates? Again, it works on Chrome and Explorer.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.5.146
  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20125.0

Application

  • Firefox 25.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • feedly 16.0.512 (feedly@devhd)
  • Greasemonkey 1.8 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • HTTPS-Everywhere 3.1.4 (https-everywhere@eff.org)
  • Linkification 1.3.8 ({35106bca-6c78-48c7-ac28-56df30b51d2a})
  • Open Image In New Tab (update) 1.1.2 (daigonet@gmail.com)
  • Show Picture 2.7 (LDshowpicture_plashcor@gmail.com)
  • Stylish 1.3.1 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • YouTubeIT 0.6.2 (youtubeit_aechiara@gmail.com)
  • bomlabio 1.0.0 (firefox@bomlabio.biz) (Inactive)
  • Turn Off the Lights 2.1.0.32 (stefanvandamme@stefanvd.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0126
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 6-10-2011
  • driverDate2:
  • driverVersion: 8.15.10.2418
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • font.default.x-western: sans-serif
  • font.internaluseonly.changed: True
  • font.name.monospace.x-western: Consolas
  • font.name.sans-serif.x-western: Calibri
  • font.name.serif.x-western: Sylfaen
  • font.size.fixed.x-western: 15
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1385132169
  • places.history.expiration.transient_current_max_pages: 104253
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1384970510

Misc

  • User JS: Yes
  • Accessibility: No
the-edmeister
  • Top 10 Contributor
  • Moderator
4146 solutions 31238 answers

It;s very difficult to try to help figure out problems at websites that can't be accessed.


Please access the Web Console - https://developer.mozilla.org/en-US/docs/Tools/Web_Console - and copy / paste the messages you see.

Firefox button > Web Developer -> Web console


Another thing is to rule out a problem caused by add-ons, like the HTTPS Everywhere extension you have installed.
Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

It;s very difficult to try to help figure out problems at websites that can't be accessed. -------------- Please access the Web Console - https://developer.mozilla.org/en-US/docs/Tools/Web_Console - and copy / paste the messages you see. Firefox button > Web Developer -> Web console ------- Another thing is to rule out a problem caused by add-ons, like the HTTPS Everywhere extension you have installed. <br /> '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.''

Question owner

Yes, I already tried it in Safe Mode, but I still had the same problem.

Here's what I get on the Web Console:

[10:29:18.803] The X-Content-Security-Policy and X-Content-Security-Report-Only headers will be deprecated in the future. Please use the Content-Security-Policy and Content-Security-Report-Only headers with CSP spec compliant syntax instead. @ https://portal.adp.com/static/portlets/portal/theme/js/blank.html

[10:29:18.803] This site specified both an X-Content-Security-Policy/Report-Only header and a Content-Security-Policy/Report-Only header. The X-Content-Security-Policy/Report-Only header(s) will be ignored. @ https://portal.adp.com/static/portlets/portal/theme/js/blank.html

[10:29:22.393] GET https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css [HTTP/1.1 200 OK 411ms]

[10:29:22.501] Error in parsing value for 'white-space'. Declaration dropped. @ https://portal.adp.com/wps/myportal/sitemap/Employee/PayTax/PayStatements/!ut/p/c5/04_SB8K8xLLM9MSSzPy8xBz9CP0os3gfA1MzQyN_A3d3ZzdDA0d3N9eQAN8gI6Mgc6B8JE55A38jSnQbmFKk24CAbj-P_NxU_YLc0NCIckdFAJBaWnQ!/dl3/d3/L0lDU0lKSmdrS0NsRUpDZ3BSQ1NBL29Ob2dBRUlRaGpFS0lRQUJHY1p3aklDa3FTaFNOQkFOYUEhIS80QzFiOVdfTnIwZ0RFU1pJSlJERVNaTUpRaUlrZmchIS83X0wwNTYxMk8wR0dDRjEwQUdGRVRQTVIyMjc1L0tCWFlUMzU3NzAwMTIvaWJtLmludi8yNDYzNjc3Mzk4NTYvamF2YXguc2VydmxldC5pbmNsdWRlLnBhdGhfaW5mby8lMHBheXN0YXRlbWVudCUwbGlzdC5qc3A!/

[10:29:22.573] Content Security Policy: Directive default-src https://portal.adp.com:443 https://*.adp.com:443 https://*.google.com:443 violated by data:application/x-moz-playpreview-pdfjs;,

[10:29:22.761] Error in parsing value for 'cursor'. Declaration dropped. @ https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css:96

[10:29:22.761] Error in parsing value for 'white-space'. Declaration dropped. @ https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css:312

[10:29:22.762] Error in parsing value for 'cursor'. Declaration dropped. @ https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css:556

[10:29:22.762] Error in parsing value for 'cursor'. Declaration dropped. @ https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css:568

Yes, I already tried it in Safe Mode, but I still had the same problem. Here's what I get on the Web Console: [10:29:18.803] The X-Content-Security-Policy and X-Content-Security-Report-Only headers will be deprecated in the future. Please use the Content-Security-Policy and Content-Security-Report-Only headers with CSP spec compliant syntax instead. @ https://portal.adp.com/static/portlets/portal/theme/js/blank.html [10:29:18.803] This site specified both an X-Content-Security-Policy/Report-Only header and a Content-Security-Policy/Report-Only header. The X-Content-Security-Policy/Report-Only header(s) will be ignored. @ https://portal.adp.com/static/portlets/portal/theme/js/blank.html [10:29:22.393] GET https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css [HTTP/1.1 200 OK 411ms] [10:29:22.501] Error in parsing value for 'white-space'. Declaration dropped. @ https://portal.adp.com/wps/myportal/sitemap/Employee/PayTax/PayStatements/!ut/p/c5/04_SB8K8xLLM9MSSzPy8xBz9CP0os3gfA1MzQyN_A3d3ZzdDA0d3N9eQAN8gI6Mgc6B8JE55A38jSnQbmFKk24CAbj-P_NxU_YLc0NCIckdFAJBaWnQ!/dl3/d3/L0lDU0lKSmdrS0NsRUpDZ3BSQ1NBL29Ob2dBRUlRaGpFS0lRQUJHY1p3aklDa3FTaFNOQkFOYUEhIS80QzFiOVdfTnIwZ0RFU1pJSlJERVNaTUpRaUlrZmchIS83X0wwNTYxMk8wR0dDRjEwQUdGRVRQTVIyMjc1L0tCWFlUMzU3NzAwMTIvaWJtLmludi8yNDYzNjc3Mzk4NTYvamF2YXguc2VydmxldC5pbmNsdWRlLnBhdGhfaW5mby8lMHBheXN0YXRlbWVudCUwbGlzdC5qc3A!/ [10:29:22.573] Content Security Policy: Directive default-src https://portal.adp.com:443 https://*.adp.com:443 https://*.google.com:443 violated by data:application/x-moz-playpreview-pdfjs;, [10:29:22.761] Error in parsing value for 'cursor'. Declaration dropped. @ https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css:96 [10:29:22.761] Error in parsing value for 'white-space'. Declaration dropped. @ https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css:312 [10:29:22.762] Error in parsing value for 'cursor'. Declaration dropped. @ https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css:556 [10:29:22.762] Error in parsing value for 'cursor'. Declaration dropped. @ https://portal.adp.com/wps/PA_CSSRemotePortApp/PortletAdapterTester?portletURL=http%3A%2F%2FWWVIP%3A9080%2Fmoney%2Ftheme%2Fadpportal1.css:568

Modified by bmh4d0k3n

Jellovator 0 solutions 1 answers

Helpful Reply

I am an IT tech and have had many users complain about this same issue, which started happening around the time of the Firefox v23 or later update. Users who are still on v22 do not have this issue.

To solve this, open Firefox and go to Options. Select the Applications section. There should be 3 or 4 options for "Adobe Acrobat xxxx" and another option for "Portable Document Format (pdf)". You will need to change the Action from "Use Adobe Acrobat in Firefox" to "Use Adobe Reader".

This will allow you to view the embedded pdf statements properly.

I am an IT tech and have had many users complain about this same issue, which started happening around the time of the Firefox v23 or later update. Users who are still on v22 do not have this issue. To solve this, open Firefox and go to Options. Select the Applications section. There should be 3 or 4 options for "Adobe Acrobat xxxx" and another option for "Portable Document Format (pdf)". You will need to change the Action from "Use Adobe Acrobat in Firefox" to "Use Adobe Reader". This will allow you to view the embedded pdf statements properly.
jscher2000
  • Top 10 Contributor
3980 solutions 34753 answers

Hi Jellovator, thank you for that insight. The mixed content blocker went live in Firefox 23. It's odd that a site like ADP would have a mixed content problem with PDFs, but perhaps it is caused by some content pulled in by the PDF itself.

  • For users who need a more step-by-step description of how to change your PDF viewer to an external viewer such as the Adobe Reader application, see this support article: How to disable the built-in PDF viewer and use another viewer. Unfortunately this is a global setting and can't be varied on a site-by-site basis.
Hi Jellovator, thank you for that insight. The mixed content blocker went live in Firefox 23. It's odd that a site like ADP would have a mixed content problem with PDFs, but perhaps it is caused by some content pulled in by the PDF itself. * For users who need a more step-by-step description of how to change your PDF viewer to an external viewer such as the Adobe Reader application, see this support article: [[How to disable the built-in PDF viewer and use another viewer]]. Unfortunately this is a global setting and can't be varied on a site-by-site basis. * About the mixed content blocking feature: [[How does content that isn't secure affect my safety?]]
ajg617 0 solutions 1 answers

Helpful Reply

I had the same problem - started with Firefox 23. If I log in to adp portal at https://portal.adp.com/public/index.htm and try to click on a single pay stub, all pay stubs become highlighted and I get a blank page. However, if I log into directly to Ipay at https://ipay.adp.com/iPay/login.jsf (same login and password gets me in), I have no problem viewing my individual stubs. Company says it is a problem with Adobe 11 (which works fine with IE).

I had the same problem - started with Firefox 23. If I log in to adp portal at https://portal.adp.com/public/index.htm and try to click on a single pay stub, all pay stubs become highlighted and I get a blank page. However, if I log into directly to Ipay at https://ipay.adp.com/iPay/login.jsf (same login and password gets me in), I have no problem viewing my individual stubs. Company says it is a problem with Adobe 11 (which works fine with IE).
tmathew98 1 solutions 3 answers

The selection of 'Use Adobe Acrobat (in Firefox) solved my problem with viewing ADP paystubs.

The selection of 'Use Adobe Acrobat (in Firefox) solved my problem with viewing ADP paystubs.