X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 25.0.1 crashes when streaming video

Posted

I open up a video fullscreen in the browser which works for about fifteen minutes until it freezes. Can't escape out of fullscreen and moving the mouse doesn't move the cursor. Completely freezes the computer so I have to switch off the computer. I was able to stream videos just fine for hours before this update occurred. Happens with youtube, giantbomb.com and southparkstudios.com from the few I've tried

I open up a video fullscreen in the browser which works for about fifteen minutes until it freezes. Can't escape out of fullscreen and moving the mouse doesn't move the cursor. Completely freezes the computer so I have to switch off the computer. I was able to stream videos just fine for hours before this update occurred. Happens with youtube, giantbomb.com and southparkstudios.com from the few I've tried

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

Nellus 68 solutions 634 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
12753 solutions 117235 answers

Try to disable hardware acceleration in Firefox.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Helpful Reply

Tried safemode and restarted the browser but still encountered the same problem Did Safemode with hardware acceleration turned off and restarted the browser but still ahd the same problem

I decided to downgrade to 24 and seem to have no problems after an hour of streaming video

Tried safemode and restarted the browser but still encountered the same problem Did Safemode with hardware acceleration turned off and restarted the browser but still ahd the same problem I decided to downgrade to 24 and seem to have no problems after an hour of streaming video
DeepSilver 0 solutions 1 answers

When I found I could play streaming video in Chrome, I knew the problem was not Windows 8.1. It was something else.

I found the problem was I had two versions of flash. When doing the latest update, it did not disable/remove the old one. Hence, conflict. Hence video stopped playing. I disabled the older version. Now Flash works just fine.

Click on Tools/add-ons/plugins.

When I found I could play streaming video in Chrome, I knew the problem was not Windows 8.1. It was something else. I found the problem was I had two versions of flash. When doing the latest update, it did not disable/remove the old one. Hence, conflict. Hence video stopped playing. I disabled the older version. Now Flash works just fine. Click on Tools/add-ons/plugins.