X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 24 opened .doc file in shared Dropbox folder but firefox 25 won't

Posted

Under FF24 I could open and VIEW .doc and .docx files in a shared Dropbox folder. With FF25, I can't and instead I get a weird error message.

There is an Adobe icon and the following text:

Adobe Reader cannot show documents in this browser.

We are sorry, but Adobe Reader is unable to show documents in this browser configuration.

Please use your browser to download this file and open it in Adobe Reader or Adobe Acrobat.

To avoid this message in the future, many browsers provide a way to turn off certain add-ons, and some are able to show this document natively. Please contact your browser vendor for more details.

So why is FF25 trying to use a PDF reader to open a .doc/.docx file?

Post a Reply

Additional System Details

Installed Plug-ins

  • Plugin for Wacom tablets.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.04
  • Shockwave Flash 11.8 r800
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Coupons Inc., Coupon Printing Plugin
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • View PDF documents within your web browser.
  • iPhoto6

Application

  • Firefox 25.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0.1/Darwin/en-US/

Extensions

  • 1Password 3.9.19 (onepassword@agilebits.com)
  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • DoNotTrackMe 2.2.9.618 (donottrackplus@abine.com)
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Forecastfox 2.2.2 ({0538E3E3-7E9B-4d49-8831-A227C80A7AD3})
  • Personas Plus 1.7.3 (personas@christopher.beard)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com) (Inactive)
  • Dashlane 2.1.1.38498 (442718d9-475e-452a-b3e1-fb1ee16b8e9d@dashlane.com) (Inactive)
  • Easy YouTube Video Downloader 7.0 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b}) (Inactive)
  • EPUBReader 1.4.2.1 ({5384767E-00D9-40E9-B72F-9CC39D655D6F}) (Inactive)
  • Flash Block 4.20.13 ({95ab36d4-fb6f-47b0-8b8d-e5f3bd547953}) (Inactive)
  • Ghostery 5.0.6 (firefox@ghostery.com) (Inactive)
  • HTTPS-Everywhere 3.4.2 (https-everywhere@eff.org) (Inactive)
  • PDF Viewer 0.8.649 (uriloader@pdf.js) (Inactive)
  • Rapportive 1.4.0.1 (rapportive@rapportive.com) (Inactive)
  • WOT 20131030 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6741
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6750M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage: http://www.doonesbury.com/strip
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • dom.disable_open_during_load: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • font.internaluseonly.changed: True
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • network.http.max-persistent-connections-per-server: 18
  • network.image.imageBehavior: 0
  • places.database.lastMaintenance: 1384710713
  • places.history.expiration.transient_current_max_pages: 104858
  • places.last_vacuum: 1343935653
  • plugin.disable_full_page_plugin_for_types: application/vnd.fdf
  • plugin.importedState: True
  • plugin.state.dashlane: 0
  • plugin.state.pdf browser plugin: 2
  • plugin.state.silverlight: 0
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.OCSP.signingCA: Builtin Object Token:IPS CLASE1 root
  • security.OCSP.URL:
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1383263226

Misc

  • User JS: No
  • Accessibility: No
Steve 7 solutions 53 answers

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Was this helpful to you? 0
Reply

Question owner

The only 2 marked as "Update Now" were the Java and Flash plug-ins. Please tell me WHICH plug-in is required to open up MS Word .doc & .docx files (read-only) as I don't see any listed in my plug-ins folder. Also, please tell me why I didn't have a problem with FF24. Last, do you have any idea as to why FF25 is trying to use a PDF plug-in to open NON-PDF files?

Was this helpful to you? 0
Reply

Question owner

I've done some searching and with this plug-in disabled, I'm asked to install it to open .doc & .docx files in FF25:

Adobe Acrobat NPAPI Plug-in

According to the plug-in info, this plug-in is for the following MIME types:

application/vnd.adobe.pdf (Acrobat Portable Document Format: pdf), application/vnd.adobe.pdfxml (Acrobat XML Portable Document Format: pdfxml), application/vnd.adobe.x-mars (Acrobat XML Portable Document Format: mars), application/vnd.adobe.xdp+xml (XML Data Package: xdp), application/vnd.fdf (Acrobat Forms Data Format: fdf), application/vnd.adobe.xfd+xml (FormFlow99 Data File: xfd), application/pdf (Acrobat Portable Document Format: pdf), application/vnd.adobe.xfdf (Acrobat Forms Data Format in XML: xfdf)

What I DON'T see is any reference to .doc/.docx file types, so why is the plug-in being asked for?

Was this helpful to you? 0
Reply

Question owner

Well, yesterday, on a whim, I again DISABLED the Adobe Acrobat NPAPI Plug-in, and all of a sudden I can open .doc files in Firefox again! Really weird. Before I was being asked to install this already-installed plug-in to open the files; when I did re-install it, I was told it COULDN'T open the files. Looks like it is time to completely purge Adobe from my iMac.

Was this helpful to you? 1
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.