Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mac Firefox 25 hangs when i open site?

  • 10 replies
  • 8 have this problem
  • 572 views
  • Last reply by cjlpa

more options

I have used web font on my website, which is worked on previous version of Firefox(24), even latest version of nightly firefox.

last week, I have updated my Firefox to 25, After that i'm not able to open my website from Firefox, which hangs at time loading. URL of website - http://www.vdrlawassociates.com/

@font-face { font-family:'karla-regular'; src: url('../fonts/karla-regular.woff') format('truetype'),url('../fonts/karla-Regular.eot?#iefix') format('eot'), url('../fonts/karla-Regular.ttf') format('ttf'), url('../fonts/karla-Regular.svg') format('svg'); }

Chosen solution

we have removed font-face and font-family from style sheet and used google font api.

<link href="//fonts.googleapis.com/css?family=Karla:400italic,400,700italic,700" rel="stylesheet" type="text/css"> <style>

   body {font-family:"Karla"; }

</style>

Read this answer in context 👍 0

All Replies (10)

more options

This website loads on my Firefox program fine.


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back soon.

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

more options

Thanks for reply.

I have tried clearing cache and Cookie for my Firefox , But this will not cause this issue. This issue is specific to Mac and Firefox 25, not other OS.

If i remove my webfont from stylesheet , I'm able to see My website. Its specific to Web font as well

Modified by Game

more options

Mac Firefox 25 crash report here

more options

Chosen Solution

we have removed font-face and font-family from style sheet and used google font api.

<link href="//fonts.googleapis.com/css?family=Karla:400italic,400,700italic,700" rel="stylesheet" type="text/css"> <style>

   body {font-family:"Karla"; }

</style>

more options

We are glad to here that you have solved your Firefox issue.
Thank you using the Mozilla support forum.
We hope that you will continue to browse with us here on Mozilla Firefox.

more options

This seems like a workaround as opposed to a solution. Is the underlying problem, which started with Firefox 25, being addressed at this time?

more options

This problem is not present in upcoming version. it may be addressed on upcoming version.

http://nightly.mozilla.org/

more options

I wrote about this in another thread, but in case anybody comes a-searchin', I believe this issue is related to:

https://bugzilla.mozilla.org/show_bug.cgi?id=906704

It would appear that the combination of absolute positioning, "synthetic" bolding, web fonts, and rotating triggers an infinite loop in Firefox 25. I was able to create a temporary workaround by just removing the bolding on my site.

The issue is supposed to be fixed (as OP mentioned) in the upcoming version.

more options

Same problem with FF 26 on OS X 10.9.1

Funny thing is, it's not the CSS that actually hangs Firefox, it's the rendering of the (a) font. Pages that don't make use of that specific font work fine.

Disabling gfx.downloadable_fonts.enabled did not help.

Page works fine in IE and Chrome.