Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to manage search engines, pressing ok do nothing!

  • 12 replies
  • 11 have this problem
  • 2719 views
  • Last reply by cor-el

more options

I have a list of about 15 search engines added to search bar (all usual and famous sites), but somehow suddenly i've been unable to organize them or even change order of them. when i select manage search engines from the drop down menu of search bar the options window opens ok. next, if i change the order or remove or even press restore defaults then the ok button will never save this new settings or close the window and nothing to do other than to press cancel.

after some tries i found that changing order of some engines works ok. i tried everything and i don't want to lose my firefox profile it has a lot of hard work.

Modified by ayhkas

Chosen solution

What a coincidence Vallovic I found the solution today and i was going to report what the problem is.

It's all caused by an add-on called "keyword.url hack" https://addons.mozilla.org/en-US/firefox/addon/keywordurl-hack/ It resolves the most unbelievable change by Mozilla when they destroyed the address bar independent search engine. unfortunately i need this add-on hard so I'm gonna stick with the same workaround you mentioned to solve this issue.

I've wrote a review on the add-on page reporting the problem. If you are not a user of it check your add-ons one by one until you find out the bugy one.

good luck.

Read this answer in context 👍 0

All Replies (12)

more options
more options

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

more options

Deleting search files didn't change a thing. In a new profile there were about 5 search engines and everything was ok about managing them.

Modified by ayhkas

more options

If you still have the old profile then try to rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value to see if that helps.

more options

of course i have the old profile, actually the problem is i can't give up on it.

I'll try deleting these files but i'm confused about losing or breaking my addons and some manually configured tweaks if i deleted prefs.js. i'll backup and try, thanks for helping.

more options

I don't know if you already solved this bug or not, since two weeks have passed since your last post, but I was having this same problem and found a workaround.

Searching for a solution for my (and yours) problem, I've found some threads, including this one, and tried a few things and since, like you, I wasn't willing to create a new profile, I've tried the following and it worked:


1. Start Firefox in Safe Mode.

2. Organize your search engines.

3. Hit OK and restart Firefox.

4. Voilá, all working and ordered like it should.


Hope it helps you and/or someone who comes to this thread to find an answer to this problem.

Modified by vallovic

more options

Chosen Solution

What a coincidence Vallovic I found the solution today and i was going to report what the problem is.

It's all caused by an add-on called "keyword.url hack" https://addons.mozilla.org/en-US/firefox/addon/keywordurl-hack/ It resolves the most unbelievable change by Mozilla when they destroyed the address bar independent search engine. unfortunately i need this add-on hard so I'm gonna stick with the same workaround you mentioned to solve this issue.

I've wrote a review on the add-on page reporting the problem. If you are not a user of it check your add-ons one by one until you find out the bugy one.

good luck.

Modified by ayhkas

more options

It's funny, because I use that add-on too, so it's definitely it. It's such a strange bug that I don't even tried to disable only the add-ons, I always thought that it was a Firefox problem - and it kinda is, because if they didn't have removed the URL behaviour, which comes from since I don't know when (I use Firefox almost since its first release), the add-on wouldn't need to exist and break the search engines manager. :P

Well, the solution is found and it's all that matters for now. Let's enjoy our Firefox again.

more options

As an alternative you can look at the Keyword Search extension to see if that also has this problem.

You can specify in the Options of the Keyword Search extension in "Firefox/Tools > Add-ons > Extensions" which search engine to use for the location bar and which search engine to use for the about:home page.

more options

Thanks cor-el, I've tried keyword search before, I think it's not a good addon, specially for me as an Arabic language user it was full of bugs. keyword hack brings the original behavior of old address bar.

more options

I have the same problem too: suddenly all my search bars are stuck in alphabetical order. Trying to rearrange either i) fails: (the "ok" button to accept changes doesn't do anything); or ii) the order can be changed but resets to alphabetical order on restarting firefox.

I've tried all the solutions mentioned: rearranging in safe mode, deleting files from the prfile folder, etc, but nothing works.

Pleae help.

more options

You can try these steps if you haven't done this yet:

Rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.

Delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.