Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

my browser automatically opens previous session, why

  • 16 replies
  • 3 have this problem
  • 838 views
  • Last reply by kobe

more options

My browser does not open to my home page anymore. When I open my browser it automatically opens to the previous session. This has been happening since I updated my Java. How can I fix this.

Chosen solution

You can delete this file if you have done this yet.

These are all entries added by an extension (delta) that is considered malware. If you still have this extension then you should remove it.

You can check the about:addons page (Firefox/Tools > Add-ons > Extensions) for suspicious extensions that you didn't install from the Mozilla Add-ons website yourself.

Read this answer in context 👍 0

All Replies (16)

more options

try resetting your homepage and tell me the results.

  • how to change your homepage
  1. Firefox tab
  2. Options
  3. then options again
  4. and under the general tab their should be a field where you enter your homepage

Modified by user991771

more options

I did that before asking the question and it didn't help at all. If I reset my browser would I have to install all my toolbars and addons?

more options

it shouldn't unless you check the box in the uninstaller.

more options

You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.


The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

more options

Cor-el how do i change that? i tried to go to the page you suggested and i don't have an account and it won't let me create an account just keeps suggesting that i log in to make changes. it does say that i have a user.js file. user_pref("browser.sessionstore.resume_session_once", true); now if i am understanding this right it should only do it once but is doing it every time.

more options

You need to make the changes to a file on your computer and not to the mozillaZine knowledge base article.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Note that Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see a name without file extension.
You can see the real file extension (type) if you open the Properties of the file via the right-click context menu.

more options

i am not a programer so most of this is chinese to me. i have tried to get where you are saying but it appears that i am doing something wrong. can you send me step by step instructions on what i need to do please. i'm going crazy here trying to figure this out with absolutely no luck. thanks.

more options

Did you manage to open the Firefox profile folder by clicking this button?

more options

yes i have it open

more options

Is there a user file in that folder showing that is a JSCRIPT file if you check the Properties via the right-click context menu?

more options

yes there is a user file

more options

You can delete this user.js file as this file shouldn't be there.

You can open this file in a text editor (Notepad) via "Open with" in the right-click context menu (do not double-click) to check its content and post it in a next reply.

more options

do i delete this folder before doing anything to it?

user_pref("extensions.delta.tlbrSrchUrl", ""); user_pref("extensions.delta.id", "7c4e86d4000000000000e006e663d88e"); user_pref("extensions.delta.appId", "{C26644C4-2A12-4CA6-8F2E-0EDE6CF018F3}"); user_pref("extensions.delta.instlDay", "15967"); user_pref("extensions.delta.vrsn", "1.8.24.6"); user_pref("extensions.delta.vrsni", "1.8.24.6"); user_pref("extensions.delta.vrsnTs", "1.8.24.619:34:12"); user_pref("extensions.delta.prtnrId", "delta"); user_pref("extensions.delta.prdct", "delta"); user_pref("extensions.delta.aflt", "babsst"); user_pref("extensions.delta.smplGrp", "none"); user_pref("extensions.delta.tlbrId", "base"); user_pref("extensions.delta.instlRef", "sst"); user_pref("extensions.delta.dfltLng", "en"); user_pref("extensions.delta.excTlbr", false); user_pref("extensions.delta.ffxUnstlRst", true); user_pref("extensions.delta.admin", false); user_pref("extensions.delta_i.babTrack", "affID=119794&tsp=5010"); user_pref("extensions.delta_i.babExt", ""); user_pref("extensions.delta_i.srcExt", "ss"); user_pref("extensions.delta.autoRvrt", "false"); user_pref("extensions.delta.rvrt", "false"); user_pref("extensions.delta.newTab", false); user_pref("browser.sessionstore.resume_session_once", true);

more options

i changed this entry to false and then deleted it and it worked. firefox opens like it should again. thank you so much for all your help.

more options

Chosen Solution

You can delete this file if you have done this yet.

These are all entries added by an extension (delta) that is considered malware. If you still have this extension then you should remove it.

You can check the about:addons page (Firefox/Tools > Add-ons > Extensions) for suspicious extensions that you didn't install from the Mozilla Add-ons website yourself.

more options