X
Tap here to go to the mobile version of the site.

Support Forum

Why doesn't right-clicking an individual bookmark create a context menu, when it's in a folder on the bookmark bar?

Posted

When I have a folder of bookmarks in my bookmarks bar, the bookmarks in the folder don't respond at all to right-clicking - this means I can't edit or delete them without moving them out of the folder. Is this normal? If not, is it fixable?

When I have a folder of bookmarks in my bookmarks bar, the bookmarks in the folder don't respond at all to right-clicking - this means I can't edit or delete them without moving them out of the folder. Is this normal? If not, is it fixable?

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Version 4.8.2.15856
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Shockwave Flash 11.9 r900
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).

Application

  • Firefox 25.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0/Darwin/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x fd8
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GT 640M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332
  • browser.startup.homepage: https://eu2.salesforce.com/home/home.jsp
  • browser.startup.homepage_override.buildID: 20131025151332
  • browser.startup.homepage_override.mstone: 25.0
  • browser.tabs.autoHide: True
  • browser.tabs.loadInBackground: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1383314242
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1382482377

Misc

  • User JS: No
  • Accessibility: No
Wesley Branton 180 solutions 2271 answers

This is not a normal thing for Firefox to do.


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

This is not a normal thing for Firefox to do. ------------------ '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' Please report back soon.
petin 0 solutions 2 answers

I have the same issue and neither of the Safe Mode or the Firefox Reset solved my problem - if I have a bookmark in a folder, I can't right-click on it ...(MAC - Mavericks)

I have the same issue and '''neither of the Safe Mode or the Firefox Reset solved my problem''' - if I have a bookmark in a folder, I can't right-click on it ...(MAC - Mavericks)
mohammed.samad 17 solutions 233 answers

backup bookmarks reset firefox or reinstall restore bookmarks this fixes the issue

backup bookmarks reset firefox or reinstall restore bookmarks this fixes the issue
petin 0 solutions 2 answers

a did reset, and reinstall but neither helped

a did reset, and reinstall but neither helped

Helpful Reply

I also tried safe mode and it didn't change anything (and I don't have any extensions or addons installed).

I tried backing up and restoring my bookmarks a couple times, also no difference.

I also tried safe mode and it didn't change anything (and I don't have any extensions or addons installed). I tried backing up and restoring my bookmarks a couple times, also no difference.
Wesley Branton 180 solutions 2271 answers

@petin
I recommend creating your own thread with the details of your operating system. Please post the link when you have done so.


@justzisguyuknow
Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

<b>@petin</b><br> I recommend creating your own thread with the details of your operating system. Please post the link when you have done so. --------------------------- <b>@justzisguyuknow</b><br> Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/faq/?qid=208283363 TDSSKiller - AntiRootkit Utility] * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Did this fix your problems? Please report back to us!
Wesley Branton 180 solutions 2271 answers

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back soon.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back soon.
Wesley Branton 180 solutions 2271 answers

Does this issue occur on another Firefox profile?

Does this issue occur on another Firefox profile?
cor-el
  • Top 10 Contributor
  • Moderator
12329 solutions 114053 answers

On Mac you can make the modification in the Bookmarks Manager (Library) in the Details pane at the bottom right or possibly in the Bookmarks sidebar via the right-click context menu.

On Mac you can make the modification in the Bookmarks Manager (Library) in the Details pane at the bottom right or possibly in the Bookmarks sidebar via the right-click context menu. *https://support.mozilla.org/kb/how-do-i-use-bookmarks
coriander 0 solutions 1 answers

I have this issue, too. And I have tried all the methods recommended above, but none of it resolve this issue for me. I also create my own thread with the details of my OS environment. The link to my thread -- https://support.mozilla.org/en-US/questions/982100

I have this issue, too. And I have tried all the methods recommended above, but none of it resolve this issue for me. I also create my own thread with the details of my OS environment. The link to my thread -- https://support.mozilla.org/en-US/questions/982100