X
Tap here to go to the mobile version of the site.

Support Forum

How do I DISABLE 'Restore previous session'??

Posted

Suddenly, Firefox is remembering tabs after I exit. I do not want this 'feature'. In preferences, I have "When Firefox starts" set to 'Show my home page'. Also, the "Restore previous tabs" option under the History menu is disabled (no ckeckmark next to it).

Why is this suddenly happening and how do I disable it?

Using: Windows 7 Firefox 24.0

Thanks.

Suddenly, Firefox is remembering tabs after I exit. I do not want this 'feature'. In preferences, I have "When Firefox starts" set to 'Show my home page'. Also, the "Restore previous tabs" option under the History menu is disabled (no ckeckmark next to it). Why is this suddenly happening and how do I disable it? Using: Windows 7 Firefox 24.0 Thanks.

Chosen solution

Those lines shouldn't be there and the setting the browser.sessionstore.resume_session_once pref to true will make Firefox restore the previous session automatically on every start, so you need the delete this user.js file as this file shouldn't be there.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • 5.1.20913.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Sling Player Plug-In for Mozilla
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • Coupons, Inc. Coupon Printer Plugin
  • Logitech Harmony Remote Plugin
  • npapicomadapter
  • npmnqmp 989898989877
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • ColorfulTabs 21.1 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • Move Media Player 7 (moveplayer@movenetworks.com)
  • Norton Toolbar 2013.4.4.3 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection 12.0.3.2 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • RealDownloader 1.3.3 ({DF153AFF-6948-45d7-AC98-4FC4AF8A08E2})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WebSlingPlayer 1.5.15.770 ({9EB34849-81D3-4841-939D-666D522B889A})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-10-2012
  • driverDate2:
  • driverVersion: 8.15.10.2622
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.history_expire_days.mirror: 180
  • browser.history_expire_days_min: 2
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.search.suggest.enabled: False
  • browser.search.useDBForOrder: True
  • browser.sessionstore.resume_from_crash: False
  • browser.startup.homepage: https://login.yahoo.com/config/login_verify2?&.src=ym&.intl=us
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.default.x-western: sans-serif
  • font.name.monospace.x-western: MS Sans Serif
  • font.name.sans-serif.x-western: Microsoft Sans Serif
  • font.name.serif.x-western: MS Sans Serif
  • font.size.fixed.x-western: 16
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • keyword.URL:
  • network.cookie.prefsMigrated: True
  • network.protocol-handler.warn-external.dnupdate: False
  • places.database.lastMaintenance: 1383042197
  • places.history.expiration.transient_current_max_pages: 98743
  • places.last_vacuum: 1330093340
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npdeployjava: 0
  • plugin.state.npwlpg: 0
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.cpd.cache: False
  • privacy.cpd.cookies: False
  • privacy.cpd.formdata: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • security.warn_viewing_mixed.show_once: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1382350828

Misc

  • User JS: Yes
  • Accessibility: No
mohammed.samad 17 solutions 233 answers

configuring session restore

By default, when Firefox starts, a single window is opened, displaying your specified home page. If you wish, you can configure Firefox to open all windows and tabs from your previous session:

   Startup Options - Win 
   At the top of the Firefox window, click on the Firefox button and then select Options
   Select the General panel.
   From the When Firefox starts drop-down, select Show my windows and tabs from last time.
   Click OK to close the Options window 

Privacy issues

Session Restore may keep you logged in to sites that you were logged into before you closed Firefox. If someone else used your computer after you, they could access your account on these sites. If this is a concern then you should not configure Firefox to open all windows and tabs from your previous session.

You may also wish to disable the Session Restore crash recovery feature which is enabled by default. This will prevent restoring a previous session when Firefox is opened after an unexpected close or software crash:

   In the Location bar, type about:config and press Enter.
       The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page. 
   In the Search box at the top, type browser.sessionstore.resume_from_crash.
   In the resulting grid, double-click on browser.sessionstore.resume_from_crash to set it to false. 

Troubleshooting Previous session not correctly closed

To get your tabs and windows back from a previous session, you should close Firefox from the menu: At the top of the Firefox window, click on the Firefox button and then select Exit If you close each window or tab, only the tabs in the final window that you close are available when you restart Firefox. Settings may be incorrect

For other session restore problems, you may need to make corrections to your Firefox settings:

   At the top of the Firefox window, click on the Firefox button and then select Options
   Select the Privacy panel and make sure Firefox will: is set to either Remember history or Use custom settings for history.
       If Firefox will: is set to Use custom settings for history then make sure that Permanent Private Browsing mode is not selected.
       If Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, then click the Settings button and make sure that Browsing History is not selected. 
   Click OK to close the Options window
configuring session restore By default, when Firefox starts, a single window is opened, displaying your specified home page. If you wish, you can configure Firefox to open all windows and tabs from your previous session: Startup Options - Win At the top of the Firefox window, click on the Firefox button and then select Options Select the General panel. From the When Firefox starts drop-down, select Show my windows and tabs from last time. Click OK to close the Options window Privacy issues Session Restore may keep you logged in to sites that you were logged into before you closed Firefox. If someone else used your computer after you, they could access your account on these sites. If this is a concern then you should not configure Firefox to open all windows and tabs from your previous session. You may also wish to disable the Session Restore crash recovery feature which is enabled by default. This will prevent restoring a previous session when Firefox is opened after an unexpected close or software crash: In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page. In the Search box at the top, type browser.sessionstore.resume_from_crash. In the resulting grid, double-click on browser.sessionstore.resume_from_crash to set it to false. Troubleshooting Previous session not correctly closed To get your tabs and windows back from a previous session, you should close Firefox from the menu: At the top of the Firefox window, click on the Firefox button and then select Exit If you close each window or tab, only the tabs in the final window that you close are available when you restart Firefox. Settings may be incorrect For other session restore problems, you may need to make corrections to your Firefox settings: At the top of the Firefox window, click on the Firefox button and then select Options Select the Privacy panel and make sure Firefox will: is set to either Remember history or Use custom settings for history. If Firefox will: is set to Use custom settings for history then make sure that Permanent Private Browsing mode is not selected. If Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, then click the Settings button and make sure that Browsing History is not selected. Click OK to close the Options window

Helpful Reply

Your reply said: By default, when Firefox starts, a single window is opened, displaying your specified home page. If you wish, you can configure Firefox to open all windows and tabs from your previous session: (etc.)

The problem is, I have Show my home page' in the Options drop-down setting and it STILL opens displaying the previous pages I was on.

Why is this setting failing to open my specific home page?

Your reply said: ''By default, when Firefox starts, a single window is opened, displaying your specified home page. If you wish, you can configure Firefox to open all windows and tabs from your previous session: (etc.)'' The problem is, I have '''Show my home page'''' in the Options drop-down setting and it STILL opens displaying the previous pages I was on. Why is this setting failing to open my specific home page?
cor-el
  • Top 10 Contributor
  • Moderator
12739 solutions 117078 answers

You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true. *http://kb.mozillazine.org/browser.sessionstore.resume_session_once You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Mohammed and cor-el, thanks for your attempts to help me.

Cor-el, I checked the user.js file, and the setting is already set to "true". Below is the contents of my user.js file. (The very strange thing is that this behavior just started happening suddenly, yesterday afternoon. Prior to that, everything was behaving normally!)

My user.js file:

user_pref("network.protocol-handler.warn-external.dnupdate", false);user_pref("network.protocol-handler.warn-external.dnupdate", false);user_pref("network.protocol-handler.warn-external.dnupdate", false); user_pref("browser.sessionstore.resume_from_crash", false); user_pref("browser.sessionstore.resume_session_once", true);

Mohammed and cor-el, thanks for your attempts to help me. Cor-el, I checked the user.js file, and the setting is already set to "true". Below is the contents of my user.js file. (The very strange thing is that this behavior just started happening suddenly, yesterday afternoon. Prior to that, everything was behaving normally!) '''My user.js file:''' user_pref("network.protocol-handler.warn-external.dnupdate", false);user_pref("network.protocol-handler.warn-external.dnupdate", false);user_pref("network.protocol-handler.warn-external.dnupdate", false); user_pref("browser.sessionstore.resume_from_crash", false); user_pref("browser.sessionstore.resume_session_once", true);
cor-el
  • Top 10 Contributor
  • Moderator
12739 solutions 117078 answers

Chosen Solution

Those lines shouldn't be there and the setting the browser.sessionstore.resume_session_once pref to true will make Firefox restore the previous session automatically on every start, so you need the delete this user.js file as this file shouldn't be there.

Those lines shouldn't be there and the setting the browser.sessionstore.resume_session_once pref to true will make Firefox restore the previous session automatically on every start, so you need the delete this user.js file as this file shouldn't be there.

Question owner

cor-el, THANK YOU! Deleting the user.js file did the trick!

cor-el, THANK YOU! Deleting the user.js file did the trick!