X
Tap here to go to the mobile version of the site.

Support Forum

how to activate lightbeam

Posted

I downloaded and installed the Lightbeam add-on but how do you use or activate it?

I downloaded and installed the Lightbeam add-on but how do you use or activate it?

Chosen solution

Actually I too had this problem, until I figured out that the way to "open" Lightbeam is by displaying the menu bar (Press Alt key), and you will find it under the Tools Menu -> Show Lightbeam. See pic below.

Hope this helps

Thanks, Ravi

Read this answer in context 52

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • Windows Activation Technologies Plugin for Mozilla
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

jdbazagaruiz 0 solutions 4 answers

Hello,

Lightbeam is an add-on that allows you to monitor how third parties track and share your data as you visit the web. So, as you surf in the web Lightbeam will gather information that will be represented graphically. By reading the legend below (I draw a red line around them) the main black screen you can know about the different indicators shown:

- CIRCLES are sites that you have actually visited (the most popular sites have a logo, such as google, twitter or firefox)

- TRIANGLES are sites that are tracking you somehow. I have draw some light blue arrows to point them out.

- LINES show the links between the sites you have actually visited and those that are tracking you without having visited them

That is all about the basic use of it. There are some more options related to time and detail about the places listed (like the url of each one), which are located in the column to the left.

Hope it helps. Feel free to reply if you have more questions.

Hello, Lightbeam is an add-on that allows you to monitor how third parties track and share your data as you visit the web. So, as you surf in the web Lightbeam will gather information that will be represented graphically. By reading the legend below (I draw a '''red line''' around them) the main black screen you can know about the different indicators shown: - CIRCLES are sites that you have actually visited (the most popular sites have a logo, such as google, twitter or firefox) - TRIANGLES are sites that are tracking you somehow. I have draw some light blue arrows to point them out. - LINES show the links between the sites you have actually visited and those that are tracking you without having visited them That is all about the '''basic use''' of it. There are some more options related to time and detail about the places listed (like the url of each one), which are located in the column to the left. Hope it helps. Feel free to reply if you have more questions.

Modified by jdbazagaruiz

ravim77 1 solutions 1 answers

Chosen Solution

Actually I too had this problem, until I figured out that the way to "open" Lightbeam is by displaying the menu bar (Press Alt key), and you will find it under the Tools Menu -> Show Lightbeam. See pic below.

Hope this helps

Thanks, Ravi

Actually I too had this problem, until I figured out that the way to "open" Lightbeam is by displaying the menu bar (Press Alt key), and you will find it under the Tools Menu -> Show Lightbeam. See pic below. Hope this helps Thanks, Ravi
jdbazagaruiz 0 solutions 4 answers

Helpful Reply

That's right Ravi. You might also access Lightbeam by clicking the bottom-right button that is shown in the picture:

Thanks for your help

That's right ''Ravi''. You might also access Lightbeam by clicking the bottom-right button that is shown in the picture: Thanks for your help
ilyavg 0 solutions 5 answers

I have a similar problem, only I do not have anything in the right click menu and not in the corner of the browser. I am on a mac, maybe there is a different way to do it there?

I have a similar problem, only I do not have anything in the right click menu and not in the corner of the browser. I am on a mac, maybe there is a different way to do it there?

Modified by ilyavg

jdbazagaruiz 0 solutions 4 answers

Hi ilyavg,

I am not a Mac user, but let's see if you checked several things:

1) Open and select Firefox, then click alt+T and select Show Lightbeam.

2) If Show Lightbeam doesn't appear, select add-ons in the same menu, or use the shortcut crtl+shift+a. A new tab will appear, the add-ons Manager, you have to click in the Extensions tab. If you already installed Lightbeam, it should appear there, with a button that allows you to enable/disable it. Make sure that it is enabled.

Let us know how it goes.

Hi '''ilyavg''', I am not a Mac user, but let's see if you checked several things: 1) Open and select Firefox, then click ''alt+T'' and select '''Show Lightbeam'''. 2) If '''Show Lightbeam''' doesn't appear, select '''add-ons''' in the same menu, or use the shortcut ''crtl+shift+a''. A new tab will appear, the '''add-ons Manager''', you have to click in the '''Extensions''' tab. If you already installed Lightbeam, it should appear there, with a button that allows you to enable/disable it. Make sure that it is enabled. Let us know how it goes.

Modified by jdbazagaruiz

ilyavg 0 solutions 5 answers

Dear jdbazagaruiz,

As you can see from the attached screenshots i have checked all the things you mention. I am assumint alt-T is the tools menu, and there is no "SHOW LIGHTBEAM" option, also in the addon menu it is both installed and enabled...

Dear jdbazagaruiz, As you can see from the attached screenshots i have checked all the things you mention. I am assumint alt-T is the tools menu, and there is no "SHOW LIGHTBEAM" option, also in the addon menu it is both installed and enabled...
Karen53 0 solutions 6 answers

I am having a different problem. I can see Lightbeam. I have a little icon on my toolbar. But it just doesn't do anything. It will show that I have connected with x amount of websites at the top but when I click on graph or clock there is no visualization at all. In fact nothing is clickable. I have NoScript. Could that be interfering with it somehow? It is not showing any scripts being blocked. Thanks for any help.

I am having a different problem. I can see Lightbeam. I have a little icon on my toolbar. But it just doesn't do anything. It will show that I have connected with x amount of websites at the top but when I click on graph or clock there is no visualization at all. In fact nothing is clickable. I have NoScript. Could that be interfering with it somehow? It is not showing any scripts being blocked. Thanks for any help.
jscher2000
  • Top 10 Contributor
2973 solutions 27673 answers

Hi ilyavg, if you use the Customize feature, can you find the Lightbeam icon and move it to a more useful location? This article describes the steps to do that, and discover whether it is on the Add-on Bar (not displayed in your screen shot) or possibly in the dialog with other unused buttons: Customize Firefox controls, buttons and toolbars.

I'm not sure why it is not appearing on your Tools menu. Do you have any add-ons that let you modify menus? If so, check to see whether it needs to be added there.

Hi ilyavg, if you use the Customize feature, can you find the Lightbeam icon and move it to a more useful location? This article describes the steps to do that, and discover whether it is on the Add-on Bar (not displayed in your screen shot) or possibly in the dialog with other unused buttons: [[Customize Firefox controls, buttons and toolbars]]. I'm not sure why it is not appearing on your Tools menu. Do you have any add-ons that let you modify menus? If so, check to see whether it needs to be added there.
ilyavg 0 solutions 5 answers

Dear jscher2000,

I do not have it in the customize menu (I have looked there previously) it is strange, to say the least. (see the screenshots). Perhaps any other suggestions?

Dear jscher2000, I do not have it in the customize menu (I have looked there previously) it is strange, to say the least. (see the screenshots). Perhaps any other suggestions?
ilyavg 0 solutions 5 answers

Dear Karen53,

I have read somewhere that adblock and ghosterly addons (and other similar blocking addons) interfere with lightbeams ability to track... are you using anything like that? (so it is entirely possible that noscript would cause this problem for you)

Dear Karen53, I have read somewhere that adblock and ghosterly addons (and other similar blocking addons) interfere with lightbeams ability to track... are you using anything like that? (so it is entirely possible that noscript would cause this problem for you)

Modified by ilyavg

Karen53 0 solutions 6 answers

Thank you for the fast response. I just have No Script and I disabled it and restarted Firefox and still no visuals and nothing is clickable. I tried removing and reinstalling Lightbeam and no luck there either. I am getting data at the top but nothing shows in the window nor can I customize anything. Customize link doesn't work. OTOH, I have no problem getting an icon. I checked source code and there are a lot of javascript links that work. So I'm at a loss why I seem to be the only one with this problem. Maybe I'm not since everyone seems to be installing this new version today.

Thank you for the fast response. I just have No Script and I disabled it and restarted Firefox and still no visuals and nothing is clickable. I tried removing and reinstalling Lightbeam and no luck there either. I am getting data at the top but nothing shows in the window nor can I customize anything. Customize link doesn't work. OTOH, I have no problem getting an icon. I checked source code and there are a lot of javascript links that work. So I'm at a loss why I seem to be the only one with this problem. Maybe I'm not since everyone seems to be installing this new version today.
DLS_AZ 0 solutions 4 answers

Is this possibly a 64 Bit issue, I have the same problem. The add-on is installed and enabled, but the 'show' function is not available in the Tools menu of the right click context menu. Does anyone know for sure that Lightbeam works with the latest 64 bit Firefox browser?

Is this possibly a 64 Bit issue, I have the same problem. The add-on is installed and enabled, but the 'show' function is not available in the Tools menu of the right click context menu. Does anyone know for sure that Lightbeam works with the latest 64 bit Firefox browser?
the-edmeister
  • Top 10 Contributor
  • Moderator
3854 solutions 29209 answers

The Lightbeam icon should appear in the lower-right corner on the Add-on Bar which isn't displayed by default. Hit the Firefox button > Options and click on Add-on Bar so that it has a check-mark.

There is no contextual menu item for Lightbeam.

The Lightbeam icon should appear in the lower-right corner on the Add-on Bar which isn't displayed by default. Hit the Firefox button > Options and click on Add-on Bar so that it has a check-mark. There is no contextual menu item for Lightbeam.
James
  • Top 25 Contributor
  • Moderator
619 solutions 4641 answers

DLS_AZ, there is no Win64 Releases of Firefox from Mozilla so either you are using Win32 Firefox on 64-bit Windows or are using a third-party build, built it yourself or Win64 build that is on the unstable Nightly development channel.

'''DLS_AZ''', there is no Win64 Releases of Firefox from Mozilla so either you are using '''Win32 Firefox''' on 64-bit Windows or are using a third-party build, built it yourself or Win64 build that is on the unstable Nightly development channel.
DLS_AZ 0 solutions 4 answers

Yikes, I did this so quickly that I DID install NIGHTLY in error. Removed it, installed the latest 32 bit Firefox + Lightbeam, all is working...

Sorry for the confusion, my misstep and cross posting. I am a newbie here and could not find my way to the new question I posted. Since I did not get an email confirm and could not find the question by searching, I assumed it went to bit heaven.

I will do better next time ...

Good catch James!

Yikes, I did this so quickly that I DID install NIGHTLY in error. Removed it, installed the latest 32 bit Firefox + Lightbeam, all is working... Sorry for the confusion, my misstep and cross posting. I am a newbie here and could not find my way to the new question I posted. Since I did not get an email confirm and could not find the question by searching, I assumed it went to bit heaven. I will do better next time ... Good catch James!
DLS_AZ 0 solutions 4 answers

Well, I though i was good to go, but now that I have Lightbeam up in a tab, i have the same issue as karen53, no visualizations and nothing is click-able.

Suggestions??

Well, I though i was good to go, but now that I have Lightbeam up in a tab, i have the same issue as karen53, no visualizations and nothing is click-able. Suggestions??
ilyavg 0 solutions 5 answers

Hi the-edmeister,

I have the add-on bar open and still I have no lightbeam icon... i am at a complete loss... noone seems to be able to solve my issue...

Hi the-edmeister, I have the add-on bar open and still I have no lightbeam icon... i am at a complete loss... noone seems to be able to solve my issue...
the-edmeister
  • Top 10 Contributor
  • Moderator
3854 solutions 29209 answers

lyavg,

Mac's, PC's, and Linux OS's have slight differences in where some menu items are placed. I am surprised to see a Tools menu on a Mac - I thought that category was called Preferences.

Have you looked completely thru every menu, like in the Web Developer menu under Tools?

As far as not seeing the Add-on Bar icon / button for Lightbeam, have you considered disabling all your other Extensions to see it Lightbeam appears? Maybe another Extension has hidden it?

Can't help you any further, I don't have access to a Mac OSX computer to check out the menu differences between Mac's and PC's.

lyavg, Mac's, PC's, and Linux OS's have slight differences in where some menu items are placed. I am surprised to see a '''Tools''' menu on a Mac - I thought that category was called Preferences. Have you looked completely thru every menu, like in the Web Developer menu under Tools? As far as not seeing the Add-on Bar icon / button for Lightbeam, have you considered disabling all your other Extensions to see it Lightbeam appears? Maybe another Extension has hidden it? Can't help you any further, I don't have access to a Mac OSX computer to check out the menu differences between Mac's and PC's.
Karen53 0 solutions 6 answers

I tried on a different PC and got the same results. I don't know. Maybe you need the special decoder ring. I guess I could try downloading directly and installing from GitHub but it seems a lot to go through if it's an issue that will be fixed soon.

I tried on a different PC and got the same results. I don't know. Maybe you need the special decoder ring. I guess I could try downloading directly and installing from GitHub but it seems a lot to go through if it's an issue that will be fixed soon.
cor-el
  • Top 10 Contributor
  • Moderator
11981 solutions 111345 answers

The Tools menu is the same on all platforms (Mac, Linux, Windows).
The only difference is the place where the Options/Preferences menu entry is found, on Mac is that in "Firefox > Preferences" and not under "Tools > Options" like on Windows or under "Edit > Preferences" on Linux


You can try to disable all other extensions to see if that helps to identify a possible culprit.

The Tools menu is the same on all platforms (Mac, Linux, Windows).<br /> The only difference is the place where the Options/Preferences menu entry is found, on Mac is that in "Firefox > Preferences" and not under "Tools > Options" like on Windows or under "Edit > Preferences" on Linux ---- You can try to disable all other extensions to see if that helps to identify a possible culprit.