X
Tap here to go to the mobile version of the site.

Support Forum

Youtube video not working in firefox.

Posted

Hi everyone,

I'm having problems playing youtube videos on firefox. Yet I don't seem to have any problem playing flash supported videos on other sites, but whenever I try to play a video on youtube all I get a is a black box. Is there any suggestion I didn't have this problem before.

I'am currently using Firefox 24.0 Browser which is upto date, and the plugin I use to watch any flash enabled video is Shockwave Flash 11.9.900.117 r900 .

Hi everyone, I'm having problems playing youtube videos on firefox. Yet I don't seem to have any problem playing flash supported videos on other sites, but whenever I try to play a video on youtube all I get a is a black box. Is there any suggestion I didn't have this problem before. I'am currently using Firefox 24.0 Browser which is upto date, and the plugin I use to watch any flash enabled video is Shockwave Flash 11.9.900.117 r900 .

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.9 r900
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20913.0
  • GEPlugin
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.1.1.94
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Office Live Update v1.3
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Nellus 68 solutions 634 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
12910 solutions 118408 answers

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"
Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Question owner

Hey Nellus91,

I've followed your instructions and i found out which extention was causing me the problem was adblock. Even though it didn't cause any problem previously it suddenly did. I had to change the setting on it to make the videos on youtube work again. But now i'm having to watch those bloody ads again. If there is any solution on making youtube work without the ads please do let me know.

I will also try the sugesstion by cor-el and see if that works too.

Hey Nellus91, I've followed your instructions and i found out which extention was causing me the problem was adblock. Even though it didn't cause any problem previously it suddenly did. I had to change the setting on it to make the videos on youtube work again. But now i'm having to watch those bloody ads again. If there is any solution on making youtube work without the ads please do let me know. I will also try the sugesstion by cor-el and see if that works too.
Nellus 68 solutions 634 answers

Try with NoScript or RequestPolicy

Try with [https://addons.mozilla.org/en-US/firefox/addon/noscript/ NoScript] or [https://addons.mozilla.org/en-US/firefox/addon/requestpolicy/?src=ss RequestPolicy]
Revelations0369 0 solutions 1 answers

I had the same problem. I had to manually disable each plugin. Not just disable it in the options menu. Type "about:addons" in your address bar. it will give you the path to all add ons. go to each path and rename the file it gives you with a "X" in front of it. When all is said and done just install Adobe Flash Player with the link youtube gives you. Or use this link. http://get.adobe.com/flashplayer/. let it install and you problem should be fixed. make sure you dont have any other media player plugins enabled. Good Luck!!!

I had the same problem. I had to manually disable each plugin. Not just disable it in the options menu. Type "about:addons" in your address bar. it will give you the path to all add ons. go to each path and rename the file it gives you with a "X" in front of it. When all is said and done just install Adobe Flash Player with the link youtube gives you. Or use this link. http://get.adobe.com/flashplayer/. let it install and you problem should be fixed. make sure you dont have any other media player plugins enabled. Good Luck!!!