X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This Connection is Untrusted

Posted

I got this message yesterday. I got this message on one of my other PCs quite a while back, and it was a date/time issue, but on this pc that is not the case my date and time are correct. Any help would be very appreciated.


This Connection is Untrusted

You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.


Technical Details

www.google.com uses an invalid security certificate. The certificate is not trusted because no issuer chain was provided. (Error code: sec_error_unknown_issuer)

Chosen solution

Yes because now you can go to google.com directly without going through a proxy server

Read this answer in context 16
Post a Reply

Additional System Details

Installed Plug-ins

  • Google Update
  • VLC media player Web Plugin 2.1.0
  • 5.1.20913.0
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GanymedeNet.Detector
  • Shockwave Flash 10.3 r183
  • Facebook Desktop Plugin
  • Roblox Launcher Plugin
  • WildTangent Games App V2 Presence Detector
  • Facebook Video Calling Plugin
  • MindSpark Toolbar Platform Plugin Stub for 32-bit Windows
  • Yahoo Application State Plugin version 1.0.0.7
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 15.0.2.72
  • NPWLPG
  • npapicomadapter
  • 2.25.1.0 - The WorldWinner plug-in allows you to enjoy online casual games with the thrill of playing for cash and prizes
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Exent® AOD Gecko Plugin
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Aniello 75 solutions 633 answers

see this conversation https://support.mozilla.org/it/questions/929332?esab=a&s=this+connection+is+untrested&r=4&as=s

Modified by Aniello

Was this helpful to you? 24
Reply

Helpful Reply

As far as I know there have been no add ons recently put on the laptop, but I can not be sure as my 13yr old daughter was on it most of the weekend.

I already did a malwarebytes scan on it.

Im not sure what to do or what to look for, and a lot of the computer lingo gets me confused cause I do not know what all of it means =/

Not sure where to go from here!

Was this helpful to you? 16
Reply

Question owner

I just went into "tool...Options, Advanced and then Network" and went into the connections settings and click on the "no proxy" option and it is seeming to load google up just fine now...but my question is what does clicking the no proxy option do?

Was this helpful to you? 14
Reply
Aniello 75 solutions 633 answers

Helpful Reply

Disabling the option does not allow firefox to pass through a proxy server. See here for more information about proxy server: http://en.wikipedia.org/wiki/Proxy_server

Modified by Aniello

Was this helpful to you? 9
Reply

Question owner

With that being said...since doing that seemed to "fix" the problem and it is now letting me go to Google without any problems, is doing that option a suitable fix?

Was this helpful to you? 7
Reply
Aniello 75 solutions 633 answers

Chosen Solution

Yes because now you can go to google.com directly without going through a proxy server

Was this helpful to you? 16
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

What were the previous connection settings before you changed them?

Was there a proxy selected or the default "Use the system proxy settings" ?

Was this helpful to you? 11
Reply
mizzoug 0 solutions 1 answers

I had this problem on FF and also on Chrome. In my case, I was clicking "log in" on Snapfish and the pop up wouldn't load correctly. I would get the security message with no options to move forward anyway. I came upon my solution accidentally. I was going to email Snapfish, so went to Contact Us and then Other Ways to Contact Us, at which point I got a the same error (full page) but this time, there was the option to Proceed Anyway and then Allow. This did it for me and not I can log in regularly. So my suggestion is to find a page on that site that will get the Allow Anyway dialogue to appear and then add the exception that way. Hope this helps.

Was this helpful to you? 4
Reply
mohammadmikaeel 0 solutions 4 answers

this problem when i change my motherbord , Happened. i solved this , by set the time & date in windows & mainbord time in bois . it's fixed.

Was this helpful to you? 10
Reply
tominatorius 0 solutions 1 answers
I have this problem too. I get this prompt for every site. I had a virus on the computer and had to clean it off and have gotten it ever since. My computer date is correct. Help. Thanks. 
Application Basics
------------------
Name: Firefox
Version: 26.0
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Extensions
----------
Name: Buzz-it
Version: 1.150
Enabled: false
ID: {10886a85-c81d-48e0-a17e-106b174c4131}
Name: HP Smart Web Printing
Version: 4.51
Enabled: false
ID: smartwebprinting@hp.com
Name: Media Player
Version: 1.1
Enabled: false
ID: ext@MediaPlayerV1alpha660.net
Name: Webexp Enhanced
Version: 1.1
Enabled: false
ID: ext@WebexpEnhancedV1alpha167.net
Important Modified Preferences
------------------------------
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 358400
browser.places.smartBookmarksVersion: 4
browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
browser.startup.homepage_override.buildID: 20131205075310
browser.startup.homepage_override.mstone: 26.0
extensions.lastAppVersion: 26.0
gfx.direct3d.last_used_feature_level_idx: 1
network.cookie.prefsMigrated: true
places.history.expiration.transient_current_max_pages: 104837
plugin.disable_full_page_plugin_for_types: application/pdf
privacy.sanitize.migrateFx3Prefs: true
Graphics
--------
Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Adapter RAM: Unknown
Device ID: 0x2a42
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7600.16972)
Driver Date: 2-11-2011
Driver Version: 8.15.10.2302
GPU #2 Active: false
GPU Accelerated Windows: 3/3 Direct3D 10
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
JavaScript
----------
Incremental GC: true
Accessibility
-------------
Activated: false
Prevent Accessibility: 0
Library Versions
----------------
NSPR
Expected minimum version: 4.10.2
Version in use: 4.10.2
NSS
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSMIME
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSSL
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSUTIL
Expected minimum version: 3.15.3.1
Version in use: 3.15.3.1

Modified by cor-el

Was this helpful to you? 5
Reply
JacquesBergier 0 solutions 1 answers

My mother had exactly the same problem. I´ve cleaned everything was possible, used PC Tune, all cleansing and wiping tools. Since then, although I don´t know why, no mess...messages about untrusted connections.

Was this helpful to you? 2
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.