X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Auto-hide all toolbars in fullscreen

Posted

When I enter fullscreen mode I'd like all toolbars to auto-hide, and maybe only show when I move my mouse to the top edge, or when I hit Cmd+L or such. Other windows that are not made fullscreen should keep their toolbars in place.

My reason for going fullscreen is to have the entire screen dedicated to the current website / webapp. It's no use getting rid of the OS toolbars if I can't get rid of Firefox ones.

Chrome calls this feature Presentation Mode, it's in the View menu right above Full screen. The latter does not hide toolbars, just like Firefox's. So I guess what Firefox calls "full screen" is actually consistent with that of Chrome, but it lacks Presentation mode. Is there an option or an extension to add it?

Also note that this is very different from the various Kiosk mode extensions. I don't want Firefox to start fullscreen, to limit browsing to the current website, to disable right click and keyboard shortcuts, and all the other limitations put in place by Kiosk mode extensions.

Modified by tobia

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Reader Applicaiton Detector Plugin
  • Displays Java applet content, or a placeholder if Java is not installed.
  • EMusic Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • RealPlayer Plugin
  • 20-20 Technologies - 20-20 3D Viewer for IKEA v5.0.94.0
  • Reader Library Helper Plugin
  • Juniper Networks Safari Extensions

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/Darwin/en-US/

Extensions

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Ghostery 5.0.5 (firefox@ghostery.com)
  • HTTPS Finder 0.87 ({6bdc61ae-7b80-44a3-9476-e1d121ec2238})
  • HTTPS-Everywhere 3.4.2 (https-everywhere@eff.org)
  • RightToClick 2.9.5 ({cd617375-6743-4ee8-bac4-fbf10f35729e})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 116
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.newtab.url: about:blank
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: True
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1382119861
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1382127575

Misc

  • User JS: No
  • Accessibility: No
Aniello 75 solutions 633 answers

You can use full screen mode by pressing F11 on your keyboard. In full screen mode all toolbare are hide and you have the website in a full screen mode.

Question owner

When I press F11, the browser goes fullscreen, but no toolbar is hidden.

That's why I asked this question.

I can try with a blank profile, if you think Firefox (on OS X) should do what you say.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96777 answers

Helpful Reply

You can right-click the toolbar when in full screen mode and set the check-mark on Hide Toolbars (about:config - pref: browser.fullscreen.autohide)

Modified by cor-el

Question owner

I just tried with a blank profile and I confirm that it's not caused by any of my extensions or settings.

cor-el, my context menu on the toolbar, while in full screen, does not have that option. I only see Navigation Toolbar, Bookmarks Toolbar, Add-On Bar, (separator), Tabs on Top, Customize

Modified by tobia

Aniello 75 solutions 633 answers
  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

Searche the string "browser.fullscreen.autohide"

Question owner

That's weird. My setting browser.fullscreen.autohide was already set to true, but it doesn't work. Changing it seems to do nothing. I've entered and exited fullscreen, restarted Firefox… nada.

Modified by tobia

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96777 answers

You can check for problems caused by a corrupted localstore.rdf file.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Question owner

I just tried Safe Mode. Still nothing. The default setting is true, but it doesn't work. I tried changing it back and forth, and going back and forth into fullscreen, but nothing. The toolbars are always shown.

Could it be because I'm on Mac OS X 10.7 Lion, that has its own fullscreen support? (Which Firefox is using since version 14)

If anybody else with OS X Lion or newer can confirm this behaviour, we might have to file it as a bug.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96777 answers

On Mac you would have to use Command+Shift+F to toggle full screen mode.

Question owner

I just tried Command+Shift+F and it triggers the same Full screen mode as the View menu, with this very bug.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96777 answers

You can try to remove the Firefox plist file (org.mozilla.firefox.plist).

Go to "~/Library/Preferences" and remove the plist file for Firefox (org.mozilla.firefox.plist)

Question owner

Nope.

Thanks for all your suggestions though :-)

cxr341 0 solutions 1 answers

I'm having same issue, FF 24.0 and OSX 10.8.5. I go into FS mode via menu option or Shift+Cmd+F and still the tabs, address bar, and bookmark bar remain. Behavior identical in Safe mode. Ensured that browser.fullscreen.autohide = true. No way to hide them.

Defeats purpose of FS mode when I want to block out distractions. Haven't been able to use any of the add-ons to fix this either. Did something break in a recent build?

Question owner

I tried all previous releases of Firefox (actually I did a binary search) and I found out this bug appeared between:

  • Firefox 14.0.1 (en-US, Mac) in which the toolbar would auto-hide on fullscreen; and
  • Firefox 15.0b1 (en-US, Mac) released a few days later, in which the auto-hide did not work anymore.

Both releases had browser.fullscreen.autohide=true as a default setting. I removed the entire Firefox folder in Application Support before launching each release.

This was all tested on the latest OS X 10.9 Mavericks. At my workplace I have access to Macs running most if not all previous OS X releases, so I can perform some tests on them if needed.

Can anybody please page a developer or open a bug report with this information?

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Helpful Reply

There is a bug for this: 740148 – [10.7] Allow hiding toolbars for presentations. Looks like not much activity...

If you hadn't noticed this behavior until recently, perhaps you were using the Old Lion Fullscreen extension as a workaround?

Note on the bug tracking system: If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add comments to bugs, but you can register on the Bugzilla site and "vote" for them to be fixed. See:

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

By the way, it might be possible to use a custom style rule to remove the toolbars in "Lion fullscreen" mode.

I do not have a Mac to experiment with, but on Windows, when you go into full screen, the individual toolbars and the toolbar area (#navigator-toolbox) get the attribute inFullscreen=true. It might be possible to target this area for removal based on that attribute if it's also present on Mac (i.e., so it's only removed when in full screen).

OverZealous 0 solutions 1 answers

Using the suggestion from @jscher2000, I was able to get a fairly complete Stylish modification working.

This hides specific toolbars (in my case, the Personal Toolbar, the Web Developer Toolbar and Googlebar Lite), but re-shows them if you mouse over the toolbar area. It also removes the ~11px of padding at the top that exists for no reason that I can see.

It's easy to add other toolbars, but you need to use the DOM Inspector to inspect the chrome and find their IDs.


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

#main-window[inFullscreen=true] {
    padding-top: 0px !important;
}

#navigator-toolbox[inFullscreen=true]:not(:hover) #PersonalToolbar,
#navigator-toolbox[inFullscreen=true]:not(:hover) #GBL-Toolbar,
#navigator-toolbox[inFullscreen=true]:not(:hover) #web-developer-toolbar,
#navigator-toolbox[inFullscreen=true]:not(:hover) .web-developer-toolbar {
    visibility: collapse;
}

Note: I'm not hiding the tab bar, because I use TreeStyle Tabs, and they autohide already. I believe this was #TabsToolbar or #TabToolbar

Modified by OverZealous